summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-03-01 16:54:56 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-03-01 16:54:56 +0000
commit47253f0b256d82c14628b94ad04802bf2c34b7db (patch)
tree3b95e0481ff590b6a150437fda4053b5db85a1b2 /dev-cpp/poslib
parentinteractive fix (Manifest recommit) (diff)
downloadgentoo-2-47253f0b256d82c14628b94ad04802bf2c34b7db.tar.gz
gentoo-2-47253f0b256d82c14628b94ad04802bf2c34b7db.tar.bz2
gentoo-2-47253f0b256d82c14628b94ad04802bf2c34b7db.zip
Version bumped. #40194.
Diffstat (limited to 'dev-cpp/poslib')
-rw-r--r--dev-cpp/poslib/ChangeLog10
-rw-r--r--dev-cpp/poslib/Manifest4
-rw-r--r--dev-cpp/poslib/files/digest-poslib-1.0.21
-rw-r--r--dev-cpp/poslib/poslib-1.0.2.ebuild26
4 files changed, 38 insertions, 3 deletions
diff --git a/dev-cpp/poslib/ChangeLog b/dev-cpp/poslib/ChangeLog
index be7aa219d2c4..336403ee0de8 100644
--- a/dev-cpp/poslib/ChangeLog
+++ b/dev-cpp/poslib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/poslib
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/ChangeLog,v 1.2 2004/01/04 18:54:49 aliz Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/ChangeLog,v 1.3 2004/03/01 16:51:19 matsuu Exp $
+
+*poslib-1.0.2 (02 Mar 2004)
+
+ 02 Mar 2004; <matsuu@gentoo.org> poslib-1.0.2.ebuild:
+ Version bumped. Bug # 40194.
+ Added ~amd64 to KEYWORDS.
*poslib-1.0.1 (02 Nov 2003)
diff --git a/dev-cpp/poslib/Manifest b/dev-cpp/poslib/Manifest
index 90f1909b4eab..f2338dd4a023 100644
--- a/dev-cpp/poslib/Manifest
+++ b/dev-cpp/poslib/Manifest
@@ -1,4 +1,6 @@
-MD5 db2236865a9147566b0432566c8e9d6b poslib-1.0.1.ebuild 710
MD5 c3f736cef97ea981cc8e5dee714bb85c ChangeLog 333
MD5 ca160035368973903394d90e1506ff21 metadata.xml 566
+MD5 db2236865a9147566b0432566c8e9d6b poslib-1.0.1.ebuild 710
+MD5 1ae9299c35418346e7fd46fa59db4537 poslib-1.0.2.ebuild 717
MD5 a27e94a708d0593be9de871130fbee66 files/digest-poslib-1.0.1 64
+MD5 d26ec63ce97f5c2e14c08762a62ba2f7 files/digest-poslib-1.0.2 64
diff --git a/dev-cpp/poslib/files/digest-poslib-1.0.2 b/dev-cpp/poslib/files/digest-poslib-1.0.2
new file mode 100644
index 000000000000..67ffdb0096ef
--- /dev/null
+++ b/dev-cpp/poslib/files/digest-poslib-1.0.2
@@ -0,0 +1 @@
+MD5 49de55d4f1efc2f1c81912a3bcd7bee7 poslib-1.0.2.tar.gz 255360
diff --git a/dev-cpp/poslib/poslib-1.0.2.ebuild b/dev-cpp/poslib/poslib-1.0.2.ebuild
new file mode 100644
index 000000000000..10192b0358b7
--- /dev/null
+++ b/dev-cpp/poslib/poslib-1.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/poslib-1.0.2.ebuild,v 1.1 2004/03/01 16:51:19 matsuu Exp $
+
+DESCRIPTION="A library for creating C++ programs using the Domain Name System"
+HOMEPAGE="http://www.posadis.org/projects/poslib.php"
+SRC_URI="mirror://sourceforge/posadis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="ipv6"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ econf \
+ --with-cxxflags="${CXXFLAGS} -funsigned-char" \
+ `use_enable ipv6` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}