summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2007-06-10 18:20:23 +0000
committerRémi Cardona <remi@gentoo.org>2007-06-10 18:20:23 +0000
commit846853f748c0af688c6c73a2436dfd0ca5b24ebf (patch)
treea08e14cffdb2df464967de54305cb7556f0f74f9 /dev-cpp/libgtksourceviewmm/libgtksourceviewmm-0.3.1.ebuild
parentAdded ~ppc64 (diff)
downloadgentoo-2-846853f748c0af688c6c73a2436dfd0ca5b24ebf.tar.gz
gentoo-2-846853f748c0af688c6c73a2436dfd0ca5b24ebf.tar.bz2
gentoo-2-846853f748c0af688c6c73a2436dfd0ca5b24ebf.zip
dev-cpp/libgtksourceviewmm: bump to 0.3.1
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-cpp/libgtksourceviewmm/libgtksourceviewmm-0.3.1.ebuild')
-rw-r--r--dev-cpp/libgtksourceviewmm/libgtksourceviewmm-0.3.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-cpp/libgtksourceviewmm/libgtksourceviewmm-0.3.1.ebuild b/dev-cpp/libgtksourceviewmm/libgtksourceviewmm-0.3.1.ebuild
new file mode 100644
index 000000000000..457242c9faa3
--- /dev/null
+++ b/dev-cpp/libgtksourceviewmm/libgtksourceviewmm-0.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgtksourceviewmm/libgtksourceviewmm-0.3.1.ebuild,v 1.1 2007/06/10 18:20:23 remi Exp $
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for gtksourceview"
+HOMEPAGE="http://home.gna.org/gtksourceviewmm/"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+SLOT="0"
+LICENSE="LGPL-2"
+
+RDEPEND=">=dev-cpp/gtkmm-2.4
+ >=x11-libs/gtksourceview-1.2.0"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS ChangeLog* NEWS README TODO"
+
+G2CONF="${G2CONF} $(use_enable doc docs)"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Remove docs from SUBDIRS so that docs are not installed, as
+ # we handle it in src_install.
+ sed -i -e 's|^\(SUBDIRS =.*\)docs\(.*\)|\1\2|' Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_install() {
+ gnome2_src_install
+ use doc && dohtml -r docs/reference/html/*
+}