summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-09-19 12:19:59 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-09-19 12:19:59 +0000
commitbea1b0cf335cb31eaf4b922f9491be36946c591d (patch)
treed7430086fa520c0d3a7a5f6c8c1c804ccb568b7d /dev-cpp/libgnomeuimm/libgnomeuimm-2.12.0.ebuild
parentcrlf fix thanks to James Rowe in bug #106246 (diff)
downloadgentoo-2-bea1b0cf335cb31eaf4b922f9491be36946c591d.tar.gz
gentoo-2-bea1b0cf335cb31eaf4b922f9491be36946c591d.tar.bz2
gentoo-2-bea1b0cf335cb31eaf4b922f9491be36946c591d.zip
Version bump.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-cpp/libgnomeuimm/libgnomeuimm-2.12.0.ebuild')
-rw-r--r--dev-cpp/libgnomeuimm/libgnomeuimm-2.12.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/libgnomeuimm/libgnomeuimm-2.12.0.ebuild b/dev-cpp/libgnomeuimm/libgnomeuimm-2.12.0.ebuild
new file mode 100644
index 000000000000..807c2b20494a
--- /dev/null
+++ b/dev-cpp/libgnomeuimm/libgnomeuimm-2.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgnomeuimm/libgnomeuimm-2.12.0.ebuild,v 1.1 2005/09/19 12:19:59 ka0ttic Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="C++ bindings for libgnomeui"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~hppa"
+IUSE=""
+
+RDEPEND=">=gnome-base/libgnomeui-2.6
+ >=dev-cpp/libgnomemm-2.6
+ >=dev-cpp/libgnomecanvasmm-2.6
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/libglademm-2.4
+ >=dev-cpp/gnome-vfsmm-2.6"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ ${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS INSTALL TODO"
+
+src_compile() {
+ if useq amd64 || useq ppc64; then
+ aclocal -I scripts
+ automake -c -f
+ autoconf
+ libtoolize --copy --force
+ fi
+
+ gnome2_src_compile
+}