summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-11-18 10:36:47 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-11-18 10:36:47 +0000
commit5ee9ff2d575a32a648732350f491f63bbc62ab86 (patch)
tree9c132829bc86b247e69e0e1a5862c95a5ee940d8 /dev-cpp/libebt/files
parentAdding missing libpcre dep wrt bug #155553 (diff)
downloadgentoo-2-5ee9ff2d575a32a648732350f491f63bbc62ab86.tar.gz
gentoo-2-5ee9ff2d575a32a648732350f491f63bbc62ab86.tar.bz2
gentoo-2-5ee9ff2d575a32a648732350f491f63bbc62ab86.zip
Added as-needed patch, bug #155462 thanks to drizzt. Added 'test' USE-flag to track boost-dependency for testing. Dropped old versions.
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'dev-cpp/libebt/files')
-rw-r--r--dev-cpp/libebt/files/digest-libebt-1.3.02
-rw-r--r--dev-cpp/libebt/files/libebt-1.3.0-as-needed.patch32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/libebt/files/digest-libebt-1.3.0 b/dev-cpp/libebt/files/digest-libebt-1.3.0
index d822b6a4acd1..129f043cc106 100644
--- a/dev-cpp/libebt/files/digest-libebt-1.3.0
+++ b/dev-cpp/libebt/files/digest-libebt-1.3.0
@@ -1 +1,3 @@
MD5 4db63470575336e27f89038d7c7cc01e libebt-1.3.0.tar.bz2 144838
+RMD160 ad5def229f6b0166e929b51a0046eab17f744252 libebt-1.3.0.tar.bz2 144838
+SHA256 a375a51295a8417ba2fff8fdc3fefe84d39a56452e5a7345aacd5e0a01cba303 libebt-1.3.0.tar.bz2 144838
diff --git a/dev-cpp/libebt/files/libebt-1.3.0-as-needed.patch b/dev-cpp/libebt/files/libebt-1.3.0-as-needed.patch
new file mode 100644
index 000000000000..7653dab9ce2a
--- /dev/null
+++ b/dev-cpp/libebt/files/libebt-1.3.0-as-needed.patch
@@ -0,0 +1,32 @@
+--- libebt/Makefile.am.orig 2006-11-17 11:44:49.000000000 +0100
++++ libebt/Makefile.am 2006-11-17 11:47:28.000000000 +0100
+@@ -23,17 +23,15 @@
+ the_tests += libebt_boost_threads_TEST
+
+ libebt_boost_threads_TEST_SOURCES = libebt_boost_threads_TEST.cc $(test_headers) $(libinclude_HEADERS)
+-libebt_boost_threads_TEST_LDADD = libebttests.a
+-libebt_boost_threads_TEST_LDFLAGS = -lboost_thread
+-libebt_boost_threads_TEST_CXXFLAGS = -pthread $(AM_CXXFLAGS)
++libebt_boost_threads_TEST_LDADD = libebttests.a -lboost_thread
++libebt_boost_threads_TEST_LDFLAGS = -pthread
+ endif
+
+ if USE_ZTHREAD_TESTS
+ the_tests += libebt_zthread_threads_TEST
+
+ libebt_zthread_threads_TEST_SOURCES = libebt_zthread_threads_TEST.cc $(test_headers) $(libinclude_HEADERS)
+-libebt_zthread_threads_TEST_LDADD = libebttests.a
+-libebt_zthread_threads_TEST_LDFLAGS = -lZThread
++libebt_zthread_threads_TEST_LDADD = libebttests.a -lZThread
+ endif
+
+ if USE_PTHREAD_TESTS
+@@ -41,7 +39,7 @@
+
+ libebt_pthread_threads_TEST_SOURCES = libebt_pthread_threads_TEST.cc $(test_headers) $(libinclude_HEADERS)
+ libebt_pthread_threads_TEST_LDADD = libebttests.a
+-libebt_pthread_threads_TEST_LDFLAGS = -lpthread
++libebt_pthread_threads_TEST_LDFLAGS = -pthread
+ endif
+
+ TESTS = $(the_tests)