summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-09-28 14:00:24 +0000
committerMart Raudsepp <leio@gentoo.org>2008-09-28 14:00:24 +0000
commitfbf4878345f001c68c74b18f4924a62a7cf0ceee (patch)
tree97854c78021cab6ef5e3e4d627239f2d4c08dbe2 /dev-cpp/gtkmm
parentFix manpages and docs not being installed to the right place. Fixup mulilib s... (diff)
downloadgentoo-2-fbf4878345f001c68c74b18f4924a62a7cf0ceee.tar.gz
gentoo-2-fbf4878345f001c68c74b18f4924a62a7cf0ceee.tar.bz2
gentoo-2-fbf4878345f001c68c74b18f4924a62a7cf0ceee.zip
Fix compatibility with gtk+-2.14, bug 238698
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'dev-cpp/gtkmm')
-rw-r--r--dev-cpp/gtkmm/ChangeLog7
-rw-r--r--dev-cpp/gtkmm/files/gtkmm-2.12.7-gtk2_14-compatibility.patch55
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.12.1.ebuild9
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.12.7.ebuild7
4 files changed, 74 insertions, 4 deletions
diff --git a/dev-cpp/gtkmm/ChangeLog b/dev-cpp/gtkmm/ChangeLog
index 93c4dbf561a2..c05f15a47642 100644
--- a/dev-cpp/gtkmm/ChangeLog
+++ b/dev-cpp/gtkmm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/gtkmm
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/ChangeLog,v 1.150 2008/08/12 19:32:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/ChangeLog,v 1.151 2008/09/28 14:00:23 leio Exp $
+
+ 28 Sep 2008; Mart Raudsepp <leio@gentoo.org>
+ +files/gtkmm-2.12.7-gtk2_14-compatibility.patch, gtkmm-2.12.1.ebuild,
+ gtkmm-2.12.7.ebuild:
+ Fix compatibility with gtk+-2.14, bug 238698
12 Aug 2008; Raúl Porcel <armin76@gentoo.org> gtkmm-2.12.7.ebuild:
alpha/ia64/sparc stable wrt #229709
diff --git a/dev-cpp/gtkmm/files/gtkmm-2.12.7-gtk2_14-compatibility.patch b/dev-cpp/gtkmm/files/gtkmm-2.12.7-gtk2_14-compatibility.patch
new file mode 100644
index 000000000000..aeb3a7acfc9b
--- /dev/null
+++ b/dev-cpp/gtkmm/files/gtkmm-2.12.7-gtk2_14-compatibility.patch
@@ -0,0 +1,55 @@
+http://svn.gnome.org/viewvc/gtkmm/trunk/gtk/src/toolbar.ccg?r1=869&r2=999&view=patch
+with the same repeated for gtk/gtkmm generated sources
+
+Fixes build against gtk+-2.14 to allow gtkmm to be stabled later than gtk+
+
+--- trunk/gtk/src/toolbar.ccg 2007/07/12 12:41:04 869
++++ trunk/gtk/src/toolbar.ccg 2008/07/03 15:09:41 999
+@@ -20,13 +20,6 @@
+ * Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
+-//Define this to make sure that we don't use any of the deprecated GtkToolbar API.
+-//Normally we just deprecate it in gtkmm too,
+-//but the GtkToolbar compatibility system is particularly unpleasant, so we just removed it in gtkmm 2.4. murrayc.
+-//In future, this GTK_DISABLE_DEPRECATED might be inappropriate because it might cover extra GTK+ API. Just remove it then.
+-
+-#define GTK_DISABLE_DEPRECATED
+-
+ #include <glib.h>
+ #include <gtkmm/button.h>
+ #include <gtkmm/togglebutton.h>
+@@ -96,7 +89,7 @@
+ Tooltips* Toolbar::get_tooltips_object() const
+ {
+ //Note that the _tooltips field is deprecated and broken since GTK+ 2.12:
+- return Glib::wrap((GtkTooltips*)gobj()->_tooltips);
++ return 0; //Glib::wrap((GtkTooltips*)gobj()->_tooltips);
+ }
+ #endif //GTKMM_DISABLE_DEPRECATED
+
+--- trunk/gtk/gtkmm/toolbar.cc 2007/07/12 12:41:04 869
++++ trunk/gtk/gtkmm/toolbar.cc 2008/07/03 15:09:41 999
+@@ -20,13 +20,6 @@
+ * Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
+-//Define this to make sure that we don't use any of the deprecated GtkToolbar API.
+-//Normally we just deprecate it in gtkmm too,
+-//but the GtkToolbar compatibility system is particularly unpleasant, so we just removed it in gtkmm 2.4. murrayc.
+-//In future, this GTK_DISABLE_DEPRECATED might be inappropriate because it might cover extra GTK+ API. Just remove it then.
+-
+-#define GTK_DISABLE_DEPRECATED
+-
+ #include <glib.h>
+ #include <gtkmm/button.h>
+ #include <gtkmm/togglebutton.h>
+@@ -96,7 +89,7 @@
+ Tooltips* Toolbar::get_tooltips_object() const
+ {
+ //Note that the _tooltips field is deprecated and broken since GTK+ 2.12:
+- return Glib::wrap((GtkTooltips*)gobj()->_tooltips);
++ return 0; //Glib::wrap((GtkTooltips*)gobj()->_tooltips);
+ }
+ #endif //GTKMM_DISABLE_DEPRECATED
+
diff --git a/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild b/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild
index 97f2a805ef7e..da65bc0f61f1 100644
--- a/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild,v 1.11 2008/07/10 15:16:28 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild,v 1.12 2008/09/28 14:00:23 leio Exp $
inherit gnome2 autotools
@@ -30,3 +30,10 @@ pkg_setup() {
$(use_enable examples)
$(use_enable examples demos)"
}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix build with gtk+-2.14
+ epatch "${FILESDIR}/${PN}-2.12.7-gtk2_14-compatibility.patch"
+}
diff --git a/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild b/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild
index f997ed9b35ba..aa3d0684844a 100644
--- a/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild,v 1.7 2008/08/12 19:32:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild,v 1.8 2008/09/28 14:00:23 leio Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="C++ interface for GTK+2"
HOMEPAGE="http://www.gtkmm.org"
@@ -34,6 +34,9 @@ pkg_setup() {
src_unpack() {
gnome2_src_unpack
+ # Fix build with gtk+-2.14
+ epatch "${FILESDIR}/${P}-gtk2_14-compatibility.patch"
+
if ! use test; then
# don't waste time building tests
sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die "sed failed"