summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-01-03 20:33:06 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-01-03 20:33:06 +0000
commitb99b4a4c28476ab1c7bed32ccefce47326d79a5e (patch)
tree65a04f2c6319ad16f0f038e272fae1fd3db3cb7c /dev-cpp/gnome-vfsmm
parentstable x86, bug 194329 (diff)
downloadgentoo-2-b99b4a4c28476ab1c7bed32ccefce47326d79a5e.tar.gz
gentoo-2-b99b4a4c28476ab1c7bed32ccefce47326d79a5e.tar.bz2
gentoo-2-b99b4a4c28476ab1c7bed32ccefce47326d79a5e.zip
bump to 2.20.0, nothing new
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-cpp/gnome-vfsmm')
-rw-r--r--dev-cpp/gnome-vfsmm/ChangeLog10
-rw-r--r--dev-cpp/gnome-vfsmm/files/digest-gnome-vfsmm-2.20.03
-rw-r--r--dev-cpp/gnome-vfsmm/gnome-vfsmm-2.20.0.ebuild53
3 files changed, 64 insertions, 2 deletions
diff --git a/dev-cpp/gnome-vfsmm/ChangeLog b/dev-cpp/gnome-vfsmm/ChangeLog
index b594304731c1..d1b65fa49101 100644
--- a/dev-cpp/gnome-vfsmm/ChangeLog
+++ b/dev-cpp/gnome-vfsmm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/gnome-vfsmm
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/ChangeLog,v 1.51 2007/12/25 14:36:12 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/ChangeLog,v 1.52 2008/01/03 20:33:06 eva Exp $
+
+*gnome-vfsmm-2.20.0 (03 Jan 2008)
+
+ 03 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-vfsmm-2.20.0.ebuild:
+ bump to 2.20.0
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing pyrania from metadata.xml as per #26352.
diff --git a/dev-cpp/gnome-vfsmm/files/digest-gnome-vfsmm-2.20.0 b/dev-cpp/gnome-vfsmm/files/digest-gnome-vfsmm-2.20.0
new file mode 100644
index 000000000000..223c4e57e998
--- /dev/null
+++ b/dev-cpp/gnome-vfsmm/files/digest-gnome-vfsmm-2.20.0
@@ -0,0 +1,3 @@
+MD5 3da9908850655031a383998d0cda1f85 gnome-vfsmm-2.20.0.tar.bz2 344213
+RMD160 4231975d9ff3b957c0b0f7fbaa8a427eafb6fbf2 gnome-vfsmm-2.20.0.tar.bz2 344213
+SHA256 5a2cdeab177278ccb8b2e55eb257d332d57c750ba698b4199b7798b45afa7690 gnome-vfsmm-2.20.0.tar.bz2 344213
diff --git a/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.20.0.ebuild b/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.20.0.ebuild
new file mode 100644
index 000000000000..d567cc26c793
--- /dev/null
+++ b/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.20.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.20.0.ebuild,v 1.1 2008/01/03 20:33:06 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for gnome-vfs"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+# glibmm dep is because build fails with older versions...
+RDEPEND=">=gnome-base/gnome-vfs-2.8.1
+ >=dev-cpp/glibmm-2.12"
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ ${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS README INSTALL"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ if ! use examples; then
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+ fi
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ if use doc; then
+ cd "${S}"/docs/reference
+ make all
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/* docs/images/*
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -fr {} \; 2>/dev/null
+ cp -R examples "${D}"/usr/share/doc/${PF}
+ fi
+}