summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-06-30 13:48:23 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-06-30 13:48:23 +0000
commitf63a254ebad10b64769cc5abbd4de35b906ad0bc (patch)
tree86b9d4a440243a8724817c25c7506009e157f135 /app-vim
parentdev-libs/newt: Fix python deps (diff)
downloadgentoo-2-f63a254ebad10b64769cc5abbd4de35b906ad0bc.tar.gz
gentoo-2-f63a254ebad10b64769cc5abbd4de35b906ad0bc.tar.bz2
gentoo-2-f63a254ebad10b64769cc5abbd4de35b906ad0bc.zip
Debundle most of the dependencies
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/python-mode/ChangeLog8
-rw-r--r--app-vim/python-mode/python-mode-0.6.18-r1.ebuild (renamed from app-vim/python-mode/python-mode-0.6.18.ebuild)12
2 files changed, 15 insertions, 5 deletions
diff --git a/app-vim/python-mode/ChangeLog b/app-vim/python-mode/ChangeLog
index 95dc8e1aaf08..01ed06e2ddb3 100644
--- a/app-vim/python-mode/ChangeLog
+++ b/app-vim/python-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/python-mode
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/ChangeLog,v 1.6 2013/05/28 19:17:48 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/ChangeLog,v 1.7 2013/06/30 13:48:23 xarthisius Exp $
+
+*python-mode-0.6.18-r1 (30 Jun 2013)
+
+ 30 Jun 2013; Kacper Kowalik <xarthisius@gentoo.org>
+ +python-mode-0.6.18-r1.ebuild, -python-mode-0.6.18.ebuild:
+ Debundle most of the dependencies
*python-mode-0.6.18 (28 May 2013)
diff --git a/app-vim/python-mode/python-mode-0.6.18.ebuild b/app-vim/python-mode/python-mode-0.6.18-r1.ebuild
index 76a7801fe8eb..093373650fd0 100644
--- a/app-vim/python-mode/python-mode-0.6.18.ebuild
+++ b/app-vim/python-mode/python-mode-0.6.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/python-mode-0.6.18.ebuild,v 1.1 2013/05/28 19:17:48 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/python-mode-0.6.18-r1.ebuild,v 1.1 2013/06/30 13:48:23 xarthisius Exp $
EAPI=5
@@ -27,12 +27,16 @@ RDEPEND="
"
src_prepare() {
- rm -rf pylibs/{logilab,*pep8.py,pyflakes,pylint,rope,ropemode} .gitignore
+ # debundling fun
+ rm -rf pylibs/pylama/{pep8.py,pyflakes} pylibs/{autopep8.py,rope,ropemode}
+ sed -e 's/from .pep8/from pep8/g' \
+ -e 's/from .pyflakes/from pyflakes/g' \
+ -i pylibs/pylama/utils.py || die
+ # there's still pylint left, I failed to debundle it :/
+
mv pylint.ini "${T}" || die
sed -e "s|expand(\"<sfile>:p:h:h\")|\"${EPREFIX}/usr/share/${PN}\"|" \
-i autoload/pymode.vim || die # use custom path
- sed -e "s/pylibs.autopep8/autopep8/g" -i pylibs/pymode/auto.py || die
- sed -e "s/pylibs.ropemode/ropemode/g" -i pylibs/ropevim.py || die
}
src_install() {