summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-02-22 19:12:53 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-02-22 19:12:53 +0000
commite20a03bc13731d62bb41fa99826b436516c3b08f (patch)
treecf38535dfb91ffe1fa3cfa9ba1d0df9f5a40114c /app-vim
parentMarked ~mips (diff)
downloadgentoo-2-e20a03bc13731d62bb41fa99826b436516c3b08f.tar.gz
gentoo-2-e20a03bc13731d62bb41fa99826b436516c3b08f.tar.bz2
gentoo-2-e20a03bc13731d62bb41fa99826b436516c3b08f.zip
New version, bug #82883
(Portage version: 2.0.51.16-militant-sandwich)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimoutliner/ChangeLog8
-rw-r--r--app-vim/vimoutliner/Manifest4
-rw-r--r--app-vim/vimoutliner/files/digest-vimoutliner-0.3.3a1
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.3a.ebuild42
4 files changed, 53 insertions, 2 deletions
diff --git a/app-vim/vimoutliner/ChangeLog b/app-vim/vimoutliner/ChangeLog
index 61566d23d092..1a92a53c256e 100644
--- a/app-vim/vimoutliner/ChangeLog
+++ b/app-vim/vimoutliner/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/vimoutliner
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vimoutliner/ChangeLog,v 1.3 2005/01/01 16:55:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimoutliner/ChangeLog,v 1.4 2005/02/22 19:12:53 ciaranm Exp $
+
+*vimoutliner-0.3.3a (22 Feb 2005)
+
+ 22 Feb 2005; Ciaran McCreesh <ciaranm@gentoo.org>
+ +vimoutliner-0.3.3a.ebuild:
+ New version, bug #82883
29 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org>
vimoutliner-0.3.3.ebuild:
diff --git a/app-vim/vimoutliner/Manifest b/app-vim/vimoutliner/Manifest
index bfc4eaae4f6a..84f0956c06da 100644
--- a/app-vim/vimoutliner/Manifest
+++ b/app-vim/vimoutliner/Manifest
@@ -1,4 +1,6 @@
+MD5 f45e8f3b921e0e4d06edc2bfddda2ff6 vimoutliner-0.3.3.ebuild 1054
MD5 5d36dd569237aedbc8885164b98084e5 ChangeLog 495
+MD5 936e4b58d2a976314b6790c8b5bbf8d5 vimoutliner-0.3.3a.ebuild 1057
MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
-MD5 f45e8f3b921e0e4d06edc2bfddda2ff6 vimoutliner-0.3.3.ebuild 1054
MD5 dff564f942c557805a4254359c428756 files/digest-vimoutliner-0.3.3 68
+MD5 1eb384041125b0ae91304ec2ff5d84e6 files/digest-vimoutliner-0.3.3a 69
diff --git a/app-vim/vimoutliner/files/digest-vimoutliner-0.3.3a b/app-vim/vimoutliner/files/digest-vimoutliner-0.3.3a
new file mode 100644
index 000000000000..a277f7535eaf
--- /dev/null
+++ b/app-vim/vimoutliner/files/digest-vimoutliner-0.3.3a
@@ -0,0 +1 @@
+MD5 a1f0bc71e0fd4d5619142f9662c50505 vimoutliner-0.3.3a.tar.gz 43938
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.3a.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.3a.ebuild
new file mode 100644
index 000000000000..1ab1d13671d9
--- /dev/null
+++ b/app-vim/vimoutliner/vimoutliner-0.3.3a.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimoutliner/vimoutliner-0.3.3a.ebuild,v 1.1 2005/02/22 19:12:53 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: easy and fast outlining"
+HOMEPAGE="http://www.vimoutliner.org"
+SRC_URI="mirror://gentoo/${PN}-${PV}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~mips ~amd64"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="vimoutliner"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim
+ sed -i -e '/ru .vimoutlinerrc/aru vimoutlinerrc' ftplugin/vo_base.vim
+ sed -i -e '/hi spellErr,SpellErrors,BadWord/d' syntax/vo_base.vim
+}
+
+src_install() {
+ cd ${S}
+ p=/usr/share/vim/vimfiles
+ for d in doc ftdetect ftplugin syntax ; do
+ dodir ${p}/${d}
+ cp -R ${d} ${D}/${p}/
+ done
+
+ dodir ${p}/vimoutliner/plugins
+ cp -R add-ons/plugins ${D}/${p}/vimoutliner/
+
+ for d in scripts/* add-ons/scripts/* ; do
+ dobin ${d}
+ done
+
+ dodoc vimoutlinerrc
+}
+