summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-26 06:35:49 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-26 06:35:49 +0000
commit6b9ab9f6d4896dec1dd1956357ef00563b9dbcae (patch)
tree50c5ac6506957710944b9cae76c39fde74ca4a42 /app-vim
parentVersion bump. (diff)
downloadgentoo-2-6b9ab9f6d4896dec1dd1956357ef00563b9dbcae.tar.gz
gentoo-2-6b9ab9f6d4896dec1dd1956357ef00563b9dbcae.tar.bz2
gentoo-2-6b9ab9f6d4896dec1dd1956357ef00563b9dbcae.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/command-t/ChangeLog7
-rw-r--r--app-vim/command-t/command-t-1.9.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/app-vim/command-t/ChangeLog b/app-vim/command-t/ChangeLog
index 384d5908377b..995eae773a86 100644
--- a/app-vim/command-t/ChangeLog
+++ b/app-vim/command-t/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/command-t
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/ChangeLog,v 1.17 2014/05/26 07:40:21 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/ChangeLog,v 1.18 2014/06/26 06:35:48 radhermit Exp $
+
+*command-t-1.9.1 (26 Jun 2014)
+
+ 26 Jun 2014; Tim Harder <radhermit@gentoo.org> +command-t-1.9.1.ebuild:
+ Version bump.
*command-t-1.9 (26 May 2014)
diff --git a/app-vim/command-t/command-t-1.9.1.ebuild b/app-vim/command-t/command-t-1.9.1.ebuild
new file mode 100644
index 000000000000..38bb010974bf
--- /dev/null
+++ b/app-vim/command-t/command-t-1.9.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/command-t-1.9.1.ebuild,v 1.1 2014/06/26 06:35:49 radhermit Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit vim-plugin ruby-ng
+
+DESCRIPTION="vim plugin: fast file navigation for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3025
+ https://wincent.com/products/command-t"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+each_ruby_configure() {
+ cd ruby/${PN}
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ cd ruby/${PN}
+ emake V=1
+ rm *.o *.c *.h *.log extconf.rb depend Makefile || die
+}
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ insinto ${sitelibdir}/${PN}
+ doins -r ruby/${PN}/*
+}
+
+all_ruby_install() {
+ rm -r ruby || die
+ vim-plugin_src_install
+}