summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-05 03:32:47 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-05 03:32:47 +0000
commit2231cc3417b8d12bca5cc7adcdb79ffbe9d434bf (patch)
tree1e003d8ccdb1ef3d22c2765f7359402c340ea02e /app-vim
parentMinor grammar fix. (diff)
downloadgentoo-2-2231cc3417b8d12bca5cc7adcdb79ffbe9d434bf.tar.gz
gentoo-2-2231cc3417b8d12bca5cc7adcdb79ffbe9d434bf.tar.bz2
gentoo-2-2231cc3417b8d12bca5cc7adcdb79ffbe9d434bf.zip
Initial import.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/dirdiff/ChangeLog10
-rw-r--r--app-vim/dirdiff/dirdiff-1.1.4.ebuild37
-rw-r--r--app-vim/dirdiff/metadata.xml5
3 files changed, 52 insertions, 0 deletions
diff --git a/app-vim/dirdiff/ChangeLog b/app-vim/dirdiff/ChangeLog
new file mode 100644
index 000000000000..c482eeaa81a8
--- /dev/null
+++ b/app-vim/dirdiff/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/dirdiff
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/dirdiff/ChangeLog,v 1.1 2011/09/05 03:32:47 radhermit Exp $
+
+*dirdiff-1.1.4 (05 Sep 2011)
+
+ 05 Sep 2011; Tim Harder <radhermit@gentoo.org> +dirdiff-1.1.4.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/app-vim/dirdiff/dirdiff-1.1.4.ebuild b/app-vim/dirdiff/dirdiff-1.1.4.ebuild
new file mode 100644
index 000000000000..0ebcaa0060e9
--- /dev/null
+++ b/app-vim/dirdiff/dirdiff-1.1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/dirdiff/dirdiff-1.1.4.ebuild,v 1.1 2011/09/05 03:32:47 radhermit Exp $
+
+EAPI="4"
+
+inherit vim-plugin
+
+MY_PN="DirDiff.vim"
+DESCRIPTION="vim plugin: diff and merge two directories recursively"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=102"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="DirDiff.txt"
+
+RDEPEND="sys-apps/diffutils"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '0,/" -\*- vim -\*-$/d' -e '/" 0.7 Initial Release$/,9999d' -e 's/^" \?//' \
+ -e 's/\(FILE: \)".\+\.vim"/\1*DirDiff.txt*/' \
+ plugin/DirDiff.vim \
+ > doc/DirDiff.txt
+
+ rm -f README
+}
diff --git a/app-vim/dirdiff/metadata.xml b/app-vim/dirdiff/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/dirdiff/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>