summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-06 00:01:39 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-06 00:01:39 +0000
commit76e47c3dbc7895714fb1ad9979eb1d9582a068a6 (patch)
treeae9b58dd7726f0e0a6045a6190a17b3737338781 /app-vim/lustyexplorer/lustyexplorer-4.3.ebuild
parentStable ppc ppc64, bug #428956 (diff)
downloadgentoo-2-76e47c3dbc7895714fb1ad9979eb1d9582a068a6.tar.gz
gentoo-2-76e47c3dbc7895714fb1ad9979eb1d9582a068a6.tar.bz2
gentoo-2-76e47c3dbc7895714fb1ad9979eb1d9582a068a6.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/lustyexplorer/lustyexplorer-4.3.ebuild')
-rw-r--r--app-vim/lustyexplorer/lustyexplorer-4.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-vim/lustyexplorer/lustyexplorer-4.3.ebuild b/app-vim/lustyexplorer/lustyexplorer-4.3.ebuild
new file mode 100644
index 000000000000..c0d5de67b765
--- /dev/null
+++ b/app-vim/lustyexplorer/lustyexplorer-4.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/lustyexplorer/lustyexplorer-4.3.ebuild,v 1.1 2012/08/06 00:01:38 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: dynamic filesystem and buffer explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1890"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="lusty-explorer.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '0,/"$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+ -e "s/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/" \
+ plugin/lusty-explorer.vim > doc/lusty-explorer.txt
+}