summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-24 23:38:16 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-24 23:38:16 +0000
commit3de57758ff66f806c328b67f065eb1f0f09805da (patch)
treee65650282270144613dbdd7446e2ffb31af26068 /app-vim/dhcpd-syntax
parentMarked ppc (diff)
downloadgentoo-2-3de57758ff66f806c328b67f065eb1f0f09805da.tar.gz
gentoo-2-3de57758ff66f806c328b67f065eb1f0f09805da.tar.bz2
gentoo-2-3de57758ff66f806c328b67f065eb1f0f09805da.zip
New package, requested by Bjarke Istrup Pedersen in bug #85808.
(Portage version: 2.0.51.19 small furry bundle of death edition)
Diffstat (limited to 'app-vim/dhcpd-syntax')
-rw-r--r--app-vim/dhcpd-syntax/ChangeLog11
-rw-r--r--app-vim/dhcpd-syntax/Manifest3
-rw-r--r--app-vim/dhcpd-syntax/dhcpd-syntax-20030825.ebuild20
-rw-r--r--app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch12
-rw-r--r--app-vim/dhcpd-syntax/files/digest-dhcpd-syntax-200308251
-rw-r--r--app-vim/dhcpd-syntax/metadata.xml14
6 files changed, 61 insertions, 0 deletions
diff --git a/app-vim/dhcpd-syntax/ChangeLog b/app-vim/dhcpd-syntax/ChangeLog
new file mode 100644
index 000000000000..5ab67c3be66f
--- /dev/null
+++ b/app-vim/dhcpd-syntax/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-vim/dhcpd-syntax
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/dhcpd-syntax/ChangeLog,v 1.1 2005/03/24 23:38:16 ciaranm Exp $
+
+*dhcpd-syntax-20030825 (24 Mar 2005)
+
+ 24 Mar 2005; Ciaran McCreesh <ciaranm@gentoo.org>
+ +files/dhcpd-syntax-20030825-multiple-addresses.patch, +metadata.xml,
+ +dhcpd-syntax-20030825.ebuild:
+ New package, requested by Bjarke Istrup Pedersen in bug #85808.
+
diff --git a/app-vim/dhcpd-syntax/Manifest b/app-vim/dhcpd-syntax/Manifest
new file mode 100644
index 000000000000..335812b3399c
--- /dev/null
+++ b/app-vim/dhcpd-syntax/Manifest
@@ -0,0 +1,3 @@
+MD5 6e14914eabc56c4bce9ed1d0cf924e27 dhcpd-syntax-20030825.ebuild 524
+MD5 d884667583c2bf9ce0adaa2701391ce3 files/dhcpd-syntax-20030825-multiple-addresses.patch 589
+MD5 4e6bf368188c17f891bc68fbab9cd9bc files/digest-dhcpd-syntax-20030825 72
diff --git a/app-vim/dhcpd-syntax/dhcpd-syntax-20030825.ebuild b/app-vim/dhcpd-syntax/dhcpd-syntax-20030825.ebuild
new file mode 100644
index 000000000000..3e0a3e9f7315
--- /dev/null
+++ b/app-vim/dhcpd-syntax/dhcpd-syntax-20030825.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/dhcpd-syntax/dhcpd-syntax-20030825.ebuild,v 1.1 2005/03/24 23:38:16 ciaranm Exp $
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: syntax highlighting for dhcpd.conf"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=744"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc ~ppc64 ~amd64 ~alpha ~ia64"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for dhcpd.conf files."
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-multiple-addresses.patch
+}
diff --git a/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch b/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch
new file mode 100644
index 000000000000..22eaa8236795
--- /dev/null
+++ b/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch
@@ -0,0 +1,12 @@
+--- syntax/dhcpd.vim.orig 2005-03-24 16:41:59.755564944 +0000
++++ syntax/dhcpd.vim 2005-03-24 16:42:15.894111512 +0000
+@@ -33,7 +33,7 @@
+ " Base constructs {{{
+ syn match dhcpdString +"[^"]*"+
+ syn match dhcpdDecNumber "\<-\?\d\+\(;\|\s\|$\)"
+-syn match dhcpdIPv4 "\<\(\d\{1,3}\.\)\{3}\d\{1,3}\(;\|\s\|$\)"
++syn match dhcpdIPv4 "\<\(\d\{1,3}\.\)\{3}\d\{1,3}\(;\|\s\|,\|$\)"
+ syn match dhcpdMAC "\<\(\x\x\?:\)\{5}\x\x\?\(;\|\s\|$\)"
+ syn match dhcpdDate "\<[0-6]\s\d\{4}/\d\d/\d\d/\s\d\d:\d\d:\d\d\(;\|\s\|$\)"
+ """""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""" }}}
+
diff --git a/app-vim/dhcpd-syntax/files/digest-dhcpd-syntax-20030825 b/app-vim/dhcpd-syntax/files/digest-dhcpd-syntax-20030825
new file mode 100644
index 000000000000..1548bd216dc0
--- /dev/null
+++ b/app-vim/dhcpd-syntax/files/digest-dhcpd-syntax-20030825
@@ -0,0 +1 @@
+MD5 d7f120a5d37f7184ef0766800eb4a3f9 dhcpd-syntax-20030825.tar.bz2 2761
diff --git a/app-vim/dhcpd-syntax/metadata.xml b/app-vim/dhcpd-syntax/metadata.xml
new file mode 100644
index 000000000000..4bee094e7234
--- /dev/null
+++ b/app-vim/dhcpd-syntax/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <maintainer>
+ <email>ciaranm@gentoo.org</email>
+ <name>Ciaran McCreesh</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package provides Vim syntax highlighting for dhcpd configuration
+ files, and automatic filetype detection for these files based upon
+ filename.
+ </longdescription>
+</pkgmetadata>