summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-12 21:56:28 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-12 21:56:28 +0000
commit5e21087e018c9d08b0b5de012224f4821d08bbae (patch)
tree3b7bc112717e6d2e6ab7aaffcc34199049db96bb /app-vim/automatictexplugin
parentAdd missing DEPEND on net-misc/mobile-broadband-provider-info. (diff)
downloadgentoo-2-5e21087e018c9d08b0b5de012224f4821d08bbae.tar.gz
gentoo-2-5e21087e018c9d08b0b5de012224f4821d08bbae.tar.bz2
gentoo-2-5e21087e018c9d08b0b5de012224f4821d08bbae.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim/automatictexplugin')
-rw-r--r--app-vim/automatictexplugin/ChangeLog8
-rw-r--r--app-vim/automatictexplugin/automatictexplugin-12.5.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/app-vim/automatictexplugin/ChangeLog b/app-vim/automatictexplugin/ChangeLog
index a10d0a0d36bc..af19f6decb84 100644
--- a/app-vim/automatictexplugin/ChangeLog
+++ b/app-vim/automatictexplugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/automatictexplugin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.47 2014/04/12 09:40:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.48 2014/04/12 21:56:28 radhermit Exp $
+
+*automatictexplugin-12.5 (12 Apr 2014)
+
+ 12 Apr 2014; Tim Harder <radhermit@gentoo.org>
+ +automatictexplugin-12.5.ebuild:
+ Version bump.
12 Apr 2014; Agostino Sarubbo <ago@gentoo.org> automatictexplugin-12.4.ebuild:
Stable for x86, wrt bug #502634
diff --git a/app-vim/automatictexplugin/automatictexplugin-12.5.ebuild b/app-vim/automatictexplugin/automatictexplugin-12.5.ebuild
new file mode 100644
index 000000000000..23bf335c052c
--- /dev/null
+++ b/app-vim/automatictexplugin/automatictexplugin-12.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/automatictexplugin-12.5.ebuild,v 1.1 2014/04/12 21:56:27 radhermit Exp $
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_P="AutomaticTexPlugin_${PV}"
+DESCRIPTION="vim plugin: a comprehensive plugin for editing LaTeX files"
+HOMEPAGE="http://atp-vim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atp-vim/releases/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}
+
+VIM_PLUGIN_HELPFILES="automatic-tex-plugin.txt"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ !app-vim/vim-latex
+ app-vim/align
+ app-text/wdiff
+ >=dev-lang/python-2.7
+ dev-python/psutil
+ dev-tex/latexmk
+ dev-tex/detex
+ virtual/tex-base"