summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-03 14:15:17 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-03 14:15:17 +0000
commitf6687c4b11b11cc053d600cfeb87e3f9987013e9 (patch)
treee24771ad23d83b4470040f246a27da9c4a630379 /app-text
parentadd ~arm, bug #336158 (diff)
downloadgentoo-2-f6687c4b11b11cc053d600cfeb87e3f9987013e9.tar.gz
gentoo-2-f6687c4b11b11cc053d600cfeb87e3f9987013e9.tar.bz2
gentoo-2-f6687c4b11b11cc053d600cfeb87e3f9987013e9.zip
QA, removed old, respecting LDFLAGS/CFLAGS/CC, 335595
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pstotext/ChangeLog11
-rw-r--r--app-text/pstotext/files/1.9-flags.patch36
-rw-r--r--app-text/pstotext/files/pstotext-1.8g-dsafer.patch14
-rw-r--r--app-text/pstotext/pstotext-1.8g-r1.ebuild36
-rw-r--r--app-text/pstotext/pstotext-1.9-r2.ebuild18
-rw-r--r--app-text/pstotext/pstotext-1.9-r3.ebuild31
6 files changed, 82 insertions, 64 deletions
diff --git a/app-text/pstotext/ChangeLog b/app-text/pstotext/ChangeLog
index 2d81a6a094d4..3073f1ffdfe5 100644
--- a/app-text/pstotext/ChangeLog
+++ b/app-text/pstotext/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/pstotext
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/ChangeLog,v 1.33 2009/12/26 19:47:13 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/ChangeLog,v 1.34 2010/10/03 14:15:17 jlec Exp $
+
+*pstotext-1.9-r3 (03 Oct 2010)
+
+ 03 Oct 2010; Justin Lecher <jlec@gentoo.org> +files/1.9-flags.patch,
+ -pstotext-1.8g-r1.ebuild, -files/pstotext-1.8g-dsafer.patch,
+ pstotext-1.9-r2.ebuild, +pstotext-1.9-r3.ebuild:
+ QA, removed old, respecting LDFLAGS/CFLAGS/CC, 335595
26 Dec 2009; Peter Volkov <pva@gentoo.org> pstotext-1.8g-r1.ebuild,
pstotext-1.9-r2.ebuild:
diff --git a/app-text/pstotext/files/1.9-flags.patch b/app-text/pstotext/files/1.9-flags.patch
new file mode 100644
index 000000000000..6f3c9b68d82c
--- /dev/null
+++ b/app-text/pstotext/files/1.9-flags.patch
@@ -0,0 +1,36 @@
+diff --git a/Makefile b/Makefile
+index 551e3b8..1d55ebe 100644
+--- a/Makefile
++++ b/Makefile
+@@ -9,7 +9,7 @@
+ # commenting out the includes of ptotdll.h in ptotdll.c and main.c.
+ # PMcJ 6 Sep 96
+
+-CC=gcc
++CC ?= gcc
+ #CC=cc -std
+
+ BUNDLE = ocr.h rot270.h rot90.h
+@@ -17,18 +17,18 @@ BUNDLE = ocr.h rot270.h rot90.h
+ all: pstotext
+
+ main.o: main.c ptotdll.h bundle.h ocr.h rot270.h rot90.h
+- $(CC) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+ ptotdll.o: ptotdll.c ptotdll.h
+- $(CC) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+ pstotext: bundle.o main.o ptotdll.o
+- $(CC) -o pstotext main.o bundle.o ptotdll.o -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -o pstotext main.o bundle.o ptotdll.o -lm
+
+ .SUFFIXES: .ps
+
+ .c.o:
+- $(CC) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+ # "Bundle" an Ascii file.
+ .ps.h:
diff --git a/app-text/pstotext/files/pstotext-1.8g-dsafer.patch b/app-text/pstotext/files/pstotext-1.8g-dsafer.patch
deleted file mode 100644
index 06e67e897cba..000000000000
--- a/app-text/pstotext/files/pstotext-1.8g-dsafer.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- pstotext-1.9/main.c~ 2005-06-02 15:42:33.754177096 +0200
-+++ pstotext-1.9/main.c 2005-06-02 15:45:20.412084016 +0200
-@@ -231,9 +231,9 @@
- sprintf(
- gs_cmdline,
- #ifdef VMS
-- "%s -r72 \"-dNODISPLAY\" \"-dFIXEDMEDIA\" \"-dDELAYBIND\" \"-dWRITESYSTEMDICT\" %s \"-dNOPAUSE\" %s %s %s",
-+ "%s -r72 \"-dNODISPLAY\" \"-dFIXEDMEDIA\" \"-dDELAYBIND\" \"-dWRITESYSTEMDICT\" %s \"-dNOPAUSE\" \"-dSAFER\" %s %s %s",
- #else
-- "%s -r72 -dNODISPLAY -dFIXEDMEDIA -dDELAYBIND -dWRITESYSTEMDICT %s -dNOPAUSE %s %s %s",
-+ "%s -r72 -dNODISPLAY -dFIXEDMEDIA -dDELAYBIND -dWRITESYSTEMDICT %s -dNOPAUSE -dSAFER %s %s %s",
- #endif
- gs_cmd,
- (debug ? "" : "-q"),
diff --git a/app-text/pstotext/pstotext-1.8g-r1.ebuild b/app-text/pstotext/pstotext-1.8g-r1.ebuild
deleted file mode 100644
index 684e8f60e761..000000000000
--- a/app-text/pstotext/pstotext-1.8g-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/pstotext-1.8g-r1.ebuild,v 1.6 2009/12/26 19:47:13 pva Exp $
-
-inherit eutils
-
-DESCRIPTION="extract ASCII text from a PostScript or PDF file"
-HOMEPAGE="http://research.compaq.com/SRC/virtualpaper/pstotext.html"
-SRC_URI="http://research.compaq.com/SRC/virtualpaper/binaries/pstotext.tar.Z"
-
-LICENSE="PSTT"
-SLOT="0"
-KEYWORDS="~amd64 ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND="app-arch/ncompress"
-
-RDEPEND="app-text/ghostscript-gpl"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch "${FILESDIR}"/${PN}-1.8g-dsafer.patch
-}
-
-src_compile() {
- emake || die
-}
-
-src_install () {
- into /usr
- dobin pstotext
- doman pstotext.1
-}
diff --git a/app-text/pstotext/pstotext-1.9-r2.ebuild b/app-text/pstotext/pstotext-1.9-r2.ebuild
index 7b78723b660f..cb11dc6f1f5e 100644
--- a/app-text/pstotext/pstotext-1.9-r2.ebuild
+++ b/app-text/pstotext/pstotext-1.9-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/pstotext-1.9-r2.ebuild,v 1.9 2009/12/26 19:47:13 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/pstotext-1.9-r2.ebuild,v 1.10 2010/10/03 14:15:17 jlec Exp $
inherit eutils
-DESCRIPTION="extract ASCII text from a PostScript or PDF file"
+DESCRIPTION="Extract ASCII text from a PostScript or PDF file"
HOMEPAGE="http://www.cs.wisc.edu/~ghost/doc/pstotext.htm"
SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/contrib/${P}.tar.gz"
@@ -14,22 +14,16 @@ KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
IUSE=""
DEPEND="app-arch/ncompress"
-
RDEPEND="app-text/ghostscript-gpl"
src_unpack() {
unpack ${A}
cd "${S}"
# fix bug #132662
- epatch "${FILESDIR}"/${P}-quote-chars-fix.patch || die
-}
-
-src_compile() {
- emake || die
+ epatch "${FILESDIR}"/${P}-quote-chars-fix.patch
}
src_install () {
- into /usr
- dobin pstotext
- doman pstotext.1
+ dobin pstotext || die
+ doman pstotext.1 || die
}
diff --git a/app-text/pstotext/pstotext-1.9-r3.ebuild b/app-text/pstotext/pstotext-1.9-r3.ebuild
new file mode 100644
index 000000000000..7df444deb9c6
--- /dev/null
+++ b/app-text/pstotext/pstotext-1.9-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/pstotext-1.9-r3.ebuild,v 1.1 2010/10/03 14:15:17 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extract ASCII text from a PostScript or PDF file"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/doc/pstotext.htm"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/contrib/${P}.tar.gz"
+
+LICENSE="PSTT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/ncompress"
+RDEPEND="app-text/ghostscript-gpl"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-quote-chars-fix.patch \
+ "${FILESDIR}"/${PV}-flags.patch
+ tc-export CC
+}
+
+src_install () {
+ dobin pstotext || die
+ doman pstotext.1 || die
+}