summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-06-27 20:34:25 +0000
committerJeroen Roovers <jer@gentoo.org>2010-06-27 20:34:25 +0000
commite376ac19dfb5bf1e1fb8714856e14b9ad58df3e2 (patch)
treee9c80cda7b85ce1bf8c8e46a0782ab1793bbd685 /app-text
parentx86 stable, bug 322791 (diff)
downloadgentoo-2-e376ac19dfb5bf1e1fb8714856e14b9ad58df3e2.tar.gz
gentoo-2-e376ac19dfb5bf1e1fb8714856e14b9ad58df3e2.tar.bz2
gentoo-2-e376ac19dfb5bf1e1fb8714856e14b9ad58df3e2.zip
Bump the Debian patch set. Replace the Makefile patch with a compatible set of sed scripts. Respect LDFLAGS. Do not patch lib/Makefile since we do not use it. Do not install INSTALL. Properly use EAPI=2.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/an/ChangeLog12
-rw-r--r--app-text/an/an-0.95.3.2.ebuild (renamed from app-text/an/an-0.95.3.1.ebuild)24
2 files changed, 23 insertions, 13 deletions
diff --git a/app-text/an/ChangeLog b/app-text/an/ChangeLog
index 91ccf1727e90..c6cc6f11be7c 100644
--- a/app-text/an/ChangeLog
+++ b/app-text/an/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/an
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/an/ChangeLog,v 1.26 2009/03/18 20:02:59 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/ChangeLog,v 1.27 2010/06/27 20:34:25 jer Exp $
+
+*an-0.95.3.2 (27 Jun 2010)
+
+ 27 Jun 2010; Jeroen Roovers <jer@gentoo.org> -an-0.95.3.1.ebuild,
+ +an-0.95.3.2.ebuild:
+ Bump the Debian patch set. Replace the Makefile patch with a compatible
+ set of sed scripts. Respect LDFLAGS. Do not patch lib/Makefile since we do
+ not use it. Do not install INSTALL. Properly use EAPI=2.
*an-0.95.3.1 (18 Mar 2009)
diff --git a/app-text/an/an-0.95.3.1.ebuild b/app-text/an/an-0.95.3.2.ebuild
index e7f633086ac4..2ca0cecd6aa4 100644
--- a/app-text/an/an-0.95.3.1.ebuild
+++ b/app-text/an/an-0.95.3.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/an/an-0.95.3.1.ebuild,v 1.1 2009/03/18 20:02:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/an-0.95.3.2.ebuild,v 1.1 2010/06/27 20:34:25 jer Exp $
EAPI="2"
+
inherit eutils toolchain-funcs versionator
DESCRIPTION="Very fast anagram generator with dictionary lookup"
@@ -24,23 +25,25 @@ RDEPEND="sys-apps/miscfiles[-minimal]"
S="${WORKDIR}/${PN}-${MY_PV}"
-src_unpack() {
- unpack ${A}
- cd ${S}
-
+src_prepare() {
MY_PL="$(replace_version_separator 2 -)"
epatch "${WORKDIR}"/${PN}_${MY_PV}-${DEB_REV}.diff
- epatch "${FILESDIR}"/${PN}-${MY_PV}-make.patch
# sys-apps/miscfiles doesn't have /usr/dict/words:
- sed \
+ sed -i README \
-e 's:/usr/dict/words:/usr/share/dict/words:' \
- -i README || die "sed failed"
+ || die "sed README failed"
+ sed -i Makefile \
+ -e 's|^CC=gcc|#CC=gcc|g' \
+ -e 's|^CFLAGS=-O2|CFLAGS := $(CFLAGS)|g' \
+ -e 's|$(CC) $(CFLAGS)|$(CC) $(CFLAGS) $(LDFLAGS)|g' \
+ -e 's|&& make|\&\& $(MAKE)|g' \
+ || die "sed Makefile failed"
}
src_compile() {
tc-export CC
- emake || die "make failed"
+ emake LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {
@@ -52,7 +55,6 @@ src_install() {
DICTIONARY \
EXAMPLE.ANAGRAMS \
HINTS \
- INSTALL \
README \
TODO || die
}