summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-04-08 20:18:40 +0000
committerSebastian Pipping <sping@gentoo.org>2010-04-08 20:18:40 +0000
commitbb2d6684a3989cf18cd03402402b5173bed2e12b (patch)
tree3350c94af3d995a900348d3d9c86087fd3dcf262 /app-text
parentAdded SVG format flags, see bug #297220. (diff)
downloadgentoo-2-bb2d6684a3989cf18cd03402402b5173bed2e12b.tar.gz
gentoo-2-bb2d6684a3989cf18cd03402402b5173bed2e12b.tar.bz2
gentoo-2-bb2d6684a3989cf18cd03402402b5173bed2e12b.zip
app-text/xmlstarlet: Bump to 1.0.2
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xmlstarlet/ChangeLog8
-rw-r--r--app-text/xmlstarlet/metadata.xml3
-rw-r--r--app-text/xmlstarlet/xmlstarlet-1.0.2.ebuild53
3 files changed, 63 insertions, 1 deletions
diff --git a/app-text/xmlstarlet/ChangeLog b/app-text/xmlstarlet/ChangeLog
index 598c79e9721d..5d2811033a67 100644
--- a/app-text/xmlstarlet/ChangeLog
+++ b/app-text/xmlstarlet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/xmlstarlet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlstarlet/ChangeLog,v 1.17 2010/01/02 11:46:37 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlstarlet/ChangeLog,v 1.18 2010/04/08 20:18:40 sping Exp $
+
+*xmlstarlet-1.0.2 (08 Apr 2010)
+
+ 08 Apr 2010; Sebastian Pipping <sping@gentoo.org>
+ +xmlstarlet-1.0.2.ebuild, metadata.xml:
+ Bump to 1.0.2
02 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
xmlstarlet-1.0.1-r1.ebuild:
diff --git a/app-text/xmlstarlet/metadata.xml b/app-text/xmlstarlet/metadata.xml
index e96086477315..b0409762149c 100644
--- a/app-text/xmlstarlet/metadata.xml
+++ b/app-text/xmlstarlet/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sgml</herd>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/app-text/xmlstarlet/xmlstarlet-1.0.2.ebuild b/app-text/xmlstarlet/xmlstarlet-1.0.2.ebuild
new file mode 100644
index 000000000000..5130957cfe7b
--- /dev/null
+++ b/app-text/xmlstarlet/xmlstarlet-1.0.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlstarlet/xmlstarlet-1.0.2.ebuild,v 1.1 2010/04/08 20:18:40 sping Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="A set of tools to transform, query, validate, and edit XML documents"
+HOMEPAGE="http://xmlstar.sourceforge.net/"
+# TODO restore <mirror://sourceforge/xmlstar/${P}.tar.gz> once it's up
+SRC_URI="http://xmlstar.sourceforge.net/downloads/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.9"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Shipped configure script broken somehow:
+ # All HAVE_* end up undefined in config.h.
+ # Therefore we re-created it
+ eautoreconf || die 'eautoreconf failed'
+}
+
+src_configure() {
+ local xsltlibs=$(pkg-config --libs libxslt libexslt)
+ local xmllibs=$(pkg-config --libs libxml-2.0)
+
+ LIBXSLT_PREFIX=/usr LIBXML_PREFIX=/usr \
+ LIBXSLT_LIBS="${xsltlibs}" LIBXML_LIBS="${xmllibs}" \
+ econf
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dosym /usr/bin/xml /usr/bin/xmlstarlet
+
+ dodoc AUTHORS ChangeLog README TODO
+ dohtml -r *
+}
+
+src_test() {
+ cd tests
+ sh runTests || die "sh runTests failed."
+}