summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-05-16 02:03:03 +0000
committerSteve Dibb <beandog@gentoo.org>2010-05-16 02:03:03 +0000
commit942a888a4b7d55c69c556e74538e6b0d1ee526fc (patch)
tree22f234b726f3b2e0a6bb655a00a03335d55de1cf /app-text
parentVersion bump (diff)
downloadgentoo-2-942a888a4b7d55c69c556e74538e6b0d1ee526fc.tar.gz
gentoo-2-942a888a4b7d55c69c556e74538e6b0d1ee526fc.tar.bz2
gentoo-2-942a888a4b7d55c69c556e74538e6b0d1ee526fc.zip
Version bump, bug 310273
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bibletime/ChangeLog7
-rw-r--r--app-text/bibletime/bibletime-2.6.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/app-text/bibletime/ChangeLog b/app-text/bibletime/ChangeLog
index 5084374addda..ce2730fd6aa1 100644
--- a/app-text/bibletime/ChangeLog
+++ b/app-text/bibletime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/bibletime
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.60 2010/02/10 04:03:47 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.61 2010/05/16 02:03:03 beandog Exp $
+
+*bibletime-2.6 (16 May 2010)
+
+ 16 May 2010; Steve Dibb <beandog@gentoo.org> +bibletime-2.6.ebuild:
+ Version bump, bug 310273
10 Feb 2010; Joseph Jezak <josejx@gentoo.org> bibletime-2.3.3.ebuild:
Marked ppc stable for bug #294863.
diff --git a/app-text/bibletime/bibletime-2.6.ebuild b/app-text/bibletime/bibletime-2.6.ebuild
new file mode 100644
index 000000000000..1e2a57f164f5
--- /dev/null
+++ b/app-text/bibletime/bibletime-2.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-2.6.ebuild,v 1.1 2010/05/16 02:03:03 beandog Exp $
+
+EAPI="2"
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Bible study application using the SWORD library."
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/bibletime/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+# bug 313657
+RESTRICT="test"
+
+RDEPEND=">=app-text/sword-1.6.0
+ >=dev-cpp/clucene-0.9.16a
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ x11-libs/qt-test:4"
+
+DOCS="ChangeLog README"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DUSE_QT_WEBKIT=ON"
+ cmake-utils_src_configure
+}