summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-04-02 23:45:38 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-04-02 23:45:38 +0000
commit1eccc188886d414a1da0a196e7483724a5624aba (patch)
treee2999d6bac345ba11630ce3eb59522cf990bbfa1 /app-text
parentform fixes (diff)
downloadgentoo-2-1eccc188886d414a1da0a196e7483724a5624aba.tar.gz
gentoo-2-1eccc188886d414a1da0a196e7483724a5624aba.tar.bz2
gentoo-2-1eccc188886d414a1da0a196e7483724a5624aba.zip
libtoolize
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pspell-ispell/ChangeLog19
-rw-r--r--app-text/pspell-ispell/files/digest-pspell-ispell-0.12-r11
-rw-r--r--app-text/pspell-ispell/pspell-ispell-0.12-r1.ebuild40
3 files changed, 60 insertions, 0 deletions
diff --git a/app-text/pspell-ispell/ChangeLog b/app-text/pspell-ispell/ChangeLog
new file mode 100644
index 000000000000..850c711b82a2
--- /dev/null
+++ b/app-text/pspell-ispell/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for app-text/pspell-ispell
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspell-ispell/ChangeLog,v 1.1 2002/04/02 23:45:38 azarah Exp $
+
+*pspell-ispell-0.12-r1 (3 Apr 2002)
+
+ 3 Apr 2002; M.Schlemmer <azarah@gentoo.org> :
+
+ Libtoolize.
+
+*pspell-ispell-0.12 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-text/pspell-ispell/files/digest-pspell-ispell-0.12-r1 b/app-text/pspell-ispell/files/digest-pspell-ispell-0.12-r1
new file mode 100644
index 000000000000..a3e0d5a14f7d
--- /dev/null
+++ b/app-text/pspell-ispell/files/digest-pspell-ispell-0.12-r1
@@ -0,0 +1 @@
+MD5 7329d4122b302057a18d3a55d8d1f64c pspell-ispell-.12.tar.gz 137279
diff --git a/app-text/pspell-ispell/pspell-ispell-0.12-r1.ebuild b/app-text/pspell-ispell/pspell-ispell-0.12-r1.ebuild
new file mode 100644
index 000000000000..ac1c31f71a95
--- /dev/null
+++ b/app-text/pspell-ispell/pspell-ispell-0.12-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspell-ispell/pspell-ispell-0.12-r1.ebuild,v 1.1 2002/04/02 23:45:38 azarah Exp $
+
+#Remove '-ispell' from name for download subdirectory
+MYPN=${PN/-ispell//}
+
+#Remove leading zero from version number
+MYPV=${PV#0}
+
+S=${WORKDIR}/${PN}-${MYPV}
+DESCRIPTION="Ispell module for pspell"
+SRC_URI="http://prdownloads.sourceforge.net/${MYPN}/${PN}-${MYPV}.tar.gz"
+HOMEPAGE="http://pspell.sourceforge.net"
+
+DEPEND=">=app-text/pspell-0.12.2-r2
+ app-text/ispell-3.2.06-r1"
+
+
+src_compile() {
+
+ libtoolize --copy --force
+
+ ./configure \
+ --disable-static \
+ --prefix=/usr \
+ --enable-doc-dir=/usr/share/doc/${PF} \
+ --host=${CHOST} || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ dodoc README
+}
+