summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-08 16:41:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-08 16:41:41 +0000
commit1ccd99815cb142b65fc3cd5a0247edc1cdbfb6f3 (patch)
treefc17eff403cdcd592a6182606d6ffc1d4b9032f2 /app-text
parentremove unused use flags (diff)
downloadgentoo-2-1ccd99815cb142b65fc3cd5a0247edc1cdbfb6f3.tar.gz
gentoo-2-1ccd99815cb142b65fc3cd5a0247edc1cdbfb6f3.tar.bz2
gentoo-2-1ccd99815cb142b65fc3cd5a0247edc1cdbfb6f3.zip
Fix building with libpng14 (copied from app-text/dvipdfm and app-text/dvipdfmx).
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ptex/ChangeLog10
-rw-r--r--app-text/ptex/files/ptex-3.1.10_p20090610-libpng14.patch33
-rw-r--r--app-text/ptex/ptex-3.1.10_p20090610-r1.ebuild7
3 files changed, 45 insertions, 5 deletions
diff --git a/app-text/ptex/ChangeLog b/app-text/ptex/ChangeLog
index c718df5bfc4a..948fa3bd7401 100644
--- a/app-text/ptex/ChangeLog
+++ b/app-text/ptex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/ptex
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ChangeLog,v 1.90 2009/12/13 15:30:47 ranger Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ChangeLog,v 1.91 2010/03/08 16:41:39 ssuominen Exp $
+
+ 08 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ ptex-3.1.10_p20090610-r1.ebuild,
+ +files/ptex-3.1.10_p20090610-libpng14.patch:
+ Fix building with libpng14 (copied from app-text/dvipdfm and
+ app-text/dvipdfmx).
11 Dec 2009; Brent Baude <ranger@gentoo.org> ptex-3.1.10_p20090610.ebuild:
Marking ptex-3.1.10_p20090610 ppc64 for bug 289339
diff --git a/app-text/ptex/files/ptex-3.1.10_p20090610-libpng14.patch b/app-text/ptex/files/ptex-3.1.10_p20090610-libpng14.patch
new file mode 100644
index 000000000000..b19ba6a00482
--- /dev/null
+++ b/app-text/ptex/files/ptex-3.1.10_p20090610-libpng14.patch
@@ -0,0 +1,33 @@
+--- texk/dvipdfm/pngimage.c
++++ texk/dvipdfm/pngimage.c
+@@ -42,7 +42,7 @@
+ rewind (png_file);
+ if (fread (sigbytes, 1, sizeof(sigbytes), png_file) !=
+ sizeof(sigbytes) ||
+- (!png_check_sig (sigbytes, sizeof(sigbytes))))
++ (png_sig_cmp (sigbytes, 0, sizeof(sigbytes))))
+ return 0;
+ else
+ return 1;
+--- texk/dvipdfm/thumbnail.c
++++ texk/dvipdfm/thumbnail.c
+@@ -79,7 +79,7 @@
+ }
+ if (fread (sigbytes, 1, sizeof(sigbytes), thumb_file) !=
+ sizeof(sigbytes) ||
+- (!png_check_sig (sigbytes, sizeof(sigbytes)))) {
++ (png_sig_cmp (sigbytes, 0, sizeof(sigbytes)))) {
+ fprintf (stderr, "\nThumbnail not a png file! Skipping\n");
+ return NULL;
+ }
+--- texk/dvipdfmx/src/pngimage.c
++++ texk/dvipdfmx/src/pngimage.c
+@@ -146,7 +146,7 @@
+ rewind (png_file);
+ if (fread (sigbytes, 1, sizeof(sigbytes), png_file) !=
+ sizeof(sigbytes) ||
+- (!png_check_sig (sigbytes, sizeof(sigbytes))))
++ (png_sig_cmp (sigbytes, 0, sizeof(sigbytes))))
+ return 0;
+ else
+ return 1;
diff --git a/app-text/ptex/ptex-3.1.10_p20090610-r1.ebuild b/app-text/ptex/ptex-3.1.10_p20090610-r1.ebuild
index 7f855e966491..707c133aeb29 100644
--- a/app-text/ptex/ptex-3.1.10_p20090610-r1.ebuild
+++ b/app-text/ptex/ptex-3.1.10_p20090610-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ptex-3.1.10_p20090610-r1.ebuild,v 1.1 2009/11/15 02:37:33 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ptex-3.1.10_p20090610-r1.ebuild,v 1.2 2010/03/08 16:41:39 ssuominen Exp $
# jmbreuer FOR DEV ONLY
RESTRICT="mirror test"
@@ -199,7 +199,8 @@ EOF
# security bug #282874
epatch "${FILESDIR}/CVE-2009-1284.patch"
- epatch "${FILESDIR}/${P}-getline.patch"
+ epatch "${FILESDIR}"/${P}-getline.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
cd "${TETEX_S}/texk/dviljk"
eautoreconf