summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-11 03:11:06 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-11 03:11:06 +0000
commit96c09de971d5867acfd16b82a310a78d8aae4652 (patch)
treee6119e4187acfba96cf242d52416cfc6059d32ff /app-text/unix2dos
parentold (diff)
downloadgentoo-2-96c09de971d5867acfd16b82a310a78d8aae4652.tar.gz
gentoo-2-96c09de971d5867acfd16b82a310a78d8aae4652.tar.bz2
gentoo-2-96c09de971d5867acfd16b82a310a78d8aae4652.zip
Fix missing prototype warnings and use emake to build rather than running CC ourself.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'app-text/unix2dos')
-rw-r--r--app-text/unix2dos/ChangeLog9
-rw-r--r--app-text/unix2dos/files/unix2dos-2.2-headers.patch12
-rw-r--r--app-text/unix2dos/unix2dos-2.2-r1.ebuild7
3 files changed, 23 insertions, 5 deletions
diff --git a/app-text/unix2dos/ChangeLog b/app-text/unix2dos/ChangeLog
index ce40463b686c..b56aedb33fb0 100644
--- a/app-text/unix2dos/ChangeLog
+++ b/app-text/unix2dos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/unix2dos
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/unix2dos/ChangeLog,v 1.25 2007/11/06 17:53:58 corsair Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/unix2dos/ChangeLog,v 1.26 2008/09/11 03:11:05 vapier Exp $
+
+ 11 Sep 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/unix2dos-2.2-headers.patch, unix2dos-2.2-r1.ebuild:
+ Fix missing prototype warnings and use emake to build rather than running
+ CC ourself.
06 Nov 2007; Markus Rothe <corsair@gentoo.org> unix2dos-2.2-r1.ebuild:
Stable on ppc64; bug #197747
diff --git a/app-text/unix2dos/files/unix2dos-2.2-headers.patch b/app-text/unix2dos/files/unix2dos-2.2-headers.patch
new file mode 100644
index 000000000000..c57859ab4c79
--- /dev/null
+++ b/app-text/unix2dos/files/unix2dos-2.2-headers.patch
@@ -0,0 +1,12 @@
+need unistd.h for close() and unlink()
+
+--- unix2dos.c
++++ unix2dos.c
+@@ -62,6 +62,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <utime.h>
++#include <unistd.h>
+ #include <sys/stat.h>
+ #include "unix2dos.h"
+
diff --git a/app-text/unix2dos/unix2dos-2.2-r1.ebuild b/app-text/unix2dos/unix2dos-2.2-r1.ebuild
index 9ad41c4dd33d..f31a466cb534 100644
--- a/app-text/unix2dos/unix2dos-2.2-r1.ebuild
+++ b/app-text/unix2dos/unix2dos-2.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/unix2dos/unix2dos-2.2-r1.ebuild,v 1.8 2007/12/11 09:32:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/unix2dos/unix2dos-2.2-r1.ebuild,v 1.9 2008/09/11 03:11:05 vapier Exp $
inherit eutils toolchain-funcs
@@ -21,10 +21,11 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-segfault.patch
epatch "${FILESDIR}"/${P}-manpage.patch
epatch "${FILESDIR}"/${P}-workaround-rename-EXDEV.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
}
src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o unix2dos unix2dos.c || die
+ emake CC="$(tc-getCC)" unix2dos || die
}
src_install() {