summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-06-15 18:18:21 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-06-15 18:18:21 +0000
commit275431596b70bd2be0b18e84b8d67b0d892c7a00 (patch)
tree40456e1fec19781973eacfae8afc77180da88e1e /app-text/tkinfo
parent*** empty log message *** (diff)
downloadgentoo-2-275431596b70bd2be0b18e84b8d67b0d892c7a00.tar.gz
gentoo-2-275431596b70bd2be0b18e84b8d67b0d892c7a00.tar.bz2
gentoo-2-275431596b70bd2be0b18e84b8d67b0d892c7a00.zip
Added a tk based info browser. In this ebuild I also look for the existence of
the dir file needed by info, if it's not there I generate it.
Diffstat (limited to 'app-text/tkinfo')
-rw-r--r--app-text/tkinfo/files/digest-tkinfo-2.51
-rw-r--r--app-text/tkinfo/tkinfo-2.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/tkinfo/files/digest-tkinfo-2.5 b/app-text/tkinfo/files/digest-tkinfo-2.5
new file mode 100644
index 000000000000..b17b079663e6
--- /dev/null
+++ b/app-text/tkinfo/files/digest-tkinfo-2.5
@@ -0,0 +1 @@
+MD5 e194131e1900d1214c4157b247054c0b tkinfo-2.5.tar.gz
diff --git a/app-text/tkinfo/tkinfo-2.5.ebuild b/app-text/tkinfo/tkinfo-2.5.ebuild
new file mode 100644
index 000000000000..8eeea92d50a7
--- /dev/null
+++ b/app-text/tkinfo/tkinfo-2.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <blutgens@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/tkinfo/tkinfo-2.5.ebuild,v 1.1 2001/06/15 18:18:21 blutgens Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Info Browser in TK"
+SRC_URI="http://math-www.uni-paderborn.de/~axel/tkinfo/${A}"
+HOMEPAGE="http://math-www.uni-paderborn.de/~axel/tkinfo/"
+
+DEPEND=">=dev-lang/tcl-tk-8.0.5"
+
+
+src_install () {
+
+ dobin tkinfo
+ doman tkinfo.1
+ dodoc README
+
+}
+
+pkg_postinst () {
+
+# Let's check to see if info has been setup completely
+cd /usr/share/info
+if [ -f dir ]; then
+ exit 0;
+else
+ mkinfodir . > dir
+fi
+}
+