summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-23 12:36:31 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-23 12:36:31 +0000
commit519e53b04ba793fbc0c6ba589924df217d4ed33e (patch)
tree6dec6f0e939a81b4ff7b31d1d5e0dd1c6f1876fc /app-text/tex-guy/tex-guy-1.3.0.ebuild
parentAdded new major version. (Manifest recommit) (diff)
downloadgentoo-2-519e53b04ba793fbc0c6ba589924df217d4ed33e.tar.gz
gentoo-2-519e53b04ba793fbc0c6ba589924df217d4ed33e.tar.bz2
gentoo-2-519e53b04ba793fbc0c6ba589924df217d4ed33e.zip
Initial import. Thanks to MATSUU Takuto <matsuu@gentoo.org> at GentooJP EbuildJP, http://ebuild.gentoo.gr.jp/.
Diffstat (limited to 'app-text/tex-guy/tex-guy-1.3.0.ebuild')
-rw-r--r--app-text/tex-guy/tex-guy-1.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/tex-guy/tex-guy-1.3.0.ebuild b/app-text/tex-guy/tex-guy-1.3.0.ebuild
new file mode 100644
index 000000000000..953a5d2e39fc
--- /dev/null
+++ b/app-text/tex-guy/tex-guy-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tex-guy/tex-guy-1.3.0.ebuild,v 1.1 2004/10/23 12:36:31 usata Exp $
+
+inherit libtool
+
+MY_P="TeX-Guy-${PV}"
+DESCRIPTION="Miscellaneous utilities using DVIlib"
+HOMEPAGE="http://typehack.aial.hiroshima-u.ac.jp/TeX-Guy/"
+SRC_URI="ftp://ftp.se.hiroshima-u.ac.jp/pub/TypeHack/${MY_P}.tar.gz"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+DEPEND=">=media-libs/vflib-3.6
+ =x11-libs/gtk+-1.2*"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ elibtoolize
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake -j1 CDEBUGFLAGS="${CFLAGS}" \
+ CXXDEBUGFLAGS="${CXXFLAGS}" || die
+}
+
+src_install() {
+ einstall localedir=${D}/usr/share/locale || die "install failed"
+
+ dodoc 00_* CHANGES
+}