summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-01-23 20:42:39 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-01-23 20:42:39 +0000
commit404fee04a4bdae96356e2541bf4ac72df6afbcdc (patch)
tree2f77efa0e5eb2e40c77ae7189afe0a110d764414 /app-text/poppler-bindings
parentTake out the trash (diff)
downloadgentoo-2-404fee04a4bdae96356e2541bf4ac72df6afbcdc.tar.gz
gentoo-2-404fee04a4bdae96356e2541bf4ac72df6afbcdc.tar.bz2
gentoo-2-404fee04a4bdae96356e2541bf4ac72df6afbcdc.zip
Fix qt dependency to not pull in qt-4.4, but only the modules. Also make it more readable and remove 0.6.3.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-text/poppler-bindings')
-rw-r--r--app-text/poppler-bindings/ChangeLog8
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.10.3.ebuild15
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild83
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild17
4 files changed, 28 insertions, 95 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index 5b15b534f4d7..f38aad270eda 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/poppler-bindings
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.122 2009/01/10 22:32:48 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.123 2009/01/23 20:42:39 loki_val Exp $
+
+ 23 Jan 2009; Peter Alfredsen <loki_val@gentoo.org>
+ -poppler-bindings-0.6.3.ebuild, poppler-bindings-0.8.7.ebuild,
+ poppler-bindings-0.10.3.ebuild:
+ Fix qt dependency to not pull in qt-4.4, but only the modules. Also make
+ it more readable and remove 0.6.3.
*poppler-bindings-0.10.3 (10 Jan 2009)
diff --git a/app-text/poppler-bindings/poppler-bindings-0.10.3.ebuild b/app-text/poppler-bindings/poppler-bindings-0.10.3.ebuild
index 6226a8889153..6344f9b24a60 100644
--- a/app-text/poppler-bindings/poppler-bindings-0.10.3.ebuild
+++ b/app-text/poppler-bindings/poppler-bindings-0.10.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.10.3.ebuild,v 1.1 2009/01/10 22:32:48 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.10.3.ebuild,v 1.2 2009/01/23 20:42:39 loki_val Exp $
EAPI="2"
@@ -39,10 +39,15 @@ RDEPEND="~app-text/poppler-${PV}
>=dev-libs/glib-2.8
)
qt3? ( >=x11-libs/qt-3.3:3 )
- qt4? ( || ( ( x11-libs/qt-core:4
- x11-libs/qt-gui:4
- x11-libs/qt-test:4 )
- >=x11-libs/qt-4.3:4 ) )"
+ qt4? (
+ || (
+ ( x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-test:4 )
+
+ =x11-libs/qt-4.3*
+ )
+ )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
test? ( gtk? ( >=gnome-base/libglade-2 ) )"
diff --git a/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild b/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild
deleted file mode 100644
index e896be880d92..000000000000
--- a/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild,v 1.10 2008/10/27 05:52:35 vapier Exp $
-
-inherit autotools eutils multilib
-
-MY_P=${P/-bindings/}
-DESCRIPTION="rendering bindings for GUI toolkits for poppler"
-HOMEPAGE="http://poppler.freedesktop.org/"
-
-# Creating the testsuite tarball (must be done for every release)
-#
-# cvs -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/poppler login
-# cvs -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/poppler co test
-# tar czf poppler-test-${PV}.tar.gz
-# upload to d.g.o/space/distfiles-local
-
-SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz
- test? ( mirror://gentoo/poppler-test-0.6.1.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="gtk qt3 cairo qt4 test"
-
-RDEPEND="~app-text/poppler-${PV}
- cairo? ( >=x11-libs/cairo-1.4 )
- gtk? (
- >=x11-libs/gtk+-2.8
- >=gnome-base/libglade-2
- )
- qt3? ( =x11-libs/qt-3* )
- qt4? ( =x11-libs/qt-4* )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup(){
- use test && ewarn "Tests will fail if your locale is unset."
-}
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/poppler-0.6-bindings.patch
-
- # Don't run password test; the test file is not there. Bug #201448
- epatch "${FILESDIR}"/poppler-0.6.3-no-password-test.patch
-
- AT_M4DIR="m4" eautoreconf
-}
-
-src_compile() {
- # Configure needs help finding qt libs on multilib systems
- export QTLIB="${QTDIR}/$(get_libdir)"
- echo $QTLIB
-
- econf --enable-opi \
- $(use_enable cairo cairo-output) \
- $(use_enable gtk poppler-glib) \
- $(use_enable qt3 poppler-qt) \
- $(use_enable qt4 poppler-qt4) \
- || die "configuration failed"
- cd poppler
- if use cairo; then
- emake libpoppler-cairo.la || die "cairo failed"
- fi
- if use qt4; then
- emake libpoppler-arthur.la || die "arthur failed"
- fi
- cd ..
- emake || die "compilation failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
-
-pkg_postinst() {
- ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
-}
diff --git a/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild b/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild
index 49b31146779a..280f11818ca6 100644
--- a/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild
+++ b/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild,v 1.13 2008/11/24 20:54:38 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild,v 1.14 2009/01/23 20:42:39 loki_val Exp $
EAPI="1"
@@ -32,10 +32,15 @@ RDEPEND="~app-text/poppler-${PV}
>=gnome-base/libglade-2
)
qt3? ( >=x11-libs/qt-3.3:3 )
- qt4? ( || ( ( x11-libs/qt-core:4
- x11-libs/qt-gui:4
- x11-libs/qt-test:4 )
- >=x11-libs/qt-4.3:4 ) )"
+ qt4? (
+ || (
+ ( x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-test:4 )
+
+ =x11-libs/qt-4.3*
+ )
+ )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"