summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2013-06-15 01:38:18 +0000
committerZac Medico <zmedico@gentoo.org>2013-06-15 01:38:18 +0000
commit0fe5acfe985bf07caf0ac088f5a1b7bbb8ff6320 (patch)
tree6aa63eaee70b313dc30fc677902fbd0058cebaea /app-text/podofo
parentupdate to latest makefile changes (diff)
downloadgentoo-2-0fe5acfe985bf07caf0ac088f5a1b7bbb8ff6320.tar.gz
gentoo-2-0fe5acfe985bf07caf0ac088f5a1b7bbb8ff6320.tar.bz2
gentoo-2-0fe5acfe985bf07caf0ac088f5a1b7bbb8ff6320.zip
Remove old version.
(Portage version: 2.2.0_alpha179/cvs/Linux i686, signed Manifest commit with key 0xFDE8EF85AE5719A3)
Diffstat (limited to 'app-text/podofo')
-rw-r--r--app-text/podofo/ChangeLog5
-rw-r--r--app-text/podofo/podofo-0.9.1.ebuild118
2 files changed, 4 insertions, 119 deletions
diff --git a/app-text/podofo/ChangeLog b/app-text/podofo/ChangeLog
index ec32ed079f22..a5f6282fae24 100644
--- a/app-text/podofo/ChangeLog
+++ b/app-text/podofo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/podofo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/ChangeLog,v 1.41 2013/04/14 20:02:59 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/ChangeLog,v 1.42 2013/06/15 01:38:18 zmedico Exp $
+
+ 15 Jun 2013; Zac Medico <zmedico@gentoo.org> -podofo-0.9.1.ebuild:
+ Remove old version.
14 Apr 2013; Zac Medico <zmedico@gentoo.org> podofo-0.9.2.ebuild:
Bump to EAPI 5 for slot-operator deps.
diff --git a/app-text/podofo/podofo-0.9.1.ebuild b/app-text/podofo/podofo-0.9.1.ebuild
deleted file mode 100644
index a24ee2d34c27..000000000000
--- a/app-text/podofo/podofo-0.9.1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.9.1.ebuild,v 1.12 2013/02/28 15:03:15 zmedico Exp $
-
-EAPI=2
-inherit cmake-utils flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format."
-HOMEPAGE="http://sourceforge.net/projects/podofo/"
-SRC_URI="mirror://sourceforge/podofo/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc ppc64 ~sparc x86"
-IUSE="+boost debug test"
-
-RDEPEND="dev-lang/lua
- dev-libs/openssl
- media-libs/fontconfig
- media-libs/freetype:2
- virtual/jpeg
- >=media-libs/libpng-1.4:0
- media-libs/tiff:0
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- boost? ( dev-util/boost-build )
- test? ( dev-util/cppunit )"
-
-DOCS="AUTHORS ChangeLog TODO"
-
-src_prepare() {
- local x sed_args
-
- sed -i \
- -e "s:LIBDIRNAME \"lib\":LIBDIRNAME \"$(get_libdir)\":" \
- CMakeLists.txt || die
-
- # Use pkg-config to find headers for bug #459404.
- sed_args=
- for x in $($(tc-getPKG_CONFIG) --cflags freetype2) ; do
- [[ ${x} == -I* ]] || continue
- x=${x#-I}
- if [[ -f ${x}/ft2build.h ]] ; then
- sed_args+=" -e s:/usr/include/\\r\$:${x}:"
- elif [[ -f ${x}/freetype/config/ftheader.h ]] ; then
- sed_args+=" -e s:/usr/include/freetype2\\r\$:${x}:"
- fi
- done
- [[ -n ${sed_args} ]] && \
- { sed -i ${sed_args} cmake/modules/FindFREETYPE.cmake || die; }
-
- # Bug #439784: Add missing unistd include for close() and unlink().
- sed -i 's:^#include <stdio.h>$:#include <unistd.h>\n\0:' -i \
- test/unit/TestUtils.cpp || die
-
- # TODO: fix these test cases
- # ColorTest.cpp:62:Assertion
- # Test name: ColorTest::testDefaultConstructor
- # expected exception not thrown
- # - Expected: PdfError
- sed -e 's:CPPUNIT_TEST( testDefaultConstructor ://\0:' \
- -e 's:CPPUNIT_TEST( testGreyConstructor ://\0:' \
- -e 's:CPPUNIT_TEST( testRGBConstructor ://\0:' \
- -e 's:CPPUNIT_TEST( testCMYKConstructor ://\0:' \
- -e 's:CPPUNIT_TEST( testColorSeparationAllConstructor ://\0:' \
- -e 's:CPPUNIT_TEST( testColorSeparationNoneConstructor ://\0:' \
- -e 's:CPPUNIT_TEST( testColorSeparationConstructor ://\0:' \
- -e 's:CPPUNIT_TEST( testColorCieLabConstructor ://\0:' \
- -i test/unit/ColorTest.h || die
-
- # ColorTest.cpp:42:Assertion
- # Test name: ColorTest::testHexNames
- # assertion failed
- # - Expression: static_cast<int>(rgb.GetGreen() * 255.0) == 0x0A
- sed -e 's:CPPUNIT_TEST( testHexNames ://\0:' \
- -i test/unit/ColorTest.h || die
-
- # Bug #352125: test failure, depending on installed fonts
- # ##Failure Location unknown## : Error
- # Test name: FontTest::testFonts
- # uncaught exception of type PoDoFo::PdfError
- # - ePdfError_UnsupportedFontFormat
- sed -e 's:CPPUNIT_TEST( testFonts ://\0:' \
- -i test/unit/FontTest.h || die
-
- # Bug #407015: fix to compile with Lua 5.2
- if has_version '>=dev-lang/lua-5.2' ; then
- sed -e 's: lua_open(: luaL_newstate(:' \
- -e 's: luaL_getn(: lua_rawlen(:' -i \
- tools/podofocolor/luaconverter.cpp \
- tools/podofoimpose/planreader_lua.cpp || die
- fi
-}
-
-src_configure() {
-
- # Bug #381359: undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
- filter-flags -fvisibility-inlines-hidden
-
- mycmakeargs+=(
- "-DPODOFO_BUILD_SHARED=1"
- "-DPODOFO_HAVE_JPEG_LIB=1"
- "-DPODOFO_HAVE_PNG_LIB=1"
- "-DPODOFO_HAVE_TIFF_LIB=1"
- "-DWANT_FONTCONFIG=1"
- "-DUSE_STLPORT=0"
- $(cmake-utils_use_want boost)
- $(cmake-utils_use_has test CPPUNIT)
- )
-
- cmake-utils_src_configure
-}
-
-src_test() {
- cd "${CMAKE_BUILD_DIR}"/test/unit
- ./podofo-test --selftest || die "self test failed"
-}