summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-05-07 09:29:31 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-05-07 09:29:31 +0000
commite7e0f60181c111ea504caecb31dc683104b50a55 (patch)
treee5b6a6545d7bfc39d35f1f1915055cc80b5236ec /app-text/pdftk
parentSmall bump, ripping out logging and --new option. (diff)
downloadgentoo-2-e7e0f60181c111ea504caecb31dc683104b50a55.tar.gz
gentoo-2-e7e0f60181c111ea504caecb31dc683104b50a55.tar.bz2
gentoo-2-e7e0f60181c111ea504caecb31dc683104b50a55.zip
version bump thanks to Vedran Miletić <rivanvx@fastmail.fm> in bug 157412
(Portage version: 2.1.2.5)
Diffstat (limited to 'app-text/pdftk')
-rw-r--r--app-text/pdftk/ChangeLog7
-rw-r--r--app-text/pdftk/files/digest-pdftk-1.413
-rw-r--r--app-text/pdftk/pdftk-1.41.ebuild44
3 files changed, 53 insertions, 1 deletions
diff --git a/app-text/pdftk/ChangeLog b/app-text/pdftk/ChangeLog
index 820b56a4b94a..67558db68c7e 100644
--- a/app-text/pdftk/ChangeLog
+++ b/app-text/pdftk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pdftk
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/ChangeLog,v 1.24 2007/05/03 08:03:02 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/ChangeLog,v 1.25 2007/05/07 09:29:31 genstef Exp $
+
+*pdftk-1.41 (07 May 2007)
+
+ 07 May 2007; Stefan Schweizer <genstef@gentoo.org> +pdftk-1.41.ebuild:
+ version bump thanks to Vedran Miletić <rivanvx@fastmail.fm> in bug 157412
03 May 2007; Markus Rothe <corsair@gentoo.org> pdftk-1.12.ebuild:
Stable on ppc64
diff --git a/app-text/pdftk/files/digest-pdftk-1.41 b/app-text/pdftk/files/digest-pdftk-1.41
new file mode 100644
index 000000000000..7d4c77f06c17
--- /dev/null
+++ b/app-text/pdftk/files/digest-pdftk-1.41
@@ -0,0 +1,3 @@
+MD5 d8057a3ae8c3af7dfc7ea110f481ad7a pdftk-1.41.tar.gz 1011368
+RMD160 09394a3d772556fa2c053bcef843b1e593feab1d pdftk-1.41.tar.gz 1011368
+SHA256 6b0ff22297b50600083bb8f6b4c507c68144b2d70738d31e0e19ab4091df5164 pdftk-1.41.tar.gz 1011368
diff --git a/app-text/pdftk/pdftk-1.41.ebuild b/app-text/pdftk/pdftk-1.41.ebuild
new file mode 100644
index 000000000000..4216b5ce0e71
--- /dev/null
+++ b/app-text/pdftk/pdftk-1.41.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/pdftk-1.41.ebuild,v 1.1 2007/05/07 09:29:31 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="A tool for manipulating PDF documents"
+HOMEPAGE="http://www.pdfhacks.com/pdftk"
+SRC_URI="http://www.pdfhacks.com/pdftk/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND=">=sys-devel/gcc-3.3"
+S=${WORKDIR}/${P}/${PN}
+
+pkg_setup() {
+ if [ -z "$(type -P gcj 2>/dev/null)" ]; then
+ eerror 'It seems that gcj is not in ${PATH}.'
+ eerror "Re-emerge sys-devel/gcc with \"gcj\" enabled."
+ die "gcj not found."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ # force usage of custom CFLAGS.
+ mv ${S}/Makefile.Generic ${T}/Makefile.Generic.orig
+ sed 's:-O2:\$(CFLAGS):g' \
+ < ${T}/Makefile.Generic.orig > ${S}/Makefile.Generic
+}
+
+src_compile() {
+ # java-config settings break compilation by gcj.
+ unset CLASSPATH
+ unset JAVA_HOME
+ make -f Makefile.Generic || die "Compilation failed."
+}
+
+src_install() {
+ dobin pdftk
+ newman ../pdftk.1.txt pdftk.1
+ dohtml ../pdftk.1.html
+}