summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-12 15:57:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-12 15:57:26 +0000
commit0a048ee23b586f4aab0801c4fbd9976e84e5ca06 (patch)
tree8ed1c65fc9867ecf514ecf40f8e45717a0ec834d /app-text/pdf2html
parentStable on ppc64 (diff)
downloadgentoo-2-0a048ee23b586f4aab0801c4fbd9976e84e5ca06.tar.gz
gentoo-2-0a048ee23b586f4aab0801c4fbd9976e84e5ca06.tar.bz2
gentoo-2-0a048ee23b586f4aab0801c4fbd9976e84e5ca06.zip
improve deps, dont prestrip files (bug #152263), honour ldflags and friends, appears to work fine here so its saved from last riting
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'app-text/pdf2html')
-rw-r--r--app-text/pdf2html/ChangeLog6
-rw-r--r--app-text/pdf2html/pdf2html-1.4.ebuild22
2 files changed, 19 insertions, 9 deletions
diff --git a/app-text/pdf2html/ChangeLog b/app-text/pdf2html/ChangeLog
index d1593883d95e..2d95d4657705 100644
--- a/app-text/pdf2html/ChangeLog
+++ b/app-text/pdf2html/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/pdf2html
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2html/ChangeLog,v 1.16 2008/01/17 20:13:18 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2html/ChangeLog,v 1.17 2008/05/12 15:57:26 aballier Exp $
+
+ 12 May 2008; Alexis Ballier <aballier@gentoo.org> pdf2html-1.4.ebuild:
+ improve deps, dont prestrip files (bug #152263), honour ldflags and
+ friends, appears to work fine here so its saved from last riting
17 Jan 2008; Fabian Groffen <grobian@gentoo.org> pdf2html-1.4.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/app-text/pdf2html/pdf2html-1.4.ebuild b/app-text/pdf2html/pdf2html-1.4.ebuild
index 2a3c249c31bc..05de196637db 100644
--- a/app-text/pdf2html/pdf2html-1.4.ebuild
+++ b/app-text/pdf2html/pdf2html-1.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2html/pdf2html-1.4.ebuild,v 1.16 2008/01/17 20:13:18 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2html/pdf2html-1.4.ebuild,v 1.17 2008/05/12 15:57:26 aballier Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Converts pdf files to html files"
SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/local/clock/pdf2html/${P}.tgz"
@@ -13,20 +13,26 @@ KEYWORDS="alpha amd64 ~ppc sparc x86"
IUSE=""
SLOT="0"
-DEPEND=">=media-libs/libpng-1.2.5
+DEPEND=">=media-libs/libpng-1.2.5"
+RDEPEND="${DEPEND}
virtual/ghostscript
- >=sys-libs/zlib-1.1.4
>=media-gfx/imagemagick-5.4.9"
src_unpack() {
unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
}
src_compile() {
- emake CFLAGS="${CFLAGS}" || die "Compile has failed"
+ tc-export CC
+ # Rewrite the Makefile as that's simpler
+ echo "LDLIBS=-lpng" > Makefile
+ echo "all: pbm2png" >> Makefile
+ emake || die "failed to compile pbm2png"
+ echo "pbm2eps9: pbm2eps9.o printer.o" > Makefile
+ emake pbm2eps9 || die "failed to compile pbm2eps9"
+
echo "cp /usr/share/${P}/*.png ." >> pdf2html
}