summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-04-25 12:30:48 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-04-25 12:30:48 +0000
commit1e86de7421f89a712dc5547b5fb3d6e070dbabb0 (patch)
tree0cd13ae70979478f0e42bae47a0bb970c1933904 /app-text/pandoc
parentRemoving ancient bash dep, adding pyparsing for --expr (diff)
downloadgentoo-2-1e86de7421f89a712dc5547b5fb3d6e070dbabb0.tar.gz
gentoo-2-1e86de7421f89a712dc5547b5fb3d6e070dbabb0.tar.bz2
gentoo-2-1e86de7421f89a712dc5547b5fb3d6e070dbabb0.zip
Initial version.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'app-text/pandoc')
-rw-r--r--app-text/pandoc/ChangeLog10
-rw-r--r--app-text/pandoc/metadata.xml21
-rw-r--r--app-text/pandoc/pandoc-1.8.1.1.ebuild68
3 files changed, 99 insertions, 0 deletions
diff --git a/app-text/pandoc/ChangeLog b/app-text/pandoc/ChangeLog
new file mode 100644
index 000000000000..535c550cb116
--- /dev/null
+++ b/app-text/pandoc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/pandoc
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.1 2011/04/25 12:30:48 slyfox Exp $
+
+*pandoc-1.8.1.1 (25 Apr 2011)
+
+ 25 Apr 2011; Sergei Trofimovich <slyfox@gentoo.org>
+ +pandoc-1.8.1.1.ebuild, +metadata.xml:
+ Initial version.
+
diff --git a/app-text/pandoc/metadata.xml b/app-text/pandoc/metadata.xml
new file mode 100644
index 000000000000..a1d842d3fdba
--- /dev/null
+++ b/app-text/pandoc/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Pandoc is a Haskell library for converting from one markup
+ format to another, and a command-line tool that uses
+ this library. It can read markdown and (subsets of)
+ reStructuredText, HTML, LaTeX and Textile, and it can write
+ markdown, reStructuredText, HTML, LaTeX, ConTeXt, Docbook,
+ OpenDocument, ODT, RTF, MediaWiki, Textile, groff man pages,
+ plain text, Emacs Org-Mode, EPUB, and S5 and Slidy HTML
+ slide shows.
+ </longdescription>
+ <use>
+ <flag name="highlight">Add support for syntax highlighting with <pkg>dev-haskell/highlighting-kate</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/app-text/pandoc/pandoc-1.8.1.1.ebuild b/app-text/pandoc/pandoc-1.8.1.1.ebuild
new file mode 100644
index 000000000000..d89ac2d313bf
--- /dev/null
+++ b/app-text/pandoc/pandoc-1.8.1.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/pandoc-1.8.1.1.ebuild,v 1.1 2011/04/25 12:30:48 slyfox Exp $
+
+# ebuild generated by hackport 0.2.11
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between markup formats"
+HOMEPAGE="http://johnmacfarlane.net/pandoc"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="highlight pdf"
+RESTRICT="test" # needs quickcheck-2.4 in tree
+
+RDEPEND=">=dev-haskell/citeproc-hs-0.3.1
+ =dev-haskell/dlist-0.5*
+ =dev-haskell/http-4000.1*
+ =dev-haskell/json-0.4*
+ <dev-haskell/mtl-2.1
+ =dev-haskell/network-2.3*
+ =dev-haskell/pandoc-types-1.8*
+ >=dev-haskell/parsec-2.1
+ =dev-haskell/tagsoup-0.12*
+ =dev-haskell/texmath-0.5*
+ =dev-haskell/utf8-string-0.3*
+ =dev-haskell/xhtml-3000.2*
+ >=dev-haskell/xml-1.3.5
+ >=dev-haskell/zip-archive-0.1.1.7
+ >=dev-lang/ghc-6.10.1
+ highlight? ( =dev-haskell/highlighting-kate-0.2.9* )
+ pdf? ( virtual/latex-base )
+ "
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+pandoc_init() {
+ pandoc="${PN}"
+ pdfscript="markdown2pdf"
+}
+
+installMan() {
+ local prog=$1
+ doman "${S}/man/man1/${prog}.1"
+}
+
+src_compile() {
+ cabal_src_compile \
+ $(cabal_flag highlight highlighting)
+}
+
+src_install() {
+ pandoc_init
+ cabal_src_install
+
+ installMan "${pandoc}"
+ use pdf && installMan "${pdfscript}"
+
+ # COPYING is installed by the Cabal eclass
+ dodoc README COPYRIGHT changelog
+}