summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-07-13 17:33:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-07-13 17:33:38 +0000
commitc2bc34e4edd00789a3b0e4fbe5eed13ccbb5394b (patch)
treebefbbb0f54c9835f5802bc4232e9b4e32b438892 /app-text/mecab/mecab-0.80.ebuild
parentNot sparc stable (diff)
downloadgentoo-2-c2bc34e4edd00789a3b0e4fbe5eed13ccbb5394b.tar.gz
gentoo-2-c2bc34e4edd00789a3b0e4fbe5eed13ccbb5394b.tar.bz2
gentoo-2-c2bc34e4edd00789a3b0e4fbe5eed13ccbb5394b.zip
restore ebuild still in use
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-text/mecab/mecab-0.80.ebuild')
-rw-r--r--app-text/mecab/mecab-0.80.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/mecab/mecab-0.80.ebuild b/app-text/mecab/mecab-0.80.ebuild
new file mode 100644
index 000000000000..ade9fd29097b
--- /dev/null
+++ b/app-text/mecab/mecab-0.80.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.80.ebuild,v 1.11 2007/07/13 17:33:38 mr_bones_ Exp $
+
+# need one of ipadic-2.4.4/2.5.0/2.5.1
+MY_IPADIC="ipadic-2.5.1"
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="http://chasen.org/~taku/software/mecab/"
+SRC_URI="http://chasen.org/~taku/software/mecab/src/${P}.tar.gz
+ http://chasen.naist.jp/stable/ipadic/${MY_IPADIC}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="unicode"
+
+DEPEND="dev-lang/perl"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}/dic
+ unpack ${MY_IPADIC}.tar.gz
+}
+
+src_compile() {
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}