summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-09-11 19:34:04 +0000
committerDan Armak <danarmak@gentoo.org>2002-09-11 19:34:04 +0000
commita0cd677c975e4d5eb6670ab29b1cc86234fbeb33 (patch)
tree8cf86446a66bb6985ac31ebd6d3116eb3f86fbc0 /app-text/kbedic
parentVersion bump, should close #6687 (diff)
downloadgentoo-2-a0cd677c975e4d5eb6670ab29b1cc86234fbeb33.tar.gz
gentoo-2-a0cd677c975e4d5eb6670ab29b1cc86234fbeb33.tar.bz2
gentoo-2-a0cd677c975e4d5eb6670ab29b1cc86234fbeb33.zip
new qt3/kde3 version
Diffstat (limited to 'app-text/kbedic')
-rw-r--r--app-text/kbedic/ChangeLog10
-rw-r--r--app-text/kbedic/files/digest-kbedic-3.11
-rw-r--r--app-text/kbedic/files/kbedic-3.1-gcc3.diff84
-rw-r--r--app-text/kbedic/files/kbedic-3.1-location.diff32
-rw-r--r--app-text/kbedic/kbedic-3.1.ebuild43
5 files changed, 168 insertions, 2 deletions
diff --git a/app-text/kbedic/ChangeLog b/app-text/kbedic/ChangeLog
index b11d04b53d90..b702c8d1876f 100644
--- a/app-text/kbedic/ChangeLog
+++ b/app-text/kbedic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/kbedic
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbedic/ChangeLog,v 1.2 2002/08/02 17:42:49 phoenix Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbedic/ChangeLog,v 1.3 2002/09/11 19:34:04 danarmak Exp $
+
+*kbedic-3.1 (11 Sep 2002)
+
+ 11 Sep 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ A new version, which works with kde/qt3.
*kbedic-2.1 (1 Feb 2002)
diff --git a/app-text/kbedic/files/digest-kbedic-3.1 b/app-text/kbedic/files/digest-kbedic-3.1
new file mode 100644
index 000000000000..52440031987e
--- /dev/null
+++ b/app-text/kbedic/files/digest-kbedic-3.1
@@ -0,0 +1 @@
+MD5 9dc7cc763558637f342039c2184d505d kbedic-3.1.tar.gz 3037137
diff --git a/app-text/kbedic/files/kbedic-3.1-gcc3.diff b/app-text/kbedic/files/kbedic-3.1-gcc3.diff
new file mode 100644
index 000000000000..281f30b1d80d
--- /dev/null
+++ b/app-text/kbedic/files/kbedic-3.1-gcc3.diff
@@ -0,0 +1,84 @@
+--- src/registry.cpp Wed Aug 14 17:24:43 2002
++++ src/registry.cpp Wed Sep 11 20:22:43 2002
+@@ -79,7 +79,7 @@
+ //=== Get String =========================================================
+ // Return the value of key, if missed return default value
+ //========================================================================
+-char *Registry::getString(const char *property, const char *defaultValue = "") {
++char *Registry::getString(const char *property, const char *defaultValue) {
+ bool found = false;
+ char *ret = NULL;
+ FILE *f;
+@@ -113,7 +113,7 @@
+ //=== Get Int ============================================================
+ // Return the value of key, if missed return default value
+ //========================================================================
+-int Registry::getInt(const char *property, const int defaultValue = 0) {
++int Registry::getInt(const char *property, const int defaultValue) {
+ int ret = defaultValue;
+ char *p;
+ p = getString(property);
+@@ -141,7 +141,7 @@
+ //=== Get Bool ===========================================================
+ // Return the value of key, if missed return default value
+ //========================================================================
+-bool Registry::getBool(const char *property, const bool defaultValue = false) {
++bool Registry::getBool(const char *property, const bool defaultValue) {
+ bool ret = defaultValue;
+ char *p;
+ p = getString(property);
+--- src/database.cpp Wed Aug 14 17:24:43 2002
++++ src/database.cpp Wed Sep 11 20:30:55 2002
+109c109
+< bool Database::createDictionary(const char *fileName, const long fixedLastWordPointer = 0) {
+---
+> bool Database::createDictionary(const char *fileName, const long fixedLastWordPointer) {
+--- src/translator.cpp Wed Aug 14 17:24:43 2002
++++ src/translator.cpp Wed Sep 11 20:30:55 2002
+@@ -119,7 +119,7 @@
+ // Real construcor
+ // Call the same method of Database, and return same result
+ //========================================================================
+-bool Translator::createDictionary(const char *fileName, const int dictionary, const long fixedLastWordPointer = 0) {
++bool Translator::createDictionary(const char *fileName, const int dictionary, const long fixedLastWordPointer) {
+ bool ret = false;
+ switch (dictionary) {
+ case ENG_BUL:
+@@ -275,7 +275,7 @@
+ // Return true if passed word is legal bulgarian word as LATIN_INPUT
+ // Return pointer to new word that is legal dictionary word
+ //========================================================================
+-bool Translator::isLatinInput(const char *word, char *buf, const bool ignoreSpace = false) {
++bool Translator::isLatinInput(const char *word, char *buf, const bool ignoreSpace) {
+ int i = 0;
+ char *p;
+ while (word[i] != '\0') {
+@@ -304,7 +304,7 @@
+ // to a normal latin output
+ // Change buffer and return pointer to new word
+ //========================================================================
+-char *Translator::toLatin(const char *word, char *buf, const bool legalLatinInput = true) {
++char *Translator::toLatin(const char *word, char *buf, const bool legalLatinInput) {
+ int i = 0;
+ int j = 0;
+ char *p;
+@@ -348,7 +348,7 @@
+ // Call the same method of Database, and return same result
+ // But perform some operations
+ //========================================================================
+-char *Translator::getWord(const bool lowerCase = true, const bool legalLatinInput = true) {
++char *Translator::getWord(const bool lowerCase, const bool legalLatinInput) {
+ char *ret = NULL;
+ switch (currentDictionary) {
+ case ENG_BUL:
+--- src/win.cpp Wed Aug 14 17:24:43 2002
++++ src/win.cpp Wed Sep 11 21:27:21 2002
+@@ -214,7 +214,7 @@
+ // Create GUI
+ // Init objects and set default variables
+ //========================================================================
+-Win::Win(QWidget *parent = 0, const char *name = 0):QMainWindow(parent, name) {
++Win::Win(QWidget *parent, const char *name):QMainWindow(parent, name) {
+
+ // Init some variables
+ fromSystemHighlighted = false;
diff --git a/app-text/kbedic/files/kbedic-3.1-location.diff b/app-text/kbedic/files/kbedic-3.1-location.diff
new file mode 100644
index 000000000000..08c71f6298ff
--- /dev/null
+++ b/app-text/kbedic/files/kbedic-3.1-location.diff
@@ -0,0 +1,32 @@
+diff -ur kbedic-3.1.orig/data/Makefile.in kbedic-3.1/data/Makefile.in
+--- data/Makefile.in Wed Aug 14 17:24:36 2002
++++ data/Makefile.in Wed Sep 11 22:00:11 2002
+@@ -115,12 +115,12 @@
+ uninstall-info-am:
+ install-dataDATA: $(data_DATA)
+ @$(NORMAL_INSTALL)
+- $(mkinstalldirs) $(DESTDIR)$(datadir)
++ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)
+ @list='$(data_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(datadir)/$$f"; \
+- $(INSTALL_DATA) $$d$$p $(DESTDIR)$(datadir)/$$f; \
++ echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(pkgdatadir)/$$f"; \
++ $(INSTALL_DATA) $$d$$p $(DESTDIR)$(pkgdatadir)/$$f; \
+ done
+
+ uninstall-dataDATA:
+diff -ur kbedic-3.1.orig/src/config.h.in kbedic-3.1/src/config.h.in
+--- src/config.h.in Wed Aug 14 17:24:43 2002
++++ src/config.h.in Wed Sep 11 22:00:24 2002
+@@ -8,7 +8,7 @@
+
+
+ // Path to Database
+-#define ENG_BUL_DAT_CONFIG "@DATA_DIR@/engbul.dat"
+-#define BUL_ENG_DAT_CONFIG "@DATA_DIR@/buleng.dat"
++#define ENG_BUL_DAT_CONFIG "@DATA_DIR@/kbedic/engbul.dat"
++#define BUL_ENG_DAT_CONFIG "@DATA_DIR@/kbedic/buleng.dat"
+
+ #endif
diff --git a/app-text/kbedic/kbedic-3.1.ebuild b/app-text/kbedic/kbedic-3.1.ebuild
new file mode 100644
index 000000000000..e92c5aa17828
--- /dev/null
+++ b/app-text/kbedic/kbedic-3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbedic/kbedic-3.1.ebuild,v 1.1 2002/09/11 19:34:04 danarmak Exp $
+inherit kde
+
+S=${WORKDIR}/${P}
+DESCRIPTION="English <-> Bulgarian Dictionary"
+SRC_URI="mirror://sourceforge/kbedic/$P.tar.gz"
+HOMEPAGE="http://kbedic.sourceforge.net"
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+need-qt 3
+[ -n "`use kde`" ] && need-kde 3
+
+# -gcc3 is a typical "default value present in both definition and declaration" fix.
+# -location makes it isntall the dictionary datafiles in /usr/share/kbedic,
+# and not directly in /usr/share. Both sent upstream.
+PATCHES="$FILESDIR/$P-gcc3.diff $FILESDIR/$P-location.diff"
+
+src_compile() {
+
+ local myopts
+ if [ -n "`use kde`" ]
+ then
+ myopts="--with-kde"
+ set-kdedir 3
+ fi
+
+ need-automake 1.6
+ need-autoconf 2.5
+
+ aclocal
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ ${myopts} || die
+
+ emake || die
+
+}
+