summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-05-28 21:07:19 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-05-28 21:07:19 +0000
commita704b1d2b8765d5063a3105e101ed0df454c1d7c (patch)
tree2a6ded8e47bee77015cf66bfa7aaccf40e925cea /app-text/kbarcode/kbarcode-2.0.3.ebuild
parenthppa stable, bug #129675 (diff)
downloadgentoo-2-a704b1d2b8765d5063a3105e101ed0df454c1d7c.tar.gz
gentoo-2-a704b1d2b8765d5063a3105e101ed0df454c1d7c.tar.bz2
gentoo-2-a704b1d2b8765d5063a3105e101ed0df454c1d7c.zip
Version bump.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'app-text/kbarcode/kbarcode-2.0.3.ebuild')
-rw-r--r--app-text/kbarcode/kbarcode-2.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/kbarcode/kbarcode-2.0.3.ebuild b/app-text/kbarcode/kbarcode-2.0.3.ebuild
new file mode 100644
index 000000000000..db9f58f5b413
--- /dev/null
+++ b/app-text/kbarcode/kbarcode-2.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbarcode/kbarcode-2.0.3.ebuild,v 1.1 2006/05/28 21:07:19 carlo Exp $
+
+inherit kde
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="KBarcode is a barcode and label printing application for KDE."
+HOMEPAGE="http://www.kbarcode.net/"
+SRC_URI="mirror://sourceforge/kbarcode/${MY_P}.tar.gz
+ doc? ( mirror://sourceforge/kbarcode/${PN}-2.0.0.pdf )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND=">=app-text/barcode-0.98"
+
+RDEPEND=">=app-text/barcode-0.98
+ virtual/ghostscript"
+
+need-kde 3.4
+
+src_install() {
+ kde_src_install
+ use doc && cp ${DISTDIR}/${P}.pdf ${D}/usr/share/doc/${PF}
+} \ No newline at end of file