summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-03 09:59:04 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-03 09:59:04 +0000
commitd63d565dbc89c544e29ff39b0207ed09f3ed602e (patch)
tree7d96500879cbe9bcd341567e7239ee59e26bfa0f /app-text/hunspell
parentversion bump; 1030 was removed upstream... bug #245127 (diff)
downloadgentoo-2-d63d565dbc89c544e29ff39b0207ed09f3ed602e.tar.gz
gentoo-2-d63d565dbc89c544e29ff39b0207ed09f3ed602e.tar.bz2
gentoo-2-d63d565dbc89c544e29ff39b0207ed09f3ed602e.zip
Version bump.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-openvz.git-35f41f1 i686)
Diffstat (limited to 'app-text/hunspell')
-rw-r--r--app-text/hunspell/ChangeLog7
-rw-r--r--app-text/hunspell/hunspell-1.2.8.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/app-text/hunspell/ChangeLog b/app-text/hunspell/ChangeLog
index b77ade3855c3..42d44b98103d 100644
--- a/app-text/hunspell/ChangeLog
+++ b/app-text/hunspell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/hunspell
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.49 2008/09/26 06:13:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.50 2008/11/03 09:59:04 pva Exp $
+
+*hunspell-1.2.8 (03 Nov 2008)
+
+ 03 Nov 2008; Peter Volkov <pva@gentoo.org> +hunspell-1.2.8.ebuild:
+ Version bump.
26 Sep 2008; Raúl Porcel <armin76@gentoo.org> hunspell-1.2.7.ebuild:
Add ~arm
diff --git a/app-text/hunspell/hunspell-1.2.8.ebuild b/app-text/hunspell/hunspell-1.2.8.ebuild
new file mode 100644
index 000000000000..f0724a32b434
--- /dev/null
+++ b/app-text/hunspell/hunspell-1.2.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/hunspell-1.2.8.ebuild,v 1.1 2008/11/03 09:59:04 pva Exp $
+
+inherit eutils multilib autotools
+
+MY_P=${PN}-${PV/_beta/b}
+
+DESCRIPTION="Hunspell spell checker - an improved replacement for myspell in OOo."
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://hunspell.sourceforge.net/"
+
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE="ncurses nls readline"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )
+ sys-devel/gettext"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Upstream package creates some executables which names are too generic
+ # to be placed in /usr/bin - this patch prefixes them with 'hunspell-'.
+ # It modifies a Makefile.am file, hence eautoreconf.
+ epatch "${FILESDIR}"/${PN}-1.2.2-renameexes.patch
+ eautoreconf
+}
+
+src_compile() {
+ # I wanted to put the include files in /usr/include/hunspell
+ # but this means the openoffice build won't find them.
+ econf \
+ $(use_enable nls) \
+ $(use_with ncurses ui) \
+ $(use_with readline readline)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO license.hunspell || die "installing docs failed"
+ # hunspell is derived from myspell
+ dodoc AUTHORS.myspell README.myspell license.myspell || die "installing myspell docs failed"
+}
+
+pkg_postinst() {
+ elog "To use this package you will also need a dictionary."
+ elog "Hunspell uses myspell format dictionaries; find them"
+ elog "in the app-dicts category as myspell-<LANG>."
+}