summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-05 18:30:13 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-05 18:30:13 +0000
commit44da31ef95397bf6c1017239ff7046c2b24928a7 (patch)
treea6d2111e34faf97da5512dc5fed59fdeb6a19d3d /app-text/htag
parentVersion Bump, Some Clean up (diff)
downloadgentoo-2-44da31ef95397bf6c1017239ff7046c2b24928a7.tar.gz
gentoo-2-44da31ef95397bf6c1017239ff7046c2b24928a7.tar.bz2
gentoo-2-44da31ef95397bf6c1017239ff7046c2b24928a7.zip
Some Clean up
(Portage version: 2.2.0_alpha12/cvs/Linux x86_64)
Diffstat (limited to 'app-text/htag')
-rw-r--r--app-text/htag/ChangeLog8
-rw-r--r--app-text/htag/htag-0.0.23.ebuild16
-rw-r--r--app-text/htag/htag-0.0.24.ebuild8
3 files changed, 20 insertions, 12 deletions
diff --git a/app-text/htag/ChangeLog b/app-text/htag/ChangeLog
index 17480d718fdc..3d091d652f33 100644
--- a/app-text/htag/ChangeLog
+++ b/app-text/htag/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/htag
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htag/ChangeLog,v 1.14 2010/01/03 12:25:13 tove Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/htag/ChangeLog,v 1.15 2011/01/05 18:30:13 jlec Exp $
+
+ 05 Jan 2011; Justin Lecher <jlec@gentoo.org> htag-0.0.23.ebuild,
+ htag-0.0.24.ebuild:
+ Some Clean up
*htag-0.0.24 (03 Jan 2010)
diff --git a/app-text/htag/htag-0.0.23.ebuild b/app-text/htag/htag-0.0.23.ebuild
index 7ae68a38441f..98a22f757910 100644
--- a/app-text/htag/htag-0.0.23.ebuild
+++ b/app-text/htag/htag-0.0.23.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htag/htag-0.0.23.ebuild,v 1.5 2007/08/24 06:25:45 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htag/htag-0.0.23.ebuild,v 1.6 2011/01/05 18:30:13 jlec Exp $
+
+inherit perl-app
DESCRIPTION="random signature maker"
HOMEPAGE="http://www.earth.li/projectpurple/progs/htag.html"
@@ -12,19 +14,21 @@ KEYWORDS="x86 ~amd64 ~sparc ~mips ~ppc"
IUSE=""
RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
src_install() {
newbin htag.pl htag || die "newbin failed"
dodir /usr/share/doc/${PF}/
- mv docs/sample-config ${D}/usr/share/doc/${PF}/
- dodoc docs/*
- docinto example-scripts ; dodoc example-scripts/*
+ mv docs/sample-config "${D}"/usr/share/doc/${PF}/
+ dodoc docs/* || die
+ docinto example-scripts
+ dodoc example-scripts/* || die
prepalldocs
insinto /usr/share/htag/plugins
doins plugins/* || die "failed to install plugins"
- insinto /usr/lib/perl5/site_perl
+ insinto "${VENDOR_LIB}"
doins HtagPlugin/HtagPlugin.pm || die "failed to install perl module"
}
diff --git a/app-text/htag/htag-0.0.24.ebuild b/app-text/htag/htag-0.0.24.ebuild
index 33d936997c87..9b88cd61e53e 100644
--- a/app-text/htag/htag-0.0.24.ebuild
+++ b/app-text/htag/htag-0.0.24.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htag/htag-0.0.24.ebuild,v 1.1 2010/01/03 12:25:13 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htag/htag-0.0.24.ebuild,v 1.2 2011/01/05 18:30:13 jlec Exp $
inherit perl-app
@@ -21,9 +21,9 @@ src_install() {
dodir /usr/share/doc/${PF}/
mv docs/sample-config "${D}"/usr/share/doc/${PF}/
- dodoc docs/*
+ dodoc docs/* || die
docinto example-scripts
- dodoc example-scripts/*
+ dodoc example-scripts/* || die
prepalldocs
insinto /usr/share/htag/plugins