summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-16 23:42:55 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-16 23:42:55 +0000
commit595a44566d2af0521ae7306be9a9ed3a1003b92d (patch)
treef9645f374e0df6cfb484462fe047aea640b68b7a /app-text/gtkspell
parentRewrite, commit split 1.6.0 packages and live ebuilds for packages in 1.6.0 r... (diff)
downloadgentoo-2-595a44566d2af0521ae7306be9a9ed3a1003b92d.tar.gz
gentoo-2-595a44566d2af0521ae7306be9a9ed3a1003b92d.tar.bz2
gentoo-2-595a44566d2af0521ae7306be9a9ed3a1003b92d.zip
Bump to 2.0.15. Support for use in C++ code, integrate with devhelp, closes #262103.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'app-text/gtkspell')
-rw-r--r--app-text/gtkspell/ChangeLog11
-rw-r--r--app-text/gtkspell/gtkspell-2.0.15.ebuild34
2 files changed, 43 insertions, 2 deletions
diff --git a/app-text/gtkspell/ChangeLog b/app-text/gtkspell/ChangeLog
index 9c39e4879a0d..1001c9a86a80 100644
--- a/app-text/gtkspell/ChangeLog
+++ b/app-text/gtkspell/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/gtkspell
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.70 2008/11/22 16:11:33 jer Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.71 2009/03/16 23:42:55 eva Exp $
+
+*gtkspell-2.0.15 (16 Mar 2009)
+
+ 16 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtkspell-2.0.15.ebuild:
+ Bump to 2.0.15. Support for use in C++ code, integrate with devhelp,
+ closes #262103.
22 Nov 2008; Jeroen Roovers <jer@gentoo.org> gtkspell-2.0.14.ebuild:
Stable for HPPA (bug #246054).
diff --git a/app-text/gtkspell/gtkspell-2.0.15.ebuild b/app-text/gtkspell/gtkspell-2.0.15.ebuild
new file mode 100644
index 000000000000..9f2d06b35619
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-2.0.15.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.15.ebuild,v 1.1 2009/03/16 23:42:55 eva Exp $
+
+inherit eutils
+
+DESCRIPTION="Spell checking widget for GTK2"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+# gtkspell doesn't use sourceforge mirroring system it seems.
+SRC_URI="http://${PN}.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=app-text/enchant-1.1.6"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ doc? ( >=dev-util/gtk-doc-1
+ =app-text/docbook-xml-dtd-4.2* )"
+
+src_compile() {
+ econf $(use_enable doc gtk-doc)
+ emake || die "compile failure"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}