summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-12-27 19:16:44 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-12-27 19:16:44 +0000
commitf48adb303e7607b3b87983dccbed7f15b3b98fee (patch)
treea02f5c50982f0a827522a743aaaccba2b52da0ad /app-text/glark
parentMoved from app-sci/geda to sci-electronics/geda (diff)
downloadgentoo-2-f48adb303e7607b3b87983dccbed7f15b3b98fee.tar.gz
gentoo-2-f48adb303e7607b3b87983dccbed7f15b3b98fee.tar.bz2
gentoo-2-f48adb303e7607b3b87983dccbed7f15b3b98fee.zip
New version, bug #75814. Now with bash-completion goodness.
Diffstat (limited to 'app-text/glark')
-rw-r--r--app-text/glark/ChangeLog8
-rw-r--r--app-text/glark/Manifest13
-rw-r--r--app-text/glark/files/1.7.2/glark-completion31
-rw-r--r--app-text/glark/files/digest-glark-1.7.21
-rw-r--r--app-text/glark/glark-1.7.2.ebuild32
5 files changed, 74 insertions, 11 deletions
diff --git a/app-text/glark/ChangeLog b/app-text/glark/ChangeLog
index 6af7de5ec9eb..0fc7623a4d04 100644
--- a/app-text/glark/ChangeLog
+++ b/app-text/glark/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/glark
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/glark/ChangeLog,v 1.20 2004/12/20 15:40:48 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/ChangeLog,v 1.21 2004/12/27 19:16:44 ciaranm Exp $
+
+*glark-1.7.2 (27 Dec 2004)
+
+ 27 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org>
+ +files/1.7.2/glark-completion, +glark-1.7.2.ebuild:
+ New version, bug #75814. Now with bash-completion goodness.
*glark-1.7.1 (20 Dec 2004)
diff --git a/app-text/glark/Manifest b/app-text/glark/Manifest
index ca7f52c4cea4..454bd2a87c0b 100644
--- a/app-text/glark/Manifest
+++ b/app-text/glark/Manifest
@@ -1,16 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 d70bc598aee8379fcca56856e6e9e7fc glark-1.7.0.ebuild 667
MD5 9213cc2ac5886970925fb85d54f62b2f ChangeLog 2509
MD5 8a93f0a469a8e0a79f4191d941d9594a glark-1.7.1.ebuild 672
+MD5 87679e3a38560da91e9dd4dc31a12cb8 glark-1.7.2.ebuild 757
MD5 cc91d79e8dc6f0d1b9727eb83de5f98a metadata.xml 258
MD5 45ca54fe2662478c83bf160831b2aea9 files/digest-glark-1.7.1 62
+MD5 67bdc0662f2ad93234cf0299b10fb028 files/digest-glark-1.7.2 62
MD5 16965b8cb4e088ce14ac964bf473d124 files/digest-glark-1.7.0 62
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBxvLHLLFUmVNQ7rkRAuZlAKDV4xTA5LZ0PcKBeK5+VXuzUhctLgCdHJ/D
-OSPqSMrZCcZoJexcPn+CQII=
-=QWpD
------END PGP SIGNATURE-----
+MD5 9b0139902e8fa81c7922c08cc4cff23f files/1.7.2/glark-completion 994
diff --git a/app-text/glark/files/1.7.2/glark-completion b/app-text/glark/files/1.7.2/glark-completion
new file mode 100644
index 000000000000..4cd470e03705
--- /dev/null
+++ b/app-text/glark/files/1.7.2/glark-completion
@@ -0,0 +1,31 @@
+# Author: Ciaran McCreesh <ciaranm@gentoo.org>
+#
+# completion for glark
+
+_glark()
+{
+ local cur
+
+ COMPREPLY=()
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ if [[ "${cur}" == -* ]] || [[ ${COMP_CWORD} -eq 1 ]] ; then
+ COMPREPLY=( $( compgen -W ' --directories --binary-files --basename \
+ --name --fullname --path --exclude-matching --recurse \
+ --split-as-path --no-split-as-path --and --before --after \
+ --file --ignore-case --match-limit --or --range \
+ --invert-match --word --word-regexp --line-regexp --xor \
+ --after-context --before-context --context --count \
+ --file-color --no-filter --grep --no-filename --with-filename \
+ --files-with-matches --files-without-match --line-number \
+ --no-line-number --line-number-color --text-color --highlight \
+ --no-highlight --extract-matches --null --help --config \
+ --explain --quiet --no-messages --no-quiet --version \
+ --verbose' -- $cur ) )
+ else
+ _filedir
+ fi
+}
+
+complete -F _glark glark
diff --git a/app-text/glark/files/digest-glark-1.7.2 b/app-text/glark/files/digest-glark-1.7.2
new file mode 100644
index 000000000000..9a313651e53e
--- /dev/null
+++ b/app-text/glark/files/digest-glark-1.7.2
@@ -0,0 +1 @@
+MD5 38b3250313ce1974afb43b39b083ba5c glark-1.7.2.tar.gz 33092
diff --git a/app-text/glark/glark-1.7.2.ebuild b/app-text/glark/glark-1.7.2.ebuild
new file mode 100644
index 000000000000..465468912346
--- /dev/null
+++ b/app-text/glark/glark-1.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/glark-1.7.2.ebuild,v 1.1 2004/12/27 19:16:44 ciaranm Exp $
+
+inherit bash-completion
+
+DESCRIPTION="File searcher similar to grep but with fancy output"
+HOMEPAGE="http://glark.sourceforge.net/"
+SRC_URI="mirror://sourceforge/glark/${P}.tar.gz"
+
+KEYWORDS="~x86 ~sparc ~ppc ~mips ~amd64"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+# perl dep is for pod2man
+DEPEND="virtual/ruby
+ dev-lang/perl"
+RDEPEND="virtual/ruby"
+
+src_compile() {
+ emake
+ # force the manpage to be rebuilt
+ rm ${PN}.1
+ make ${PN}.1
+}
+
+src_install () {
+ make DESTDIR=${D} install
+ dobashcompletion ${FILESDIR}/${PV}/glark-completion ${PN}
+}
+