summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandy Westcott <brandy@gentoo.org>2003-10-30 04:07:56 +0000
committerBrandy Westcott <brandy@gentoo.org>2003-10-30 04:07:56 +0000
commit0a3f6eff955aae07967a8df9a2212a209a6d767b (patch)
treeaa7b866ee83f255324730fa22473db3f2f7ed018 /app-text/expander/files
parentnew modules for tc2 (diff)
downloadgentoo-2-0a3f6eff955aae07967a8df9a2212a209a6d767b.tar.gz
gentoo-2-0a3f6eff955aae07967a8df9a2212a209a6d767b.tar.bz2
gentoo-2-0a3f6eff955aae07967a8df9a2212a209a6d767b.zip
Initial import. Closes bug #30604.
Diffstat (limited to 'app-text/expander/files')
-rw-r--r--app-text/expander/files/digest-expander-2.0.51
-rw-r--r--app-text/expander/files/expander-2.0.5-gentoo.patch59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-text/expander/files/digest-expander-2.0.5 b/app-text/expander/files/digest-expander-2.0.5
new file mode 100644
index 000000000000..a27928fa6ac7
--- /dev/null
+++ b/app-text/expander/files/digest-expander-2.0.5
@@ -0,0 +1 @@
+MD5 e8a2b0ec7b23f9943a5403ac3df7b5b3 nedit_expander_kit_2.05.tar.gz 92571
diff --git a/app-text/expander/files/expander-2.0.5-gentoo.patch b/app-text/expander/files/expander-2.0.5-gentoo.patch
new file mode 100644
index 000000000000..e6c023834939
--- /dev/null
+++ b/app-text/expander/files/expander-2.0.5-gentoo.patch
@@ -0,0 +1,59 @@
+diff -ur expander/src/Makefile expander-gentoo/src/Makefile
+--- expander/src/Makefile 2003-10-30 14:52:00.000000000 +1300
++++ expander-gentoo/src/Makefile 2003-10-30 15:50:02.000000000 +1300
+@@ -3,15 +3,14 @@
+ bindir = $(BINDIR)/
+
+ copy = ln -fs
+-CFLAGS += -v -g # -DNEED_GETOPT_PROTO_TYPE
+-compiler = cc $(CFLAGS)
++compiler = gcc $(CFLAGS)
+
+ executables = expander boxcomment align_columns align_comments where_is
+
+ #--------------
+ # Build Targets
+ #--------------
+-all: verify $(executables)
++all: $(executables)
+
+ verify:
+ @if [ "$(bindir)" = "/" ]; then \
+@@ -24,32 +23,31 @@
+ # Abbreviation expansion filter program (with NEdit, language sensitive)
+ #-----------------------------------------------------------------------
+ expander: expander.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) -o $@ $?
+
+ #--------------------------------------------------------------------------
+ # Surround given text with open ended box. (with NEdit, language sensitive)
+ #--------------------------------------------------------------------------
+ boxcomment: boxcomment.c
+- $(compiler) -o $(bindir)$@ $?
+- @if [ ! -f $(bindir)un$@ ]; then $(copy) $(bindir)$@ $(bindir)un$@; fi
++ $(compiler) -o $@ $?
+
+ #-------------------------------------------------------------------------------
+ # Align ragged looking 'C' style comments (good substitute for align_equals too)
+ #-------------------------------------------------------------------------------
+ align_comments: align_comments.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) -o $@ $?
+
+ #----------------------------
+ # Align given text in columns
+ #----------------------------
+ align_columns: align_columns.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) -o $@ $?
+
+ #----------------------------------------------
+ # File locator (substitute for which, where...)
+ #----------------------------------------------
+ where_is: where_is.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) -o $@ $?
+
+ #------------------------------------------------
+ # Here is how to uninstall the executables built.