summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-05-01 17:01:40 +0000
committerPeter Volkov <pva@gentoo.org>2007-05-01 17:01:40 +0000
commit771eedbf6958a9e9f02f41570ee151eb7e34aa3b (patch)
tree3b82b666d8e9fa1b3bd5eb943389b1b4a343b2be /app-text/dos2unix
parentVersion bumped. (diff)
downloadgentoo-2-771eedbf6958a9e9f02f41570ee151eb7e34aa3b.tar.gz
gentoo-2-771eedbf6958a9e9f02f41570ee151eb7e34aa3b.tar.bz2
gentoo-2-771eedbf6958a9e9f02f41570ee151eb7e34aa3b.zip
Fixed bug #174776. Thank Toralf Förster for report.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/ChangeLog9
-rw-r--r--app-text/dos2unix/dos2unix-3.1-r2.ebuild38
-rw-r--r--app-text/dos2unix/dos2unix-3.1.ebuild37
-rw-r--r--app-text/dos2unix/files/digest-dos2unix-3.1-r2 (renamed from app-text/dos2unix/files/digest-dos2unix-3.1)0
-rw-r--r--app-text/dos2unix/files/dos2unix-3.1-workaround-rename-EXDEV.patch56
5 files changed, 102 insertions, 38 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index 008125890006..bc66eb41ab0e 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/dos2unix
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.25 2007/02/08 21:12:38 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.26 2007/05/01 17:01:40 pva Exp $
+
+*dos2unix-3.1-r2 (01 May 2007)
+
+ 01 May 2007; <pva@gentoo.org>
+ +files/dos2unix-3.1-workaround-rename-EXDEV.patch, -dos2unix-3.1.ebuild,
+ +dos2unix-3.1-r2.ebuild:
+ Fixed bug #174776. Thank Toralf Förster for report.
08 Feb 2007; Fabian Groffen <grobian@gentoo.org> dos2unix-3.1.ebuild,
dos2unix-3.1-r1.ebuild:
diff --git a/app-text/dos2unix/dos2unix-3.1-r2.ebuild b/app-text/dos2unix/dos2unix-3.1-r2.ebuild
new file mode 100644
index 000000000000..507bfe1556fb
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-3.1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-3.1-r2.ebuild,v 1.1 2007/05/01 17:01:40 pva Exp $
+
+inherit eutils
+
+DESCRIPTION="Dos2unix converts DOS or MAC text files to UNIX format"
+HOMEPAGE="none"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-text/hd2u"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.patch
+ epatch "${FILESDIR}"/${P}-segfault.patch
+ epatch "${FILESDIR}"/${P}-includes.patch
+ epatch "${FILESDIR}"/${P}-preserve-file-modes.patch
+ epatch "${FILESDIR}"/${P}-manpage-update.patch
+ epatch "${FILESDIR}"/${P}-safeconv.patch
+ epatch "${FILESDIR}"/${P}-workaround-rename-EXDEV.patch
+ make -s clean || die
+}
+
+src_install() {
+ dobin dos2unix || die
+ dosym dos2unix /usr/bin/mac2unix
+
+ doman dos2unix.1
+ dosym dos2unix.1 /usr/share/man/man1/mac2unix.1
+}
diff --git a/app-text/dos2unix/dos2unix-3.1.ebuild b/app-text/dos2unix/dos2unix-3.1.ebuild
deleted file mode 100644
index 34897229002f..000000000000
--- a/app-text/dos2unix/dos2unix-3.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-3.1.ebuild,v 1.21 2007/02/08 21:12:38 grobian Exp $
-
-inherit eutils
-
-DESCRIPTION="Dos2unix converts DOS or MAC text files to UNIX format"
-HOMEPAGE="I HAVE NO HOME :("
-SRC_URI="http://www2.tripleg.net.au/dos2unix.builder/${P}.tar.bz2"
-
-LICENSE="freedist"
-SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ppc64"
-IUSE=""
-
-DEPEND=""
-RDEPEND="!app-text/hd2u"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}.patch
- epatch ${FILESDIR}/${P}-segfault.patch
-}
-
-src_compile() {
- make clean || die
- make CFLAGS="${CFLAGS}" || die
-}
-
-src_install() {
- dobin dos2unix || die
- dosym dos2unix /usr/bin/mac2unix
-
- doman dos2unix.1
- dosym dos2unix.1.gz /usr/share/man/man1/mac2unix.1.gz
-}
diff --git a/app-text/dos2unix/files/digest-dos2unix-3.1 b/app-text/dos2unix/files/digest-dos2unix-3.1-r2
index a0cd4541c73e..a0cd4541c73e 100644
--- a/app-text/dos2unix/files/digest-dos2unix-3.1
+++ b/app-text/dos2unix/files/digest-dos2unix-3.1-r2
diff --git a/app-text/dos2unix/files/dos2unix-3.1-workaround-rename-EXDEV.patch b/app-text/dos2unix/files/dos2unix-3.1-workaround-rename-EXDEV.patch
new file mode 100644
index 000000000000..71a3a697e5dd
--- /dev/null
+++ b/app-text/dos2unix/files/dos2unix-3.1-workaround-rename-EXDEV.patch
@@ -0,0 +1,56 @@
+--- ./dos2unix.c.orig 2007-04-17 11:16:32.000000000 +0400
++++ ./dos2unix.c 2007-04-17 12:41:01.000000000 +0400
+@@ -279,7 +279,7 @@
+ int RetVal = 0;
+ FILE *InF = NULL;
+ FILE *TempF = NULL;
+- char TempPath[16];
++ char *TempPath = (char *) malloc(sizeof(char) * strlen(ipInFN)+14);
+ struct stat StatBuf;
+ struct utimbuf UTimeBuf;
+ int fd;
+@@ -288,7 +288,8 @@
+ if ((ipFlag->KeepDate) && stat(ipInFN, &StatBuf))
+ RetVal = -1;
+
+- strcpy (TempPath, "./d2utmpXXXXXX");
++ strcpy (TempPath, ipInFN);
++ strcat (TempPath, "_u2dtmpXXXXXX");
+ if((fd=mkstemp (TempPath))<0) {
+ perror("Failed to open output temp file");
+ RetVal = -1;
+@@ -349,6 +350,7 @@
+ RetVal = -1;
+ }
+ }
++ free (TempPath);
+ return RetVal;
+ }
+
+@@ -364,7 +366,7 @@
+ int RetVal = 0;
+ FILE *InF = NULL;
+ FILE *TempF = NULL;
+- char TempPath[16];
++ char *TempPath = (char *) malloc(sizeof(char) * strlen(ipInFN)+14);
+ struct stat StatBuf;
+ struct utimbuf UTimeBuf;
+ mode_t mode = S_IRUSR | S_IWUSR;
+@@ -376,7 +378,8 @@
+ else
+ mode = StatBuf.st_mode;
+
+- strcpy (TempPath, "./u2dtmpXXXXXX");
++ strcpy (TempPath, ipInFN);
++ strcat (TempPath, "_u2dtmpXXXXXX");
+ if((fd=mkstemp (TempPath))<0) {
+ perror("Failed to open output temp file");
+ RetVal = -1;
+@@ -442,6 +445,7 @@
+ }
+ RetVal = -1;
+ }
++ free (TempPath);
+ return RetVal;
+ }
+