summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-09-14 03:12:44 +0000
committerDonny Davies <woodchip@gentoo.org>2002-09-14 03:12:44 +0000
commit3a3d04de2dd59eade8f515533726a5f1b9c33d1a (patch)
treee7aa7cfd7c99dee5e563f5acaa66c53cc81c2716 /app-text/chktex/chktex-1.5-r2.ebuild
parentCorrected perl ecalss syntax (diff)
downloadgentoo-2-3a3d04de2dd59eade8f515533726a5f1b9c33d1a.tar.gz
gentoo-2-3a3d04de2dd59eade8f515533726a5f1b9c33d1a.tar.bz2
gentoo-2-3a3d04de2dd59eade8f515533726a5f1b9c33d1a.zip
sys-devel/ld.so is deprecated; #6476.
Diffstat (limited to 'app-text/chktex/chktex-1.5-r2.ebuild')
-rw-r--r--app-text/chktex/chktex-1.5-r2.ebuild24
1 files changed, 8 insertions, 16 deletions
diff --git a/app-text/chktex/chktex-1.5-r2.ebuild b/app-text/chktex/chktex-1.5-r2.ebuild
index 197916fbb7f8..8ae0419c108f 100644
--- a/app-text/chktex/chktex-1.5-r2.ebuild
+++ b/app-text/chktex/chktex-1.5-r2.ebuild
@@ -1,36 +1,28 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/chktex/chktex-1.5-r2.ebuild,v 1.5 2002/08/16 02:42:01 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/chktex/chktex-1.5-r2.ebuild,v 1.6 2002/09/14 03:12:44 woodchip Exp $
S=${WORKDIR}/${P}
SRC_URI="http://www.ibiblio.org/pub/linux/distributions/gentoo/${P}.tar.gz"
-
HOMEPAGE="http://www.ifi.uio.no/~jensthi/chktex/ChkTeX.html"
SLOT="0"
DESCRIPTION="Checks latex source for common mistakes"
-
DEPEND="app-text/tetex
- sys-devel/ld.so
sys-devel/perl
sys-apps/groff
app-text/latex2html"
-
+RDEPEND="${DEPEND}"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
-src_compile() {
-
- myconf="--prefix=/usr --host=${CHOST}"
- [ -n "$DEBUG" ] && myconf="$myconf --enable-debug-info" || myconf="$myconf --disable-debug-info"
-
- econf ${myconf} || die
-
- emake || die
+src_compile() {
+ myconf="--prefix=/usr --host=${CHOST}"
+ [ -n "$DEBUG" ] && myconf="$myconf --enable-debug-info" || myconf="$myconf --disable-debug-info"
+ econf ${myconf} || die
+ emake || die
}
src_install () {
-
- einstall || die
+ einstall || die
dodoc COPYING SCOPTIONS
-
}