summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2014-12-25 15:18:16 +0000
committerDavide Pesavento <pesa@gentoo.org>2014-12-25 15:18:16 +0000
commita313374276b74cb90852838a917a44ff771e634e (patch)
tree34bf9bd06c53d5b4018b6717391f84343fdab2ad /app-text/cb2bib
parentAdd CLX license to MISC-FREE group, bug 533400. (diff)
downloadgentoo-2-a313374276b74cb90852838a917a44ff771e634e.tar.gz
gentoo-2-a313374276b74cb90852838a917a44ff771e634e.tar.bz2
gentoo-2-a313374276b74cb90852838a917a44ff771e634e.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'app-text/cb2bib')
-rw-r--r--app-text/cb2bib/ChangeLog9
-rw-r--r--app-text/cb2bib/cb2bib-1.5.0.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/app-text/cb2bib/ChangeLog b/app-text/cb2bib/ChangeLog
index 2509d4965310..d5bdcaef59aa 100644
--- a/app-text/cb2bib/ChangeLog
+++ b/app-text/cb2bib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/cb2bib
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/ChangeLog,v 1.21 2013/05/10 05:53:05 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/ChangeLog,v 1.22 2014/12/25 15:18:16 pesa Exp $
+
+*cb2bib-1.5.0 (25 Dec 2014)
+
+ 25 Dec 2014; Davide Pesavento <pesa@gentoo.org> +cb2bib-1.5.0.ebuild:
+ Version bump.
10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove unused flag description from metadata
diff --git a/app-text/cb2bib/cb2bib-1.5.0.ebuild b/app-text/cb2bib/cb2bib-1.5.0.ebuild
new file mode 100644
index 000000000000..f26941314e76
--- /dev/null
+++ b/app-text/cb2bib/cb2bib-1.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/cb2bib-1.5.0.ebuild,v 1.1 2014/12/25 15:18:16 pesa Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Tool for extracting unformatted bibliographic references"
+HOMEPAGE="http://www.molspaces.com/cb2bib/"
+SRC_URI="http://www.molspaces.com/dl/progs/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +lzo +webkit"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-libs/libX11
+ lzo? ( dev-libs/lzo:2 )
+ webkit? ( dev-qt/qtwebkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Fix desktop files
+ sed -i -e '/Keywords=/ s/$/;/' c2bscripts/{c2bciter,cb2bib}.desktop || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DC2B_USE_LZO=$(use lzo && echo ON || echo OFF)
+ -DC2B_USE_WEBKIT=$(use webkit && echo ON || echo OFF)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ elog "For best functionality, emerge the following packages:"
+ elog " app-text/poppler[utils] - for data import from PDF files"
+ elog " app-text/dvipdfm - for data import from DVI files"
+ elog " app-text/bibutils - for data import from ISI, endnote format"
+ elog " media-fonts/jsmath - for displaying mathematical notation"
+ elog " media-libs/exiftool - for proper UTF-8 metadata writing in PDF"
+ elog " text strings"
+ elog " virtual/latex-base - to check for BibTeX file correctness and to get"
+ elog " nice printing through the shell script bib2pdf"
+ einfo
+}