summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-07-07 02:00:55 +0000
committerJon Hood <squinky86@gentoo.org>2006-07-07 02:00:55 +0000
commitec1665017237d357236ce93f30fcbdec2fb564cb (patch)
treec4fd50dde2a3df14e911c797af9f7cbad29e998e /app-text/bibletime
parentVersion bump. (diff)
downloadgentoo-2-ec1665017237d357236ce93f30fcbdec2fb564cb.tar.gz
gentoo-2-ec1665017237d357236ce93f30fcbdec2fb564cb.tar.bz2
gentoo-2-ec1665017237d357236ce93f30fcbdec2fb564cb.zip
Version bump for testing branch. Remove old version.
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'app-text/bibletime')
-rw-r--r--app-text/bibletime/ChangeLog8
-rw-r--r--app-text/bibletime/bibletime-1.6_beta3.ebuild87
-rw-r--r--app-text/bibletime/files/digest-bibletime-1.6_beta36
3 files changed, 100 insertions, 1 deletions
diff --git a/app-text/bibletime/ChangeLog b/app-text/bibletime/ChangeLog
index 246633dec379..f76708ca4cc2 100644
--- a/app-text/bibletime/ChangeLog
+++ b/app-text/bibletime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/bibletime
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.32 2006/06/21 13:51:48 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.33 2006/07/07 02:00:55 squinky86 Exp $
+
+*bibletime-1.6_beta3 (07 Jul 2006)
+
+ 07 Jul 2006; Jon Hood <squinky86@gentoo.org> -bibletime-1.5.2.ebuild,
+ +bibletime-1.6_beta3.ebuild:
+ Version bump for testing branch. Remove old version.
21 Jun 2006; <nixnut@gentoo.org> bibletime-1.6_beta2.ebuild:
Added ~ppc wrt bug #136709
diff --git a/app-text/bibletime/bibletime-1.6_beta3.ebuild b/app-text/bibletime/bibletime-1.6_beta3.ebuild
new file mode 100644
index 000000000000..aa63364a00fe
--- /dev/null
+++ b/app-text/bibletime/bibletime-1.6_beta3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-1.6_beta3.ebuild,v 1.1 2006/07/07 02:00:55 squinky86 Exp $
+
+inherit kde eutils versionator
+
+MY_P="${PN}-$(replace_version_separator 2 '')"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="KDE Bible study application using the SWORD library."
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/bibletime/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=app-text/sword-1.5.8
+ >=dev-cpp/clucene-0.9.12"
+
+LANGS_PKG=${PN}-i18n-1.5.3
+LANGS="af bg cs da de en_GB es fi fr hu it ko nl nn_NO no pl pt_BR ro ru sk ua"
+LANGS_DOC="bg cs de fi fr it ko nl pt_BR ru"
+
+for X in ${LANGS}; do
+ SRC_URI="${SRC_URI} linguas_${X}? ( mirror://sourceforge/bibletime/${LANGS_PKG}.tar.bz2 )"
+done
+
+need-kde 3.4
+
+pkg_setup() {
+ if ! built_with_use app-text/sword curl; then
+ echo
+ ewarn "The SWORD library may not have been compiled with curl support."
+ ewarn "If you wish to use BibleTime's ability to download modules"
+ ewarn "straight from the SWORD website, please make sure app-text/sword"
+ ewarn "was compiled with USE=\"curl\"."
+ ewarn "Press ctrl+c to abort the merge of BibleTime if you want to"
+ ewarn "recompile SWORD with curl support."
+ echo
+ ebeep 5
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS MAKE_LANGS_DOC
+ for X in ${LANGS}; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X/pt_BR/pt_br}.po"
+ done
+ for X in ${LANGS_DOC}; do
+ use linguas_${X} && MAKE_LANGS_DOC="${MAKE_LANGS_DOC} ${X/pt_BR/pt-br}"
+ done
+
+ if [ -d "${WORKDIR}/${LANGS_PKG}" ]; then
+ cd "${WORKDIR}/${LANGS_PKG}"
+ sed -i -e "s,^POFILES.*,POFILES = ${MAKE_LANGS}," po/Makefile.am
+ sed -i -e "s,^SUBDIRS.*,SUBDIRS = ${MAKE_LANGS_DOC}," docs/Makefile.am
+ make -f admin/Makefile.common || die
+ fi
+}
+
+src_compile() {
+ kde_src_compile
+
+ local _S="${S}"
+ if [ -d "${WORKDIR}/${LANGS_PKG}" ]; then
+ S="${WORKDIR}/${LANGS_PKG}"
+ cd "${S}"
+ kde_src_compile
+ fi
+ S="${_S}"
+}
+
+src_install() {
+ kde_src_install
+
+ local _S="${S}"
+ if [ -d "${WORKDIR}/${LANGS_PKG}" ]; then
+ S="${WORKDIR}/${LANGS_PKG}"
+ cd "${S}"
+ kde_src_install
+ fi
+ S="${_S}"
+}
diff --git a/app-text/bibletime/files/digest-bibletime-1.6_beta3 b/app-text/bibletime/files/digest-bibletime-1.6_beta3
new file mode 100644
index 000000000000..b69a04b45711
--- /dev/null
+++ b/app-text/bibletime/files/digest-bibletime-1.6_beta3
@@ -0,0 +1,6 @@
+MD5 137d3dca7126ec0f89f70e9646412535 bibletime-1.6beta3.tar.bz2 1183014
+RMD160 6b8af29464906358b088d71b67811b0515338dce bibletime-1.6beta3.tar.bz2 1183014
+SHA256 8418c8feb0d3a06732823d9360bf26d2b5f7dc1f9a7a54761128f8f3d30e1919 bibletime-1.6beta3.tar.bz2 1183014
+MD5 dcf548af05fde1d4d1b864f21ffc9fcb bibletime-i18n-1.5.3.tar.bz2 1024639
+RMD160 5455172a63001e84fc30628d41bd1a709f23e3e9 bibletime-i18n-1.5.3.tar.bz2 1024639
+SHA256 ac43274ae1b45e26c8ed38170657f94a146d8645122b0a2900e2bc39e9867c3e bibletime-i18n-1.5.3.tar.bz2 1024639