summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-09-14 01:44:00 +0000
committerNed Ludd <solar@gentoo.org>2008-09-14 01:44:00 +0000
commit4f5225c7e32df868f9157f9725bfd8fae8657f71 (patch)
tree55391feb878f13764f1bb85d54a85fb66d7746ff /app-text/barcode
parentfix bug #236481. block udev-126 and higher on older versions that won't work ... (diff)
downloadgentoo-2-4f5225c7e32df868f9157f9725bfd8fae8657f71.tar.gz
gentoo-2-4f5225c7e32df868f9157f9725bfd8fae8657f71.tar.bz2
gentoo-2-4f5225c7e32df868f9157f9725bfd8fae8657f71.zip
- cross compile love
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-text/barcode')
-rw-r--r--app-text/barcode/ChangeLog5
-rw-r--r--app-text/barcode/barcode-0.98.ebuild18
2 files changed, 16 insertions, 7 deletions
diff --git a/app-text/barcode/ChangeLog b/app-text/barcode/ChangeLog
index 134565d3da34..726926545ca0 100644
--- a/app-text/barcode/ChangeLog
+++ b/app-text/barcode/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/barcode
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/barcode/ChangeLog,v 1.15 2008/01/25 19:24:56 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/barcode/ChangeLog,v 1.16 2008/09/14 01:44:00 solar Exp $
+
+ 14 Sep 2008; <solar@gentoo.org> barcode-0.98.ebuild:
+ - cross compile love
25 Jan 2008; Fabian Groffen <grobian@gentoo.org> barcode-0.98.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/app-text/barcode/barcode-0.98.ebuild b/app-text/barcode/barcode-0.98.ebuild
index 40ad9b02ff41..0b24d5b57d58 100644
--- a/app-text/barcode/barcode-0.98.ebuild
+++ b/app-text/barcode/barcode-0.98.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/barcode/barcode-0.98.ebuild,v 1.15 2008/01/25 19:24:56 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/barcode/barcode-0.98.ebuild,v 1.16 2008/09/14 01:44:00 solar Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="barcode generator"
HOMEPAGE="http://www.gnu.org/software/barcode/"
@@ -10,20 +10,26 @@ SRC_URI="mirror://gnu/barcode/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
+KEYWORDS="amd64 ppc ppc64 x86 ~arm"
IUSE=""
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-info.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-info.patch
sed -i \
-e 's:/info:/share/info:' \
-e 's:/man/:/share/man/:' \
Makefile.in || die "sed failed"
}
+src_compile() {
+ tc-export CC
+ econf
+ emake || "emake failed"
+}
+
src_install() {
- emake install prefix=${D}/usr LIBDIR="\$(prefix)/$(get_libdir)" || die
+ emake install prefix="${D}/usr" LIBDIR="\$(prefix)/$(get_libdir)" || die
dodoc ChangeLog README TODO doc/barcode.{pdf,ps}
}