summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-04-02 19:15:09 +0000
committerJon Portnoy <avenj@gentoo.org>2004-04-02 19:15:09 +0000
commit289330d36e073799c770f992e97837cc0d2a20f4 (patch)
tree5adf88bf95a8696694d4153907b43aac27819296 /app-text/aspell
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-289330d36e073799c770f992e97837cc0d2a20f4.tar.gz
gentoo-2-289330d36e073799c770f992e97837cc0d2a20f4.tar.bz2
gentoo-2-289330d36e073799c770f992e97837cc0d2a20f4.zip
Fix ncurses/gpm support, bug 46432
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog7
-rw-r--r--app-text/aspell/aspell-0.50.3.ebuild9
-rw-r--r--app-text/aspell/aspell-0.50.4.1.ebuild9
-rw-r--r--app-text/aspell/aspell-0.50.5.ebuild8
4 files changed, 24 insertions, 9 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index ee5326f41fb4..330235e65248 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/aspell
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.32 2004/04/02 18:58:52 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.33 2004/04/02 19:15:09 avenj Exp $
+
+ 02 Apr 2004; Jon Portnoy <avenj@gentoo.org> aspell-0.50.5.ebuild,
+ aspell-0.50.4.1.ebuild, aspell-0.50.3.ebuild :
+ Added LDFLAGS hack to make sure gpm gets linked in with USE=gpm.
+ This is needed when ncurses is built with gpm support. #46432
02 Apr 2004; Jon Portnoy <avenj@gentoo.org> aspell-0.50.5.ebuild :
AMD64 keywords.
diff --git a/app-text/aspell/aspell-0.50.3.ebuild b/app-text/aspell/aspell-0.50.3.ebuild
index 43a4edd02475..ffb1a094a4bb 100644
--- a/app-text/aspell/aspell-0.50.3.ebuild
+++ b/app-text/aspell/aspell-0.50.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.3.ebuild,v 1.11 2003/09/05 22:37:21 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.3.ebuild,v 1.12 2004/04/02 19:15:09 avenj Exp $
inherit libtool
@@ -8,17 +8,20 @@ DESCRIPTION="A spell checker replacement for ispell"
HOMEPAGE="http://aspell.net/"
SRC_URI="ftp://ftp.gnu.org/gnu/aspell/${P}.tar.gz"
+IUSE="gpm"
SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="x86 ppc sparc alpha ~mips hppa amd64"
-DEPEND=">=sys-libs/ncurses-5.2"
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
pkg_setup() {
if [ ${ARCH} = "ppc" ] ; then
CXXFLAGS="-O2 -fsigned-char"
CFLAGS=${CXXFLAGS}
fi
+ use gpm && LDFLAGS="-lgpm"
}
src_compile() {
diff --git a/app-text/aspell/aspell-0.50.4.1.ebuild b/app-text/aspell/aspell-0.50.4.1.ebuild
index 08987cbc630b..b7fcda042488 100644
--- a/app-text/aspell/aspell-0.50.4.1.ebuild
+++ b/app-text/aspell/aspell-0.50.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.4.1.ebuild,v 1.5 2004/02/29 18:10:25 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.4.1.ebuild,v 1.6 2004/04/02 19:15:09 avenj Exp $
inherit libtool
@@ -8,17 +8,20 @@ DESCRIPTION="A spell checker replacement for ispell"
HOMEPAGE="http://aspell.net/"
SRC_URI="http://aspell.net/${P}.tar.gz"
+IUSE="gpm"
SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa -amd64 ia64"
-DEPEND=">=sys-libs/ncurses-5.2"
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
pkg_setup() {
if [ ${ARCH} = "ppc" ] ; then
CXXFLAGS="-O2 -fsigned-char"
CFLAGS=${CXXFLAGS}
fi
+ use gpm && LDFLAGS="-lgpm"
}
src_compile() {
diff --git a/app-text/aspell/aspell-0.50.5.ebuild b/app-text/aspell/aspell-0.50.5.ebuild
index 63cdc2ebe60f..f0596ee74a39 100644
--- a/app-text/aspell/aspell-0.50.5.ebuild
+++ b/app-text/aspell/aspell-0.50.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5.ebuild,v 1.5 2004/04/02 18:58:53 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5.ebuild,v 1.6 2004/04/02 19:15:09 avenj Exp $
inherit libtool
@@ -8,17 +8,21 @@ DESCRIPTION="A spell checker replacement for ispell"
HOMEPAGE="http://aspell.net/"
SRC_URI="http://aspell.net/${P}.tar.gz"
+IUSE="gpm"
+
SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ia64 s390"
-DEPEND=">=sys-libs/ncurses-5.2"
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
pkg_setup() {
if [ ${ARCH} = "ppc" ] ; then
CXXFLAGS="-O2 -fsigned-char"
CFLAGS=${CXXFLAGS}
fi
+ use gpm && LDFLAGS="-lgpm"
}
src_compile() {