summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-08 19:52:55 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-08 19:52:55 +0000
commitf0b5e9bc3d7d9d053bb35ef26931c38ad996d7bf (patch)
tree064427ab6e4e6628c083b1a47c0480ad32b88f72 /app-shells
parentStable on sparc wrt #169461 (diff)
downloadgentoo-2-f0b5e9bc3d7d9d053bb35ef26931c38ad996d7bf.tar.gz
gentoo-2-f0b5e9bc3d7d9d053bb35ef26931c38ad996d7bf.tar.bz2
gentoo-2-f0b5e9bc3d7d9d053bb35ef26931c38ad996d7bf.zip
move /bin/sh tweaking to pkg_preinst() so we dont break on upgrades
(Portage version: 2.1.2.1-r1)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-3.2_p10.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-shells/bash/bash-3.2_p10.ebuild b/app-shells/bash/bash-3.2_p10.ebuild
index 7792f9f80a3e..3dc4727ddcd6 100644
--- a/app-shells/bash/bash-3.2_p10.ebuild
+++ b/app-shells/bash/bash-3.2_p10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p10.ebuild,v 1.2 2007/03/08 16:54:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p10.ebuild,v 1.3 2007/03/08 19:52:55 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -140,10 +140,10 @@ pkg_preinst() {
if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
rm -f "${D}"/etc/bash/bash_logout
fi
-}
-pkg_postinst() {
if [[ ! -e ${ROOT}/bin/sh ]] ; then
ln -s bash "${ROOT}"/bin/sh
+ else
+ cp -a "${ROOT}"/bin/sh "${D}"/bin/
fi
}