summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-09 06:03:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-09 06:03:17 +0000
commitef6e0e57b27e3035f829e20761466fc942c652e8 (patch)
tree392ab1ca4f3f8da7e1dc930527855694cd7e095b /app-shells
parentBump (diff)
downloadgentoo-2-ef6e0e57b27e3035f829e20761466fc942c652e8.tar.gz
gentoo-2-ef6e0e57b27e3035f829e20761466fc942c652e8.tar.bz2
gentoo-2-ef6e0e57b27e3035f829e20761466fc942c652e8.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sash/ChangeLog9
-rw-r--r--app-shells/sash/sash-3.8.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/app-shells/sash/ChangeLog b/app-shells/sash/ChangeLog
index c75a9cd2d69c..a91b632bd4d5 100644
--- a/app-shells/sash/ChangeLog
+++ b/app-shells/sash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/sash
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.52 2013/12/08 17:27:39 dastergon Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.53 2014/06/09 06:03:17 patrick Exp $
+
+*sash-3.8 (09 Jun 2014)
+
+ 09 Jun 2014; Patrick Lauer <patrick@gentoo.org> +sash-3.8.ebuild:
+ Bump
08 Dec 2013; Pavlos Ratis <dastergon@gentoo.org> metadata.xml:
add myself as maintainer
diff --git a/app-shells/sash/sash-3.8.ebuild b/app-shells/sash/sash-3.8.ebuild
new file mode 100644
index 000000000000..7ad6fb474fe9
--- /dev/null
+++ b/app-shells/sash/sash-3.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.8.ebuild,v 1.1 2014/06/09 06:03:17 patrick Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A small (static) UNIX Shell"
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+DEPEND="
+ static? ( sys-libs/zlib[static-libs] )
+ !static? ( >=sys-libs/zlib-1.2.3 )"
+RDEPEND="!static? ( ${DEPEND} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/sash-3.7-builtin.patch
+
+ sed \
+ -e "s:-O3:${CFLAGS}:" \
+ -i Makefile || die
+ sed \
+ -e 's:linux/ext2_fs.h:ext2fs/ext2_fs.h:g' \
+ -i cmd_chattr.c || die
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ into /
+ dobin sash
+ doman sash.1
+ dodoc README
+}