summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-02-20 05:31:48 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-02-20 05:31:48 +0000
commited31cbdf6e1ec2ed4876ff4a1969103bb5250f09 (patch)
treebb6efaf8c9dfe40a889643f666ff68564f7e33be /app-shells
parent(non maintainer commit) don't run fetchmail as root - create new fetchmail us... (diff)
downloadgentoo-2-ed31cbdf6e1ec2ed4876ff4a1969103bb5250f09.tar.gz
gentoo-2-ed31cbdf6e1ec2ed4876ff4a1969103bb5250f09.tar.bz2
gentoo-2-ed31cbdf6e1ec2ed4876ff4a1969103bb5250f09.zip
Fix bug in bash completion for lzma man pages. Fix by Jan Hruban in bug 254814. Convert to EAPI-2, add die() messages as needed
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog9
-rw-r--r--app-shells/bash-completion/bash-completion-20081218-r1.ebuild (renamed from app-shells/bash-completion/bash-completion-20081218.ebuild)25
2 files changed, 21 insertions, 13 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index b7db07c18ab0..0eef1ca9a4ab 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.150 2009/02/11 19:07:44 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.151 2009/02/20 05:31:48 darkside Exp $
+
+*bash-completion-20081218-r1 (20 Feb 2009)
+
+ 20 Feb 2009; Jeremy Olexa <darkside@gentoo.org>
+ -bash-completion-20081218.ebuild, +bash-completion-20081218-r1.ebuild:
+ Fix bug in bash completion for lzma man pages. Fix by Jan Hruban in bug
+ 254814. Convert to EAPI-2, add die() messages as needed
11 Feb 2009; Jeremy Olexa <darkside@gentoo.org> metadata.xml:
add myself to metadata
diff --git a/app-shells/bash-completion/bash-completion-20081218.ebuild b/app-shells/bash-completion/bash-completion-20081218-r1.ebuild
index 7d56c3cb7013..7cbadb46a927 100644
--- a/app-shells/bash-completion/bash-completion-20081218.ebuild
+++ b/app-shells/bash-completion/bash-completion-20081218-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20081218.ebuild,v 1.1 2008/12/18 22:54:51 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20081218-r1.ebuild,v 1.1 2009/02/20 05:31:48 darkside Exp $
+
+EAPI="2"
DESCRIPTION="Programmable Completion for bash"
HOMEPAGE="http://bash-completion.alioth.debian.org/"
@@ -22,13 +24,10 @@ PDEPEND="app-shells/gentoo-bashcomp"
S=${WORKDIR}/${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- #EPATCH_SUFFIX="patch" epatch "${FILESDIR}"/${PV}
-
- # bug #111681
- sed -i -e "/^complete.* xine /d" bash_completion
+src_prepare() {
+ # bug #111681
+ sed -i -e "/^complete.* xine /d" \
+ -e '0,/gz|bz2/s//gz|bz2|lzma/' bash_completion || die "sed failed"
}
src_install() {
@@ -36,7 +35,7 @@ src_install() {
# 1. /usr/share/bash-completion/.pre -- hidden from eselect
# 2. /usr/share/bash-completion/base -- eselectable
# 3. /usr/share/bash-completion/.post -- hidden from eselect
- dodir /usr/share/bash-completion
+ dodir /usr/share/bash-completion || die "dodir failed"
awk -v D="$D" '
BEGIN { out=".pre" }
/^# A lot of the following one-liners/ { out="base" }
@@ -69,7 +68,7 @@ pkg_postinst() {
elog
elog "Versions of bash-completion prior to 20060301-r1 required each user to"
elog "explicitly source /etc/profile.d/bash-completion in ~/.bashrc. This"
- elog "was kludgy and inconsistent with the completion modules which are"
+ elog "was inconsistent with the completion modules which are"
elog "enabled with eselect bashcomp. Now any user can enable the base"
elog "completions without editing their .bashrc by running"
elog
@@ -84,13 +83,15 @@ pkg_postinst() {
elog
elog "If you use non-login shells you still need to source"
elog "/etc/profile.d/bash-completion.sh in your ~/.bashrc."
+ elog "Note this is bash-completion.sh, not bash-completion. Lots of people"
+ elog "overlook this"
elog
if has_version 'app-shells/zsh' ; then
elog "If you are interested in using the provided bash completion functions with"
elog "zsh, valuable tips on the effective use of bashcompinit are available:"
elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
- elog " http://zshwiki.org/ZshSwitchingTo"
+ #elog " http://zshwiki.org/ZshSwitchingTo" (doesn't exist)
elog
fi
}