summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-08-19 23:08:22 +0000
committerNed Ludd <solar@gentoo.org>2003-08-19 23:08:22 +0000
commitde90c0a525ea3d6b67f25eb513a5b3690ca8daad (patch)
tree87c026157fa134667d1a257900f84ff7098ab60f /app-shells
parentUpdate to add support for restricted bash when invoked from /etc/passwd as /b... (diff)
downloadgentoo-2-de90c0a525ea3d6b67f25eb513a5b3690ca8daad.tar.gz
gentoo-2-de90c0a525ea3d6b67f25eb513a5b3690ca8daad.tar.bz2
gentoo-2-de90c0a525ea3d6b67f25eb513a5b3690ca8daad.zip
Update to add support for restricted bash when invoked from /etc/passwd as /bin/rbash Bug #26854
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog9
-rw-r--r--app-shells/bash/Manifest4
-rw-r--r--app-shells/bash/bash-2.05b-r7.ebuild89
-rw-r--r--app-shells/bash/files/bash-2.05b-rbash.patch21
-rw-r--r--app-shells/bash/files/digest-bash-2.05b-r78
5 files changed, 128 insertions, 3 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 5025e494b315..d125806ae965 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.12 2003/07/11 19:56:53 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.13 2003/08/19 23:08:19 solar Exp $
+
+*bash-2.05b-r7 (19 Aug 2003)
+
+ 19 Aug 2003; <solar@gentoo.org> bash-2.05b-r7.ebuild,
+ files/bash-2.05b-rbash.patch:
+ Update to add support for restricted bash when invoked from /etc/passwd as
+ /bin/rbash Bug #26854
*bash-2.05b-r6 (09 Jul 2003)
diff --git a/app-shells/bash/Manifest b/app-shells/bash/Manifest
index 5aefb2cc9ffb..30a3c7ed7bf1 100644
--- a/app-shells/bash/Manifest
+++ b/app-shells/bash/Manifest
@@ -1,10 +1,10 @@
-MD5 417b6258a69dac961d587de04a5b3feb ChangeLog 4748
+MD5 937acfbbab89a3cd2251ac74001337c5 ChangeLog 4969
MD5 ba1233983751e50700241a6495306378 bash-2.05a-r3.ebuild 1917
MD5 31f9be8380509135728cb39c2c0fb8b4 bash-2.05b-r3.ebuild 1759
MD5 425c712c6f00d85f11e25b3df5141bc3 bash-2.05b-r4.ebuild 1870
MD5 b7ea47a95638397d995ccd6162d7f4b5 bash-2.05b-r5.ebuild 2052
MD5 8f18509ab36adb048e359db032e2d87f bash-2.05b-r6.ebuild 2042
-MD5 3f7b2d9fc5d8e31f35eeaf362be469aa bash-2.05b-r7.ebuild 2112
+MD5 11e5d5c1094e24f5fdb5a7379ab8a7db bash-2.05b-r7.ebuild 2133
MD5 edf95b873162f4548435c379e4998b4e files/bash-2.05b-empty-herestring.patch 836
MD5 90ba92c981c1d26e45d88ecd23a1fbf5 files/bash-2.05b-multibyte-locale.patch 1897
MD5 582fb9ed0ca44627978ce6836a5000dc files/config-top.h.diff 487
diff --git a/app-shells/bash/bash-2.05b-r7.ebuild b/app-shells/bash/bash-2.05b-r7.ebuild
new file mode 100644
index 000000000000..15f10b8a14e7
--- /dev/null
+++ b/app-shells/bash/bash-2.05b-r7.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r7.ebuild,v 1.1 2003/08/19 23:08:19 solar Exp $
+
+inherit eutils flag-o-matic
+
+# Official patches
+PLEVEL="x002 x003 x004 x005 x006 x007"
+
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2
+ ${PLEVEL//x/ftp://ftp.gnu.org/gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc"
+IUSE="nls build"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ epatch ${DISTDIR}/${P}-gentoo.diff.bz2
+
+ for x in ${PLEVEL//x}
+ do
+ epatch ${DISTDIR}/${PN}${PV/\.}-${x}
+ done
+
+ # Remove autoconf dependency
+ cp Makefile.in Makefile.in.orig
+ sed -e "/&& autoconf/d" Makefile.in.orig > Makefile.in
+
+ # Readline is slow with multibyte locale, bug #19762
+ epatch ${FILESDIR}/${P}-multibyte-locale.patch
+ # Segfault on empty herestring
+ epatch ${FILESDIR}/${P}-empty-herestring.patch
+ # fix broken rbash functionality
+ epatch ${FILESDIR}/${P}-rbash.patch
+}
+
+src_compile() {
+
+ filter-flags -malign-double
+
+ local myconf=""
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #use readline && myconf="--with-installed-readline"
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf \
+ --disable-profiling \
+ --with-curses \
+ --without-gnu-malloc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+ dosym bash /bin/rbash
+
+ use build \
+ && rm -rf ${D}/usr \
+ || ( \
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc doc/FAQ doc/INTRO
+
+ ebegin "creating info symlink"
+ dosym bash.info.gz /usr/share/info/bashref.info.gz
+ eend $?
+ )
+}
diff --git a/app-shells/bash/files/bash-2.05b-rbash.patch b/app-shells/bash/files/bash-2.05b-rbash.patch
new file mode 100644
index 000000000000..a08159f14f3b
--- /dev/null
+++ b/app-shells/bash/files/bash-2.05b-rbash.patch
@@ -0,0 +1,21 @@
+diff -Nru bash-2.05b.orig/shell.c bash-2.05b/shell.c
+--- bash-2.05b.orig/shell.c 2002-07-01 11:27:11.000000000 -0400
++++ bash-2.05b/shell.c 2003-08-18 21:20:26.000000000 -0400
+@@ -1065,7 +1065,7 @@
+ if (restricted)
+ return 1;
+ temp = base_pathname (name);
+- return (STREQ (temp, RESTRICTED_SHELL_NAME));
++ return ( (STREQ (temp, RESTRICTED_SHELL_NAME)) || (STREQ (temp, ("-"RESTRICTED_SHELL_NAME))) );
+ }
+
+ /* Perhaps make this shell a `restricted' one, based on NAME. If the
+@@ -1082,7 +1082,7 @@
+ char *temp;
+
+ temp = base_pathname (name);
+- if (restricted || (STREQ (temp, RESTRICTED_SHELL_NAME)))
++ if (restricted || (STREQ (temp, RESTRICTED_SHELL_NAME)) || (STREQ (temp, ("-"RESTRICTED_SHELL_NAME))) )
+ {
+ set_var_read_only ("PATH");
+ set_var_read_only ("SHELL");
diff --git a/app-shells/bash/files/digest-bash-2.05b-r7 b/app-shells/bash/files/digest-bash-2.05b-r7
new file mode 100644
index 000000000000..cda4481c8b5e
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-2.05b-r7
@@ -0,0 +1,8 @@
+MD5 5238251b4926d778dfe162f6ce729733 bash-2.05b.tar.gz 1956216
+MD5 acac0949285525a5920d80f2aa4668de bash-2.05b-gentoo.diff.bz2 2744
+MD5 2957bbe5f6db1830d649d1071baba63c bash205b-002 755
+MD5 2828e78563927b806246e2b4806ee0f5 bash205b-003 2356
+MD5 6bf89831209ba6d208943d2ebaa7fe3a bash205b-004 1110
+MD5 311b7f0e3dabec51767bfabe6afd4ded bash205b-005 2217
+MD5 f8a86d0a66b51080f3fbc5cc34ef1a06 bash205b-006 3155
+MD5 37d2acecc9146883f9b331c03b274f21 bash205b-007 1072