summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-03-06 17:54:10 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-03-06 17:54:10 +0000
commit7ac7e06e398280014c606ded2e5bae086f8f34af (patch)
tree515c0e8491c86593c765e20ee06292da3f35e168 /app-shells
parentunmasking -r7 xfree which now contains the Xft quality patch (diff)
downloadgentoo-2-7ac7e06e398280014c606ded2e5bae086f8f34af.tar.gz
gentoo-2-7ac7e06e398280014c606ded2e5bae086f8f34af.tar.bz2
gentoo-2-7ac7e06e398280014c606ded2e5bae086f8f34af.zip
Fixed bug #980
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/scsh/ChangeLog9
-rw-r--r--app-shells/scsh/files/digest-scsh-0.6.1-r11
-rw-r--r--app-shells/scsh/scsh-0.6.1-r1.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/app-shells/scsh/ChangeLog b/app-shells/scsh/ChangeLog
index 83cec7fcc498..48c9e7540ccc 100644
--- a/app-shells/scsh/ChangeLog
+++ b/app-shells/scsh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/scsh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/ChangeLog,v 1.1 2002/02/24 22:31:38 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/ChangeLog,v 1.2 2002/03/06 17:54:10 karltk Exp $
+
+*scsh-0.6.1-r1 ( 6 Mar 2002 )
+
+ 6 Mar 2002; Karl Trygve Kalleberg <karltk@gentoo.org> ChangeLog scsh-0.6.1-r1 files/digest-scsh-0.6.1-r1:
+
+ Fixed a bug where scsh.1 was installed in /usr/share/man instead of
+ /usr/share/man/man1.
*scsh-0.6.0 ( 25 Feb 2002 )
diff --git a/app-shells/scsh/files/digest-scsh-0.6.1-r1 b/app-shells/scsh/files/digest-scsh-0.6.1-r1
new file mode 100644
index 000000000000..8c7e5d767229
--- /dev/null
+++ b/app-shells/scsh/files/digest-scsh-0.6.1-r1
@@ -0,0 +1 @@
+MD5 8ac186061f0fd9679d86b2aa3d7826ba scsh-0.6.1.tar.gz 2438575
diff --git a/app-shells/scsh/scsh-0.6.1-r1.ebuild b/app-shells/scsh/scsh-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..f56d01ca5b21
--- /dev/null
+++ b/app-shells/scsh/scsh-0.6.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Matthew Kennedy <mbkennedy@ieee.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.1-r1.ebuild,v 1.1 2002/03/06 17:54:10 karltk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Scsh is a Unix shell embedded in Scheme"
+SRC_URI="ftp://ftp.scsh.net/pub/scsh/0.6/scsh-${PV}.tar.gz"
+HOMEPAGE="http://www.scsh.net/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure --prefix=/ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --libdir=/usr/lib \
+ --includedir=/usr/include
+ make || die
+}
+
+src_install() {
+ make prefix=${D} \
+ htmldir=${D}/usr/share/doc/${P}/html \
+ incdir=${D}/usr/include \
+ libdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man/man1 \
+ install || die
+
+ dodoc COPYING INSTALL RELEASE
+
+
+ # Scsh doesn't have a very consistent documentation
+ # structure. It's possible to override the placement of the
+ # HTML during make install, but not the other documentation in
+ # TeX, DVI and PS formats.
+
+ # Thus we let scsh install the documentation and then clean up
+ # afterwards.
+
+ mv ${D}/usr/lib/scsh/doc/* ${D}/usr/share/doc/${P}
+ rmdir ${D}/usr/lib/scsh/doc
+ find ${D}/usr/share/doc/${P} \( -name \*.ps -o \
+ -name \*.txt -o \
+ -name \*.dvi -o \
+ -name \*.tex \) \
+ -print | xargs gzip
+}