summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-08 01:20:19 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-08 01:20:19 +0000
commit5e03a1a0e40ddf98276d5182cb67a6319374d368 (patch)
treed65886f11324c09645c897b4b9c3d00fad71005d /app-shells
parentVersion bump. (diff)
downloadgentoo-2-5e03a1a0e40ddf98276d5182cb67a6319374d368.tar.gz
gentoo-2-5e03a1a0e40ddf98276d5182cb67a6319374d368.tar.bz2
gentoo-2-5e03a1a0e40ddf98276d5182cb67a6319374d368.zip
old
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-3.0-r11.ebuild163
-rw-r--r--app-shells/bash/bash-3.1_p10.ebuild150
-rw-r--r--app-shells/bash/bash-3.1_p8.ebuild150
-rw-r--r--app-shells/bash/files/digest-bash-3.0-r1118
-rw-r--r--app-shells/bash/files/digest-bash-3.1_p1036
-rw-r--r--app-shells/bash/files/digest-bash-3.1_p830
6 files changed, 0 insertions, 547 deletions
diff --git a/app-shells/bash/bash-3.0-r11.ebuild b/app-shells/bash/bash-3.0-r11.ebuild
deleted file mode 100644
index 236991e8c3a4..000000000000
--- a/app-shells/bash/bash-3.0-r11.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r11.ebuild,v 1.8 2005/06/27 21:54:54 agriffis Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-# Official patchlevel
-# See ftp://ftp.cwru.edu/pub/bash/bash-3.0-patches/
-PLEVEL=16
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-# Hit the GNU mirrors before hitting Chet's site
-SRC_URI="mirror://gnu/bash/${P}.tar.gz
- ftp://ftp.cwru.edu/pub/bash/${P}.tar.gz
- mirror://gentoo/${P}-gentoo.diff.bz2
- $(for ((i=1; i<=PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
- ${PV} ${PV/\.} ${i}
- printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
- ${PV} ${PV/\.} ${i}
- done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls build bashlogger"
-
-# we link statically with ncurses
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-RDEPEND=""
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
- epatch "${DISTDIR}"/${P}-gentoo.diff.bz2
-
- # Remove autoconf dependency
- sed -i -e "/&& autoconf/d" Makefile.in
-
- # Include official patches
- local i
- for ((i=1; i<=PLEVEL; i++)); do
- epatch "${DISTDIR}"/${PN}${PV/\.}-$(printf '%03d' ${i})
- done
-
- # Patch readline's bind.c so that /etc/inputrc is read as a last resort
- # following ~/.inputrc. This is better than putting INPUTRC in
- # the environment because INPUTRC will override even after the
- # user creates a ~/.inputrc
- epatch "${FILESDIR}"/${P}-etc-inputrc.patch
- # Fix network tests on Darwin #79124
- epatch "${FILESDIR}"/${P}-darwin-conn.patch
- # A bunch of fixes from fedora
- epatch "${FILESDIR}"/${P}-{afs,crash,jobs,manpage,pwd,read-e-segfault,ulimit}.patch
- # Fix read-builtin and the -u pipe option #87093
- epatch "${FILESDIR}"/${P}-read-builtin-pipe.patch
- # Don't barf on handled signals in scripts
- epatch "${FILESDIR}"/${P}-trap-fg-signals.patch
- # Log bash commands to syslog #91327
- if use bashlogger ; then
- echo
- ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
- ewarn "This will log ALL output you enter into the shell, you have been warned."
- ebeep
- epause
- epatch "${FILESDIR}"/${P}-bash-logger.patch
- fi
-
- # Enable SSH_SOURCE_BASHRC (#24762)
- echo '#define SSH_SOURCE_BASHRC' >> config-top.h
- # Enable system-wide bashrc (#26952)
- echo '#define SYS_BASHRC "/etc/bash/bashrc"' >> config-top.h
- # Enable system-wide logout (#90488)
- echo '#define SYS_BASH_LOGOUT "/etc/bash/bash_logout"' >> config-top.h
-
- # Force pgrp synchronization
- # (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81653)
- #
- # The session will hang cases where you 'su' (not 'su -') and
- # then run a piped command in emacs.
- # This problem seem to happen due to scheduler changes kernel
- # side - although reproduceble with later 2.4 kernels, it is
- # especially easy with 2.6 kernels.
- echo '#define PGRP_PIPE 1' >> config-bot.h
-
- sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
-
- # Fix parallel builds #87247
- epatch ${FILESDIR}/${P}-parallel.patch
-}
-
-src_compile() {
- filter-flags -malign-double
-
- local myconf=
-
- # Always use the buildin readline, else if we update readline
- # bash gets borked as readline is usually not binary compadible
- # between minor versions.
- #
- # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
- #use readline && myconf="--with-installed-readline"
-
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to use with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
- use nls || myconf="${myconf} --disable-nls"
-
- echo 'int main(){}' > "${T}"/term-test.c
- if ! $(tc-getCC) -static -lncurses "${T}"/term-test.c 2> /dev/null ; then
- export bash_cv_termcap_lib=gnutermcap
- else
- export bash_cv_termcap_lib=libcurses
- myconf="${myconf} --with-ncurses"
- fi
-
- econf \
- --disable-profiling \
- --without-gnu-malloc \
- ${myconf} || die
- # Make sure we always link statically with ncurses
- sed -i "/^TERMCAP_LIB/s:-lncurses:-Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
- emake || die "make failed"
-}
-
-src_install() {
- einstall || die
-
- dodir /bin
- mv "${D}"/usr/bin/bash "${D}"/bin/
- [[ ${USERLAND} != "BSD" ]] && dosym bash /bin/sh
- dosym bash /bin/rbash
-
- insinto /etc/bash
- doins "${FILESDIR}"/{bashrc,bash_logout}
- insinto /etc/skel
- for f in bash{_logout,_profile,rc} ; do
- newins "${FILESDIR}"/dot-${f} .${f}
- done
-
- if use build ; then
- rm -rf "${D}"/usr
- else
- doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
- dosym bash.info.gz /usr/share/info/bashref.info.gz
- fi
-}
-
-pkg_preinst() {
- if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
- mkdir -p "${ROOT}"/etc/bash
- mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
- fi
-
- # our bash_logout is just a place holder so dont
- # force users to go through etc-update all the time
- if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
- rm -f "${D}"/etc/bash/bash_logout
- fi
-}
diff --git a/app-shells/bash/bash-3.1_p10.ebuild b/app-shells/bash/bash-3.1_p10.ebuild
deleted file mode 100644
index 7d0f8db7fa9e..000000000000
--- a/app-shells/bash/bash-3.1_p10.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p10.ebuild,v 1.1 2006/02/21 08:56:42 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-# Official patchlevel
-# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-READLINE_VER=5.1
-READLINE_PLEVEL=1
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-# Hit the GNU mirrors before hitting Chet's site
-SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
- ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
- $(for ((i=1; i<=PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- done)
- $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
- ${READLINE_VER} ${READLINE_VER/\.} ${i}
- printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
- ${READLINE_VER} ${READLINE_VER/\.} ${i}
- done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="afs nls build bashlogger unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
-
- # Include official patches
- local i
- for ((i=1; i<=PLEVEL; i++)); do
- epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
- done
- cd lib/readline
- for ((i=1; i<=READLINE_PLEVEL; i++)); do
- epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
- done
- cd ../..
-
- # Fall back to /etc/inputrc
- epatch "${FILESDIR}"/${PN}-3.0-etc-inputrc.patch
- # Add more ulimit options (from Fedora)
- epatch "${FILESDIR}"/${MY_P}-ulimit.patch
- # Fix a memleak in read_builtin (from Fedora)
- epatch "${FILESDIR}"/${PN}-3.0-read-memleak.patch
- # Don't barf on handled signals in scripts
- epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
- # Fix -/bin/bash login shell #118257
- epatch "${FILESDIR}"/bash-3.1-fix-dash-login-shell.patch
-# # Fix generation of signals list when cross-compiling
-# epatch "${FILESDIR}"/${PN}-3.0-cross-signals.patch
- # Log bash commands to syslog #91327
- if use bashlogger ; then
- echo
- ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
- ewarn "This will log ALL output you enter into the shell, you have been warned."
- ebeep
- epause
- epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
- fi
-
- epatch "${FILESDIR}"/${PN}-3.0-configs.patch
-
- sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
-}
-
-src_compile() {
- filter-flags -malign-double
-
- local myconf=
-
- # Always use the buildin readline, else if we update readline
- # bash gets borked as readline is usually not binary compadible
- # between minor versions.
- #myconf="${myconf} $(use_with !readline installed-readline)"
- myconf="${myconf} --without-installed-readline"
-
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to use with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
- use nls || myconf="${myconf} --disable-nls"
-
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses
- export bash_cv_termcap_lib=libcurses
- myconf="${myconf} --with-ncurses"
-
- econf \
- $(use_with afs) \
- --disable-profiling \
- --without-gnu-malloc \
- ${myconf} || die
- emake -j1 || die "make failed" # see bug 102426
-}
-
-src_install() {
- einstall || die
-
- dodir /bin
- mv "${D}"/usr/bin/bash "${D}"/bin/
- [[ ${USERLAND} != "BSD" ]] && dosym bash /bin/sh
- dosym bash /bin/rbash
-
- insinto /etc/bash
- doins "${FILESDIR}"/{bashrc,bash_logout}
- insinto /etc/skel
- for f in bash{_logout,_profile,rc} ; do
- newins "${FILESDIR}"/dot-${f} .${f}
- done
-
- if use build ; then
- rm -rf "${D}"/usr
- else
- doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
- dosym bash.info.gz /usr/share/info/bashref.info.gz
- fi
-}
-
-pkg_preinst() {
- if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
- mkdir -p "${ROOT}"/etc/bash
- mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
- fi
-
- # our bash_logout is just a place holder so dont
- # force users to go through etc-update all the time
- if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
- rm -f "${D}"/etc/bash/bash_logout
- fi
-}
diff --git a/app-shells/bash/bash-3.1_p8.ebuild b/app-shells/bash/bash-3.1_p8.ebuild
deleted file mode 100644
index 83e0dfb44ab7..000000000000
--- a/app-shells/bash/bash-3.1_p8.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p8.ebuild,v 1.1 2006/02/17 12:20:23 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-# Official patchlevel
-# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-READLINE_VER=5.1
-READLINE_PLEVEL=1
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-# Hit the GNU mirrors before hitting Chet's site
-SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
- ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
- $(for ((i=1; i<=PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- done)
- $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
- ${READLINE_VER} ${READLINE_VER/\.} ${i}
- printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
- ${READLINE_VER} ${READLINE_VER/\.} ${i}
- done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="afs nls build bashlogger unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
-
- # Include official patches
- local i
- for ((i=1; i<=PLEVEL; i++)); do
- epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
- done
- cd lib/readline
- for ((i=1; i<=READLINE_PLEVEL; i++)); do
- epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
- done
- cd ../..
-
- # Fall back to /etc/inputrc
- epatch "${FILESDIR}"/${PN}-3.0-etc-inputrc.patch
- # Add more ulimit options (from Fedora)
- epatch "${FILESDIR}"/${MY_P}-ulimit.patch
- # Fix a memleak in read_builtin (from Fedora)
- epatch "${FILESDIR}"/${PN}-3.0-read-memleak.patch
- # Don't barf on handled signals in scripts
- epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
- # Fix -/bin/bash login shell #118257
- epatch "${FILESDIR}"/bash-3.1-fix-dash-login-shell.patch
-# # Fix generation of signals list when cross-compiling
-# epatch "${FILESDIR}"/${PN}-3.0-cross-signals.patch
- # Log bash commands to syslog #91327
- if use bashlogger ; then
- echo
- ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
- ewarn "This will log ALL output you enter into the shell, you have been warned."
- ebeep
- epause
- epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
- fi
-
- epatch "${FILESDIR}"/${PN}-3.0-configs.patch
-
- sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
-}
-
-src_compile() {
- filter-flags -malign-double
-
- local myconf=
-
- # Always use the buildin readline, else if we update readline
- # bash gets borked as readline is usually not binary compadible
- # between minor versions.
- #myconf="${myconf} $(use_with !readline installed-readline)"
- myconf="${myconf} --without-installed-readline"
-
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to use with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
- use nls || myconf="${myconf} --disable-nls"
-
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses
- export bash_cv_termcap_lib=libcurses
- myconf="${myconf} --with-ncurses"
-
- econf \
- $(use_with afs) \
- --disable-profiling \
- --without-gnu-malloc \
- ${myconf} || die
- emake -j1 || die "make failed" # see bug 102426
-}
-
-src_install() {
- einstall || die
-
- dodir /bin
- mv "${D}"/usr/bin/bash "${D}"/bin/
- [[ ${USERLAND} != "BSD" ]] && dosym bash /bin/sh
- dosym bash /bin/rbash
-
- insinto /etc/bash
- doins "${FILESDIR}"/{bashrc,bash_logout}
- insinto /etc/skel
- for f in bash{_logout,_profile,rc} ; do
- newins "${FILESDIR}"/dot-${f} .${f}
- done
-
- if use build ; then
- rm -rf "${D}"/usr
- else
- doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
- dosym bash.info.gz /usr/share/info/bashref.info.gz
- fi
-}
-
-pkg_preinst() {
- if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
- mkdir -p "${ROOT}"/etc/bash
- mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
- fi
-
- # our bash_logout is just a place holder so dont
- # force users to go through etc-update all the time
- if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
- rm -f "${D}"/etc/bash/bash_logout
- fi
-}
diff --git a/app-shells/bash/files/digest-bash-3.0-r11 b/app-shells/bash/files/digest-bash-3.0-r11
deleted file mode 100644
index 3f6ecc696328..000000000000
--- a/app-shells/bash/files/digest-bash-3.0-r11
+++ /dev/null
@@ -1,18 +0,0 @@
-MD5 26c4d642e29b3533d8d754995bc277b3 bash-3.0.tar.gz 2418293
-MD5 220cdd45dc060fd41c2bd7c46e8a9064 bash-3.0-gentoo.diff.bz2 2423
-MD5 24a83f78a44a6029024371f02da174dd bash30-001 4999
-MD5 6f4cf2aa975a1fcc0cb43a406bd47ca5 bash30-002 2119
-MD5 c8bf41e78cda16d391b9099eeba01386 bash30-003 4669
-MD5 c069dffbb3f442aac3660b883ddd97f5 bash30-004 3372
-MD5 ad06309c623ff8e1b9f039d3b7eb97c2 bash30-005 1776
-MD5 f162bf93a76759bab37b29509a4a6e20 bash30-006 4258
-MD5 89903d92ca620921aecb3f1f30c05ebe bash30-007 1808
-MD5 9a295c02f46bc867fc096862c7380a88 bash30-008 1220
-MD5 786c7e2af1dca5104af92bbdc60f7474 bash30-009 2828
-MD5 f2d90d06ed445a285c8406016e9d9c13 bash30-010 3193
-MD5 9506c56968c58332489986633319a186 bash30-011 2635
-MD5 2753d4de0b57fc8890488463c5e86d3f bash30-012 1395
-MD5 5de5be8289764c11a3206b06351d81a6 bash30-013 1963
-MD5 d4b531e02b6a0287cffdbf527134ca29 bash30-014 1165
-MD5 adc1ab952b42ed0c0f53d1c308a32101 bash30-015 1480
-MD5 a3bb09a185e4c6a813227f3e84e4f6e5 bash30-016 2453
diff --git a/app-shells/bash/files/digest-bash-3.1_p10 b/app-shells/bash/files/digest-bash-3.1_p10
deleted file mode 100644
index 89f92f9725b0..000000000000
--- a/app-shells/bash/files/digest-bash-3.1_p10
+++ /dev/null
@@ -1,36 +0,0 @@
-MD5 ef5304c4b22aaa5088972c792ed45d72 bash-3.1.tar.gz 2533934
-RMD160 cbeda56312b3f623684b2099b711bb7592e0eda1 bash-3.1.tar.gz 2533934
-SHA256 d6952b2c38f9bf417559dd3b071860e1099ddfb8a12c0228f22afaf47f79d3b9 bash-3.1.tar.gz 2533934
-MD5 c0d33bdfed6e4e6a9ae9200b77cd5c99 bash31-001 2708
-RMD160 0d071aeade45c1706f4061774bb486d9a2ba7dae bash31-001 2708
-SHA256 3b6d9151ca7a45dbcf43ebd1c6a647ef90c4b8eb54a245936fd6ffadc61fe727 bash31-001 2708
-MD5 0c9be3bad344d04b79c4eac9eb39624c bash31-002 7169
-RMD160 9b03b62c9eb1ba2a574467c6a2950b3b933794e1 bash31-002 7169
-SHA256 ecd248b1ca027368dae967502af5b28019eeee8fa3ee8d6a0210677789658f08 bash31-002 7169
-MD5 04750485f335972f7a980a1bfe048dba bash31-003 1324
-RMD160 1ee18374c2416407d1fa997ed99c5fc7f295cd62 bash31-003 1324
-SHA256 96cb8a42162a5876b2392b76fbfc78d073f50735e1e8a14e67e03b6e9c2b215d bash31-003 1324
-MD5 0c2856794ab16a4c224223c1964140c2 bash31-004 1470
-RMD160 b8182116ca8efc0bec9054694cac54045245a704 bash31-004 1470
-SHA256 a50ecd3f51e9a79f34855c68c61c9523fccb66da0870eade936cc1f64ba04415 bash31-004 1470
-MD5 943233d7227071fa040c8b9eb016fa0c bash31-005 1322
-RMD160 3e2583ebf0e4fc546cdcf8ccf8b987a100f71a7e bash31-005 1322
-SHA256 3b057498f01cb2b528a154b9043261cb059846b23222409f7de95a7971dc6664 bash31-005 1322
-MD5 68a41a9da7c669b4358837d06556a06f bash31-006 1561
-RMD160 608f650ef96c6f0e46395a21d9e30aba42fb33f9 bash31-006 1561
-SHA256 d155030ed49de27812d9ae01211283f7afe5e718ea4ed9babe1f121d25acf778 bash31-006 1561
-MD5 f6ca4950256fefd88d49c5702338e501 bash31-007 3254
-RMD160 ae865a7f4e0cbeb2022004d385c7c9d29dfe07a5 bash31-007 3254
-SHA256 fa89a6c808490e07cd7350ecb3390ce0ae6dc71d634c61c62991aafab97962c4 bash31-007 3254
-MD5 4fd01140cb5875fe020939aab02791f0 bash31-008 1422
-RMD160 9ec2f72649a1955593ab4ad98605ba323747367a bash31-008 1422
-SHA256 c30fe9da56261c7100c5b6794d4341b6b1fb6aa0ecc25b1010ac4ac25b07d1c7 bash31-008 1422
-MD5 37aad0d5aa57881742ec6419faf9e480 bash31-009 2000
-RMD160 443ba0c4cbd81fe4a24d92f213a65c4dbf123053 bash31-009 2000
-SHA256 cfdc6dd92d0f47988ee59e2a26e8e62a87558e03908a26ee33dd0394228ac255 bash31-009 2000
-MD5 91c52d2a51d41d4b6907758952aa0554 bash31-010 5218
-RMD160 9228d25e84180f576892ee6c9c3da8262e201269 bash31-010 5218
-SHA256 7ba8186d5e7de76c5b4e7c8905ad82b3d7cf459141eedc4ebcc6a0ca3b23cfc4 bash31-010 5218
-MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042
-RMD160 93dd36106f68682c4dc73a9b1ecf62bf7943fae4 readline51-001 2042
-SHA256 2c9786b231a454504c3f38361af6fd74e61789bc1009eba5fb2447b5a3ac5774 readline51-001 2042
diff --git a/app-shells/bash/files/digest-bash-3.1_p8 b/app-shells/bash/files/digest-bash-3.1_p8
deleted file mode 100644
index 9bdd931d78f0..000000000000
--- a/app-shells/bash/files/digest-bash-3.1_p8
+++ /dev/null
@@ -1,30 +0,0 @@
-MD5 ef5304c4b22aaa5088972c792ed45d72 bash-3.1.tar.gz 2533934
-RMD160 cbeda56312b3f623684b2099b711bb7592e0eda1 bash-3.1.tar.gz 2533934
-SHA256 d6952b2c38f9bf417559dd3b071860e1099ddfb8a12c0228f22afaf47f79d3b9 bash-3.1.tar.gz 2533934
-MD5 c0d33bdfed6e4e6a9ae9200b77cd5c99 bash31-001 2708
-RMD160 0d071aeade45c1706f4061774bb486d9a2ba7dae bash31-001 2708
-SHA256 3b6d9151ca7a45dbcf43ebd1c6a647ef90c4b8eb54a245936fd6ffadc61fe727 bash31-001 2708
-MD5 0c9be3bad344d04b79c4eac9eb39624c bash31-002 7169
-RMD160 9b03b62c9eb1ba2a574467c6a2950b3b933794e1 bash31-002 7169
-SHA256 ecd248b1ca027368dae967502af5b28019eeee8fa3ee8d6a0210677789658f08 bash31-002 7169
-MD5 04750485f335972f7a980a1bfe048dba bash31-003 1324
-RMD160 1ee18374c2416407d1fa997ed99c5fc7f295cd62 bash31-003 1324
-SHA256 96cb8a42162a5876b2392b76fbfc78d073f50735e1e8a14e67e03b6e9c2b215d bash31-003 1324
-MD5 0c2856794ab16a4c224223c1964140c2 bash31-004 1470
-RMD160 b8182116ca8efc0bec9054694cac54045245a704 bash31-004 1470
-SHA256 a50ecd3f51e9a79f34855c68c61c9523fccb66da0870eade936cc1f64ba04415 bash31-004 1470
-MD5 943233d7227071fa040c8b9eb016fa0c bash31-005 1322
-RMD160 3e2583ebf0e4fc546cdcf8ccf8b987a100f71a7e bash31-005 1322
-SHA256 3b057498f01cb2b528a154b9043261cb059846b23222409f7de95a7971dc6664 bash31-005 1322
-MD5 68a41a9da7c669b4358837d06556a06f bash31-006 1561
-RMD160 608f650ef96c6f0e46395a21d9e30aba42fb33f9 bash31-006 1561
-SHA256 d155030ed49de27812d9ae01211283f7afe5e718ea4ed9babe1f121d25acf778 bash31-006 1561
-MD5 f6ca4950256fefd88d49c5702338e501 bash31-007 3254
-RMD160 ae865a7f4e0cbeb2022004d385c7c9d29dfe07a5 bash31-007 3254
-SHA256 fa89a6c808490e07cd7350ecb3390ce0ae6dc71d634c61c62991aafab97962c4 bash31-007 3254
-MD5 4fd01140cb5875fe020939aab02791f0 bash31-008 1422
-RMD160 9ec2f72649a1955593ab4ad98605ba323747367a bash31-008 1422
-SHA256 c30fe9da56261c7100c5b6794d4341b6b1fb6aa0ecc25b1010ac4ac25b07d1c7 bash31-008 1422
-MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042
-RMD160 93dd36106f68682c4dc73a9b1ecf62bf7943fae4 readline51-001 2042
-SHA256 2c9786b231a454504c3f38361af6fd74e61789bc1009eba5fb2447b5a3ac5774 readline51-001 2042