summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-03-26 13:49:08 +0000
committerTorsten Veller <tove@gentoo.org>2008-03-26 13:49:08 +0000
commit280fe84b80538b4611451ad38dc943906f7f6e92 (patch)
treedcd8cdc9a684da5743a5c50f9183f957ed34aa3f /app-shells/zsh
parentamd64 stable wrt #203752 (diff)
downloadgentoo-2-280fe84b80538b4611451ad38dc943906f7f6e92.tar.gz
gentoo-2-280fe84b80538b4611451ad38dc943906f7f6e92.tar.bz2
gentoo-2-280fe84b80538b4611451ad38dc943906f7f6e92.zip
Cleaning
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/ChangeLog6
-rw-r--r--app-shells/zsh/files/zshenv15
-rw-r--r--app-shells/zsh/zsh-4.3.2-r2.ebuild165
-rw-r--r--app-shells/zsh/zsh-4.3.2-r3.ebuild172
-rw-r--r--app-shells/zsh/zsh-4.3.4.ebuild167
5 files changed, 5 insertions, 520 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 45428539b093..261d7c329ab0 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/zsh
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.130 2008/02/02 22:22:54 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.131 2008/03/26 13:49:07 tove Exp $
+
+ 26 Mar 2008; Torsten Veller <tove@gentoo.org> -files/zshenv,
+ -zsh-4.3.2-r2.ebuild, -zsh-4.3.2-r3.ebuild, -zsh-4.3.4.ebuild:
+ Cleaning
*zsh-4.3.5 (02 Feb 2008)
diff --git a/app-shells/zsh/files/zshenv b/app-shells/zsh/files/zshenv
deleted file mode 100644
index 4d350d569f5a..000000000000
--- a/app-shells/zsh/files/zshenv
+++ /dev/null
@@ -1,15 +0,0 @@
-[[ -o rcs ]] || return 0
-
-[[ -e "/etc/profile.env" ]] && source /etc/profile.env
-
-#077 would be more secure, but 022 is generally quite realistic
-umask 022
-
-if [[ $(/usr/bin/whoami) == 'root' ]]
-then
- export PATH="/bin:/sbin:/usr/bin:/usr/sbin:${ROOTPATH}"
-else
- export PATH="/bin:/usr/bin:${PATH}"
-fi
-unset ROOTPATH
-
diff --git a/app-shells/zsh/zsh-4.3.2-r2.ebuild b/app-shells/zsh/zsh-4.3.2-r2.ebuild
deleted file mode 100644
index c42b62f7c70d..000000000000
--- a/app-shells/zsh/zsh-4.3.2-r2.ebuild
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.2-r2.ebuild,v 1.13 2007/11/06 00:39:19 wolf31o2 Exp $
-
-inherit eutils multilib
-
-LOVERS_PV=0.5
-LOVERS_P=zsh-lovers-${LOVERS_PV}
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
- examples? (
- http://www.grml.org/repos/zsh-lovers_${LOVERS_PV}.orig.tar.gz )
- doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )"
-
-LICENSE="ZSH"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="maildir ncurses static doc examples pcre caps unicode"
-
-RDEPEND="pcre? ( >=dev-libs/libpcre-3.9 )
- caps? ( sys-libs/libcap )
- ncurses? ( >=sys-libs/ncurses-5.1 )"
-DEPEND="sys-apps/groff
- >=sys-apps/sed-4
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-init.d-gentoo.diff
- cd ${S}/Doc
- ln -sf . man1
- # fix zshall problem with soelim
- soelim zshall.1 > zshall.1.soelim
- mv zshall.1.soelim zshall.1
-}
-
-src_compile() {
- local myconf
-
- use static && myconf="${myconf} --disable-dynamic" \
- && LDFLAGS="${LDFLAGS} -static"
-
- econf \
- --bindir=/bin \
- --libdir=/usr/$(get_libdir) \
- --enable-etcdir=/etc/zsh \
- --enable-zshenv=/etc/zsh/zshenv \
- --enable-zlogin=/etc/zsh/zlogin \
- --enable-zlogout=/etc/zsh/zlogout \
- --enable-zprofile=/etc/zsh/zprofile \
- --enable-zshrc=/etc/zsh/zshrc \
- --enable-fndir=/usr/share/zsh/${PV%_*}/functions \
- --enable-site-fndir=/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --enable-ldflags="${LDFLAGS}" \
- --with-tcsetpgrp \
- $(use_with ncurses curses-terminfo) \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps) \
- $(use_enable unicode multibyte) \
- ${myconf} || die "configure failed"
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- sed -i -e "s/link=no/link=static/g" \
- -e "s/load=no/load=yes/g" \
- config.modules || die
-# else
- # avoid linking to libs in /usr/lib, see Bug #27064
-# sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" \
-# Makefile || die
- fi
-
- # emake still b0rks
- emake -j1 || die "make failed"
-}
-
-src_test() {
- for f in /dev/pt* ; do
- addpredict $f
- done
- make check || die "make check failed"
-}
-
-src_install() {
- einstall \
- bindir=${D}/bin \
- libdir=${D}/usr/$(get_libdir) \
- fndir=${D}/usr/share/zsh/${PV%_*}/functions \
- sitefndir=${D}/usr/share/zsh/site-functions \
- scriptdir=${D}/usr/share/zsh/${PV%_*}/scripts \
- install.bin install.man install.modules \
- install.info install.fns || die "make install failed"
-
- insinto /etc/zsh
- doins ${FILESDIR}/zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/${PV%_*}/functions/Prompts
- doins ${FILESDIR}/prompt_gentoo_setup || die
-
- # install miscellaneous scripts; bug #54520
- sed -i -e "s:/usr/local:/usr:g" {Util,Misc}/* || "sed failed"
- insinto /usr/share/zsh/${PV%_*}/Util
- doins Util/* || die "doins Util scripts failed"
- insinto /usr/share/zsh/${PV%_*}/Misc
- doins Misc/* || die "doins Misc scripts failed"
-
- dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
-
- if use doc ; then
- dohtml Doc/*
- insinto /usr/share/doc/${PF}
- doins Doc/zsh.{dvi,pdf}
- fi
-
- if use examples; then
- cd ${WORKDIR}/${LOVERS_P}
- doman zsh-lovers.1 || die "doman zsh-lovers failed"
- dohtml zsh-lovers.html || die "dohtml zsh-lovers failed"
- docinto zsh-lovers
- dodoc zsh.vim README
- insinto /usr/share/doc/${PF}/zsh-lovers
- doins zsh-lovers.{ps,pdf} refcard.{dvi,ps,pdf}
- doins -r zsh_people || die "doins zsh_people failed"
- cd -
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-}
-
-pkg_preinst() {
- # Our zprofile file does the job of the old zshenv file
- # Move the old version into a zprofile script so the normal
- # etc-update process will handle any changes.
- if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
- mv /etc/zsh/zshenv /etc/zsh/zprofile
- fi
-}
-
-pkg_postinst() {
- elog
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/zsh-completion and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- elog
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- elog
- # see Bug 26776
- ewarn
- ewarn "If you are upgrading from zsh-4.0.x you may need to"
- ewarn "remove all your old ~/.zcompdump files in order to use"
- ewarn "completion. For more info see zcompsys manpage."
- ewarn
-}
diff --git a/app-shells/zsh/zsh-4.3.2-r3.ebuild b/app-shells/zsh/zsh-4.3.2-r3.ebuild
deleted file mode 100644
index fa44c0327dc9..000000000000
--- a/app-shells/zsh/zsh-4.3.2-r3.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.2-r3.ebuild,v 1.8 2007/12/11 09:25:56 vapier Exp $
-
-inherit eutils multilib
-
-LOVERS_PV=0.5
-LOVERS_P=zsh-lovers-${LOVERS_PV}
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
- examples? (
- http://www.grml.org/repos/zsh-lovers_${LOVERS_PV}.orig.tar.gz )
- doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )"
-
-LICENSE="ZSH"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="maildir ncurses static doc examples pcre caps unicode"
-
-RDEPEND="pcre? ( >=dev-libs/libpcre-3.9 )
- caps? ( sys-libs/libcap )
- ncurses? ( >=sys-libs/ncurses-5.1 )"
-DEPEND="sys-apps/groff
- >=sys-apps/sed-4
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-init.d-gentoo.diff
-
- # fixes #201022 and
- # http://www.zsh.org/mla/workers/2007/msg01065.html
- rm Util/difflog.pl
-
- cd "${S}"/Doc
- ln -sf . man1
- # fix zshall problem with soelim
- soelim zshall.1 > zshall.1.soelim
- mv zshall.1.soelim zshall.1
-}
-
-src_compile() {
- local myconf
-
- use static && myconf="${myconf} --disable-dynamic" \
- && LDFLAGS="${LDFLAGS} -static"
-
- econf \
- --bindir=/bin \
- --libdir=/usr/$(get_libdir) \
- --enable-etcdir=/etc/zsh \
- --enable-zshenv=/etc/zsh/zshenv \
- --enable-zlogin=/etc/zsh/zlogin \
- --enable-zlogout=/etc/zsh/zlogout \
- --enable-zprofile=/etc/zsh/zprofile \
- --enable-zshrc=/etc/zsh/zshrc \
- --enable-fndir=/usr/share/zsh/${PV%_*}/functions \
- --enable-site-fndir=/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --enable-ldflags="${LDFLAGS}" \
- --with-tcsetpgrp \
- $(use_with ncurses curses-terminfo) \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps) \
- $(use_enable unicode multibyte) \
- ${myconf} || die "configure failed"
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- sed -i -e "s/link=no/link=static/g" \
- -e "s/load=no/load=yes/g" \
- config.modules || die
-# else
- # avoid linking to libs in /usr/lib, see Bug #27064
-# sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" \
-# Makefile || die
- fi
-
- # emake still b0rks
- emake -j1 || die "make failed"
-}
-
-src_test() {
- for f in /dev/pt* ; do
- addpredict $f
- done
- make check || die "make check failed"
-}
-
-src_install() {
- einstall \
- bindir="${D}"/bin \
- libdir="${D}"/usr/$(get_libdir) \
- fndir="${D}"/usr/share/zsh/${PV%_*}/functions \
- sitefndir="${D}"/usr/share/zsh/site-functions \
- scriptdir="${D}"/usr/share/zsh/${PV%_*}/scripts \
- install.bin install.man install.modules \
- install.info install.fns || die "make install failed"
-
- insinto /etc/zsh
- doins "${FILESDIR}"/zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/${PV%_*}/functions/Prompts
- doins "${FILESDIR}"/prompt_gentoo_setup || die
-
- # install miscellaneous scripts; bug #54520
- sed -i -e "s:/usr/local:/usr:g" {Util,Misc}/* || "sed failed"
- insinto /usr/share/zsh/${PV%_*}/Util
- doins Util/* || die "doins Util scripts failed"
- insinto /usr/share/zsh/${PV%_*}/Misc
- doins Misc/* || die "doins Misc scripts failed"
-
- dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
-
- if use doc ; then
- dohtml Doc/*
- insinto /usr/share/doc/${PF}
- doins Doc/zsh.{dvi,pdf}
- fi
-
- if use examples; then
- cd "${WORKDIR}"/${LOVERS_P}
- doman zsh-lovers.1 || die "doman zsh-lovers failed"
- dohtml zsh-lovers.html || die "dohtml zsh-lovers failed"
- docinto zsh-lovers
- dodoc zsh.vim README
- insinto /usr/share/doc/${PF}/zsh-lovers
- doins zsh-lovers.{ps,pdf} refcard.{dvi,ps,pdf}
- doins -r zsh_people || die "doins zsh_people failed"
- cd -
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-}
-
-pkg_preinst() {
- # Our zprofile file does the job of the old zshenv file
- # Move the old version into a zprofile script so the normal
- # etc-update process will handle any changes.
- if [ -f "${ROOT}/etc/zsh/zshenv" -a ! -f "${ROOT}/etc/zsh/zprofile" ]; then
- ewarn "Renaming /etc/zsh/zshenv to /etc/zsh/zprofile."
- ewarn "The zprofile file does the job of the old zshenv file."
- mv "${ROOT}"/etc/zsh/{zshenv,zprofile}
- fi
-}
-
-pkg_postinst() {
- elog
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/zsh-completion and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- elog
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- elog
- # see Bug 26776
- ewarn
- ewarn "If you are upgrading from zsh-4.0.x you may need to"
- ewarn "remove all your old ~/.zcompdump files in order to use"
- ewarn "completion. For more info see zcompsys manpage."
- ewarn
-}
diff --git a/app-shells/zsh/zsh-4.3.4.ebuild b/app-shells/zsh/zsh-4.3.4.ebuild
deleted file mode 100644
index b1c5ea61c267..000000000000
--- a/app-shells/zsh/zsh-4.3.4.ebuild
+++ /dev/null
@@ -1,167 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.4.ebuild,v 1.4 2007/11/06 00:39:19 wolf31o2 Exp $
-
-inherit eutils multilib autotools
-
-LOVERS_PV=0.5
-LOVERS_P=zsh-lovers-${LOVERS_PV}
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
- examples? (
- http://www.grml.org/repos/zsh-lovers_${LOVERS_PV}.orig.tar.gz )
- doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )"
-
-LICENSE="ZSH"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="maildir static doc examples pcre caps unicode"
-
-RDEPEND=">=sys-libs/ncurses-5.1
- caps? ( sys-libs/libcap )
- pcre? ( >=dev-libs/libpcre-3.9 )"
-DEPEND="sys-apps/groff
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # fix zshall problem with soelim
- ln -s Doc man1
- mv Doc/zshall.1 Doc/zshall.1.soelim
- soelim Doc/zshall.1.soelim > Doc/zshall.1
-
- epatch "${FILESDIR}/${PN}"-init.d-gentoo.diff
- epatch "${FILESDIR}/${P}"-configure-changequote.patch
- eautoreconf
-}
-
-src_compile() {
- local myconf=
-
- if use static ; then
- myconf="${myconf} --disable-dynamic"
- LDFLAGS="${LDFLAGS} -static"
- fi
-
- econf \
- --bindir=/bin \
- --libdir=/usr/$(get_libdir) \
- --enable-etcdir=/etc/zsh \
- --enable-zshenv=/etc/zsh/zshenv \
- --enable-zlogin=/etc/zsh/zlogin \
- --enable-zlogout=/etc/zsh/zlogout \
- --enable-zprofile=/etc/zsh/zprofile \
- --enable-zshrc=/etc/zsh/zshrc \
- --enable-fndir=/usr/share/zsh/${PV%_*}/functions \
- --enable-site-fndir=/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --enable-ldflags="${LDFLAGS}" \
- --enable-curses-terminfo \
- --with-tcsetpgrp \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps) \
- $(use_enable unicode multibyte) \
- ${myconf} || die "configure failed"
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- sed -i -e "s/link=no/link=static/g" \
- -e "s/load=no/load=yes/g" \
- config.modules || die
-# else
-# sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" Makefile
- fi
-
- emake || die "make failed"
-}
-
-src_test() {
- local f=
- for f in /dev/pt* ; do
- addpredict "$f"
- done
- make check || die "make check failed"
-}
-
-src_install() {
- einstall \
- bindir="${D}"/bin \
- libdir="${D}"/usr/$(get_libdir) \
- fndir="${D}"/usr/share/zsh/${PV%_*}/functions \
- sitefndir="${D}"/usr/share/zsh/site-functions \
- scriptdir="${D}"/usr/share/zsh/${PV%_*}/scripts \
- install.bin install.man install.modules \
- install.info install.fns || die "make install failed"
-
- insinto /etc/zsh
- doins "${FILESDIR}"/zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/${PV%_*}/functions/Prompts
- doins "${FILESDIR}"/prompt_gentoo_setup || die
-
- # install miscellaneous scripts; bug #54520
- sed -i -e "s:/usr/local:/usr:g" {Util,Misc}/* || "sed failed"
- insinto /usr/share/zsh/${PV%_*}/Util
- doins Util/* || die "doins Util scripts failed"
- insinto /usr/share/zsh/${PV%_*}/Misc
- doins Misc/* || die "doins Misc scripts failed"
-
- dodoc ChangeLog* META-FAQ README config.modules
-
- if use doc ; then
- dohtml Doc/*
- insinto /usr/share/doc/${PF}
- doins Doc/zsh.{dvi,pdf}
- fi
-
- if use examples; then
- cd "${WORKDIR}/${LOVERS_P}"
- doman zsh-lovers.1 || die "doman zsh-lovers failed"
- dohtml zsh-lovers.html || die "dohtml zsh-lovers failed"
- docinto zsh-lovers
- dodoc zsh.vim README
- insinto /usr/share/doc/"${PF}"/zsh-lovers
- doins zsh-lovers.{ps,pdf} refcard.{dvi,ps,pdf}
- doins -r zsh_people || die "doins zsh_people failed"
- cd -
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-}
-
-pkg_preinst() {
- # Our zprofile file does the job of the old zshenv file
- # Move the old version into a zprofile script so the normal
- # etc-update process will handle any changes.
- if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
- mv /etc/zsh/zshenv /etc/zsh/zprofile
- fi
-}
-
-pkg_postinst() {
- elog
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/zsh-completion and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- elog
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- elog
- # see Bug 26776
- ewarn
- ewarn "If you are upgrading from zsh-4.0.x you may need to"
- ewarn "remove all your old ~/.zcompdump files in order to use"
- ewarn "completion. For more info see zcompsys manpage."
- ewarn
-}