summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-29 04:00:30 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-29 04:00:30 +0000
commitdb4e9a782d8fa5934da35bdc6b3197df1fd84e61 (patch)
treecd54595451e461d2b67c30d23aa44fe3518b4ca2 /app-shells/tcsh
parentchange virtual/glibc to virtual/libc (Manifest recommit) (diff)
downloadgentoo-2-db4e9a782d8fa5934da35bdc6b3197df1fd84e61.tar.gz
gentoo-2-db4e9a782d8fa5934da35bdc6b3197df1fd84e61.tar.bz2
gentoo-2-db4e9a782d8fa5934da35bdc6b3197df1fd84e61.zip
change virtual/glibc to virtual/libc
Diffstat (limited to 'app-shells/tcsh')
-rw-r--r--app-shells/tcsh/tcsh-6.11.ebuild25
-rw-r--r--app-shells/tcsh/tcsh-6.12-r2.ebuild17
-rw-r--r--app-shells/tcsh/tcsh-6.12-r3.ebuild6
3 files changed, 22 insertions, 26 deletions
diff --git a/app-shells/tcsh/tcsh-6.11.ebuild b/app-shells/tcsh/tcsh-6.11.ebuild
index d378605d7e0b..c9b9dee289f7 100644
--- a/app-shells/tcsh/tcsh-6.11.ebuild
+++ b/app-shells/tcsh/tcsh-6.11.ebuild
@@ -1,36 +1,33 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.11.ebuild,v 1.13 2004/06/24 22:26:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.11.ebuild,v 1.14 2004/06/29 04:00:06 vapier Exp $
-IUSE="perl"
+inherit eutils
S=${WORKDIR}/${P}.00
DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="http://www.tcsh.org/"
SRC_URI="ftp://ftp.gw.com/pub/unix/tcsh/${P}.tar.gz
ftp://ftp.astron.com/pub/tcsh/${P}.tar.gz
ftp://ftp.funet.fi/pub/unix/shells/tcsh/${P}.tar.gz"
-HOMEPAGE="http://www.tcsh.org/"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1
- perl? ( dev-lang/perl )"
-
-HOMEPAGE="http://www.tcsh.org/"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="x86 ppc sparc"
+IUSE="perl"
+
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.1
+ perl? ( dev-lang/perl )"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff || die
+ epatch ${FILESDIR}/${P}-tc.os.h-gentoo.diff
}
src_compile() {
-
- econf \
- --prefix=/ || die
-
+ econf --prefix=/ || die
emake || die
}
diff --git a/app-shells/tcsh/tcsh-6.12-r2.ebuild b/app-shells/tcsh/tcsh-6.12-r2.ebuild
index 75004b7710f2..85da9fe1cd81 100644
--- a/app-shells/tcsh/tcsh-6.12-r2.ebuild
+++ b/app-shells/tcsh/tcsh-6.12-r2.ebuild
@@ -1,18 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.12-r2.ebuild,v 1.11 2004/06/24 22:26:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.12-r2.ebuild,v 1.12 2004/06/29 04:00:06 vapier Exp $
+
+inherit eutils
MY_P="${PN}-${PV}.00"
DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
-SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz"
HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc alpha ia64 amd64 hppa"
+KEYWORDS="x86 ~ppc sparc alpha hppa amd64 ia64"
IUSE="cjk perl"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
>=sys-libs/ncurses-5.1
perl? ( dev-lang/perl )"
@@ -21,11 +23,8 @@ S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff || die
- if use cjk
- then
- patch -p0 < ${FILESDIR}/tcsh_enable_kanji.diff || die
- fi
+ epatch ${FILESDIR}/${P}-tc.os.h-gentoo.diff
+ use cjk && epatch ${FILESDIR}/tcsh_enable_kanji.diff
}
src_compile() {
diff --git a/app-shells/tcsh/tcsh-6.12-r3.ebuild b/app-shells/tcsh/tcsh-6.12-r3.ebuild
index 7651410b9afa..9f491c401f3f 100644
--- a/app-shells/tcsh/tcsh-6.12-r3.ebuild
+++ b/app-shells/tcsh/tcsh-6.12-r3.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.12-r3.ebuild,v 1.7 2004/06/24 22:26:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.12-r3.ebuild,v 1.8 2004/06/29 04:00:06 vapier Exp $
inherit eutils
MY_P="${PN}-${PV}.00"
DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
-SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz"
HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha arm hppa amd64 ia64 ppc64"
IUSE="cjk perl"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
>=sys-libs/ncurses-5.1
perl? ( dev-lang/perl )"