summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-01-18 15:56:29 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-01-18 15:56:29 +0000
commitb19fb790eebe2139e44a474298c6bae265cd4169 (patch)
tree14ce1da217a9f069ae32464b7710340ff9dd7bb7 /app-shells/fish
parentMissed a \ (diff)
downloadgentoo-2-b19fb790eebe2139e44a474298c6bae265cd4169.tar.gz
gentoo-2-b19fb790eebe2139e44a474298c6bae265cd4169.tar.bz2
gentoo-2-b19fb790eebe2139e44a474298c6bae265cd4169.zip
(#161476) Bump. (#151900) Install to /bin so it's usable as a default shell when /usr is unavailable. Still needs an entry in /etc/shells, though. Use emake for install instead of make, so MAKEOPTS gets passed through. Seems to work fine in parallel.
(Portage version: 2.1.2)
Diffstat (limited to 'app-shells/fish')
-rw-r--r--app-shells/fish/ChangeLog12
-rw-r--r--app-shells/fish/files/digest-fish-1.22.23
-rw-r--r--app-shells/fish/fish-1.22.2.ebuild48
3 files changed, 61 insertions, 2 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index e61ce8bc6d41..d6082fd022b5 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/fish
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.26 2006/12/02 01:47:39 antarus Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.27 2007/01/18 15:56:29 dberkholz Exp $
+
+*fish-1.22.2 (18 Jan 2007)
+
+ 18 Jan 2007; Donnie Berkholz <dberkholz@gentoo.org>; +fish-1.22.2.ebuild:
+ (#161476) Bump. (#151900) Install to /bin so it's usable as a default shell
+ when /usr is unavailable. Still needs an entry in /etc/shells, though. Use
+ emake for install instead of make, so MAKEOPTS gets passed through. Seems to
+ work fine in parallel.
02 Dec 2006; Alec Warner <antarus@gentoo.org> fish-1.21.8.ebuild,
fish-1.21.12.ebuild, fish-1.22.1.ebuild:
diff --git a/app-shells/fish/files/digest-fish-1.22.2 b/app-shells/fish/files/digest-fish-1.22.2
new file mode 100644
index 000000000000..efa173155088
--- /dev/null
+++ b/app-shells/fish/files/digest-fish-1.22.2
@@ -0,0 +1,3 @@
+MD5 4009d786d26884a1dc06bf7547434dc7 fish-1.22.2.tar.bz2 719445
+RMD160 c3e59794e35c0af85ad923af79e543db21ac8f76 fish-1.22.2.tar.bz2 719445
+SHA256 9af58871ee80ea0b80f15e5d2d95957973b2cc6a2f3f8a61b518cd55b561add0 fish-1.22.2.tar.bz2 719445
diff --git a/app-shells/fish/fish-1.22.2.ebuild b/app-shells/fish/fish-1.22.2.ebuild
new file mode 100644
index 000000000000..63cbde7c1da4
--- /dev/null
+++ b/app-shells/fish/fish-1.22.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-1.22.2.ebuild,v 1.1 2007/01/18 15:56:29 dberkholz Exp $
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.org/"
+SRC_URI="http://fishshell.org/files/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc X"
+RDEPEND="sys-libs/ncurses
+ sys-devel/bc
+ www-client/htmlview
+ X? ( x11-misc/xsel )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir=/usr/share/doc/${PF} \
+ --without-xsel \
+ --bindir=/bin \
+ || die "econf failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use ${PN} as your default shell, you need to add /bin/${PN}"
+ einfo "to /etc/shells."
+ einfo
+ ewarn "Many files moved to ${ROOT}usr/share/fish/completions from /etc/fish.d/."
+ ewarn "Delete everything in ${ROOT}etc/fish.d/ except fish_interactive.fish."
+ ewarn "Otherwise, fish won't notice updates to the installed files,"
+ ewarn "because the ones in /etc will override the new ones in /usr."
+ einfo
+}